conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void *)0)' failed.)

Bug #19890 reported by Debian Bug Importer on 2005-08-17
6
Affects Status Importance Assigned to Milestone
freeglut (Debian)
New
Unknown
freeglut (Ubuntu)
Medium
Unassigned

Bug Description

Automatically imported from Debian bug report #320375 http://bugs.debian.org/320375

Revision history for this message
In , Clint Adams (clint) wrote : Re: Bug#320375: conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void *)0)' failed.)

reassign 320375 freeglut3
thanks

> severity to grave. If it works for others, please lover the severity
> to important or normal.

It works for me on i386 and sparc.

> This it the output I get:
>
> % conquestgl
> conquestgl: freeglut_window.c:300: fgOpenWindow: Assertion
> `window->Window.VisualInfo != ((void *)0)' failed.
> Abort (SIGABRT)
> %

The error is coming from freeglut3. I'm not sure if this indicates a
bug in freeglut or a failure of conquest to set something up properly in
your case. I hope that the freeglut maintainer can assess this
properly, and reassign back to conquest-gl if appropriate.

Revision history for this message
In , Jamie Wilkinson (jaq-spacepants) wrote : Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void *)0)' failed.)

That assertion looks similar to those that occur when glutInit has not been
called; if that's not the case, then please hold out for the new version of
freeglut that I will be uploading soon, which among other fixes, reduces the
severity of assertions throughout the code.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #320375 http://bugs.debian.org/320375

Revision history for this message
Debian Bug Importer (debzilla) wrote :
Download full text (8.6 KiB)

Message-Id: <email address hidden>
Date: Thu, 28 Jul 2005 23:52:16 +0200
From: Petter Reinholdtsen <email address hidden>
To: <email address hidden>
Subject: Re: conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void *)0)'
 failed.)

Package: conquest-gl
Version: 8.1-2
Severity: grave
Justification: renders package unusable

When I try to start conquestgl on my sarge installation, I only get an
assertion error. This render the package completely useless. As I
suspect this will be the case for all users of the package, I set the
severity to grave. If it works for others, please lover the severity
to important or normal.

This it the output I get:

  % conquestgl
  conquestgl: freeglut_window.c:300: fgOpenWindow: Assertion
    `window->Window.VisualInfo != ((void *)0)' failed.
  Abort (SIGABRT)
  %

Running it in gdb give me this backtrace:

  (gdb) bt
  #0 0x404c683b in raise () from /lib/tls/libc.so.6
  #1 0x404c7fa2 in abort () from /lib/tls/libc.so.6
  #2 0x404c02df in __assert_fail () from /lib/tls/libc.so.6
  #3 0x40198523 in fgOpenWindow () from /usr/lib/libglut.so.3
  #4 0x40196d69 in fgCreateWindow () from /usr/lib/libglut.so.3
  #5 0x40198674 in glutCreateWindow () from /usr/lib/libglut.so.3
  #6 0x40032b42 in uiGLInit () from /usr/lib/libUiGL.so.1
  #7 0x080494a1 in ?? ()
  #8 0xbffff840 in ?? ()
  #9 0xbffff8c4 in ?? ()
  #10 0x08049c01 in _IO_stdin_used ()
  #11 0x08048ae5 in _init ()
  #12 0x404b3974 in __libc_start_main () from /lib/tls/libc.so.6
  #13 0x08048d11 in ?? ()

Running it in valgrind to now show any interesting messages. I
include the end of the strace as well at the end.

In case this has anything to do with my OpenGL support, here is the
output from glxinfo. I do get glxgears and most other OpenGL
applications working, so I believe the OpenGL support should be OK.

% glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: VA Linux, Inc
OpenGL renderer string: Mesa DRI Intel(R) 830M 20021115
OpenGL version string: 1.2 Mesa 4.0.4
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_transpose_matrix, GL_EXT_abgr,
    GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_convolution, GL_EXT_compiled_vertex_array, GL_EXT_fog_coord,
    GL_EXT_histogram, GL_EXT_packed_pixels, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color, GL_EXT_texture3D,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine, GL_EXT_texture_object,
    GL_EXT_texture_lod_bias, GL_EXT_vertex_array, GL_IBM_rasterpos_clip,
    GL_MESA_window_pos, GL_NV_texgen_reflection, GL_SGI_color_matrix,
    GL_S...

Read more...

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 29 Jul 2005 09:46:36 -0400
From: Clint Adams <email address hidden>
To: Petter Reinholdtsen <email address hidden>, <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#320375: conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void
 *)0)' failed.)

reassign 320375 freeglut3
thanks

> severity to grave. If it works for others, please lover the severity
> to important or normal.

It works for me on i386 and sparc.

> This it the output I get:
>
> % conquestgl
> conquestgl: freeglut_window.c:300: fgOpenWindow: Assertion
> `window->Window.VisualInfo != ((void *)0)' failed.
> Abort (SIGABRT)
> %

The error is coming from freeglut3. I'm not sure if this indicates a
bug in freeglut or a failure of conquest to set something up properly in
your case. I hope that the freeglut maintainer can assess this
properly, and reassign back to conquest-gl if appropriate.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 30 Jul 2005 10:59:20 +1000
From: Jamie Wilkinson <email address hidden>
To: <email address hidden>
Cc: Clint Adams <email address hidden>
Subject: Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion
 `window->Window.VisualInfo != ((void *)0)' failed.)

That assertion looks similar to those that occur when glutInit has not been
called; if that's not the case, then please hold out for the new version of
freeglut that I will be uploading soon, which among other fixes, reduces the
severity of assertions throughout the code.

Revision history for this message
In , Jamie Wilkinson (jaq-spacepants) wrote : reassign 320375 to conquest-gl

# Automatically generated email from bts, devscripts version 2.9.5
reassign 320375 conquest-gl

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 23 Aug 2005 14:19:51 +1000
From: Jamie Wilkinson <email address hidden>
To: <email address hidden>
Subject: reassign 320375 to conquest-gl

# Automatically generated email from bts, devscripts version 2.9.5
reassign 320375 conquest-gl

Revision history for this message
In , Clint Adams (clint) wrote : Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void *)0)' failed.)

> That assertion looks similar to those that occur when glutInit has not been
> called; if that's not the case, then please hold out for the new version of
> freeglut that I will be uploading soon, which among other fixes, reduces the
> severity of assertions throughout the code.

It seems impossible that glutInit() would not have been called. What
now?

Revision history for this message
In , Jamie Wilkinson (jaq-spacepants) wrote :

This one time, at band camp, Clint Adams wrote:
>> That assertion looks similar to those that occur when glutInit has not been
>> called; if that's not the case, then please hold out for the new version of
>> freeglut that I will be uploading soon, which among other fixes, reduces the
>> severity of assertions throughout the code.
>
>It seems impossible that glutInit() would not have been called. What
>now?

I hate to sound patronising, but does glutInit definitely get called before
any other glut call?

I'll prepare an upload of freeglut 2.4 Real Soon Now, and then we'll see if
the assertion still appears.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 24 Aug 2005 20:25:41 -0400
From: Clint Adams <email address hidden>
To: Jamie Wilkinson <email address hidden>
Cc: <email address hidden>
Subject: Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion
 `window->Window.VisualInfo != ((void *)0)' failed.)

> That assertion looks similar to those that occur when glutInit has not been
> called; if that's not the case, then please hold out for the new version of
> freeglut that I will be uploading soon, which among other fixes, reduces the
> severity of assertions throughout the code.

It seems impossible that glutInit() would not have been called. What
now?

Revision history for this message
In , Clint Adams (clint) wrote :

> I hate to sound patronising, but does glutInit definitely get called before
> any other glut call?

Seems pretty unconditional here. You're welcome to look at the source.

> I'll prepare an upload of freeglut 2.4 Real Soon Now, and then we'll see if
> the assertion still appears.

I'll pass it back for now.

Revision history for this message
In , Clint Adams (clint) wrote : conquest/freeglut fun

reassign 320375 freeglut3
quit

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 25 Aug 2005 11:54:51 +1000
From: Jamie Wilkinson <email address hidden>
To: Clint Adams <email address hidden>
Cc: <email address hidden>
Subject: Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion
 `window->Window.VisualInfo != ((void *)0)' failed.)

This one time, at band camp, Clint Adams wrote:
>> That assertion looks similar to those that occur when glutInit has not been
>> called; if that's not the case, then please hold out for the new version of
>> freeglut that I will be uploading soon, which among other fixes, reduces the
>> severity of assertions throughout the code.
>
>It seems impossible that glutInit() would not have been called. What
>now?

I hate to sound patronising, but does glutInit definitely get called before
any other glut call?

I'll prepare an upload of freeglut 2.4 Real Soon Now, and then we'll see if
the assertion still appears.

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 24 Aug 2005 23:02:48 -0400
From: Clint Adams <email address hidden>
To: <email address hidden>
Subject: conquest/freeglut fun

reassign 320375 freeglut3
quit

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 24 Aug 2005 23:02:22 -0400
From: Clint Adams <email address hidden>
To: Jamie Wilkinson <email address hidden>
Cc: <email address hidden>
Subject: Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion
 `window->Window.VisualInfo != ((void *)0)' failed.)

> I hate to sound patronising, but does glutInit definitely get called before
> any other glut call?

Seems pretty unconditional here. You're welcome to look at the source.

> I'll prepare an upload of freeglut 2.4 Real Soon Now, and then we'll see if
> the assertion still appears.

I'll pass it back for now.

Revision history for this message
In , Jamie Wilkinson (jaq-spacepants) wrote : Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void *)0)' failed.)

This one time, at band camp, Clint Adams wrote:
>> I hate to sound patronising, but does glutInit definitely get called before
>> any other glut call?
>
>Seems pretty unconditional here. You're welcome to look at the source.
>
>> I'll prepare an upload of freeglut 2.4 Real Soon Now, and then we'll see if
>> the assertion still appears.
>
>I'll pass it back for now.

freeglut 2.4.0 is in testing; do either of you see this bug still?

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 17 Nov 2005 10:12:07 +1100
From: Jamie Wilkinson <email address hidden>
To: Clint Adams <email address hidden>
Cc: <email address hidden>
Subject: Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion
 `window->Window.VisualInfo != ((void *)0)' failed.)

This one time, at band camp, Clint Adams wrote:
>> I hate to sound patronising, but does glutInit definitely get called before
>> any other glut call?
>
>Seems pretty unconditional here. You're welcome to look at the source.
>
>> I'll prepare an upload of freeglut 2.4 Real Soon Now, and then we'll see if
>> the assertion still appears.
>
>I'll pass it back for now.

freeglut 2.4.0 is in testing; do either of you see this bug still?

Revision history for this message
In , Robert Auch (rauch-empire-today) wrote : Re: Processed: Re: Bug#320375: conquest-gl: fail to start (Assertion `window->Window.VisualInfo != ((void *)0)' failed.)

I'm getting this in Debian Etch 2.6.12 (custom) freeglut3 2.4.0-4 with
conquest-gl as well. Let me know what else I can provide.

freeglut (conquestgl): ERROR: Internal error <Visual with necessary
capabilities not found> in function fgOpenWindow
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 4 (X_DestroyWindow)
  Resource id in failed request: 0x0
  Serial number of failed request: 29
  Current serial number in output stream: 33

I can run other OpenGL apps without issue (slune, tuxkart, torcs),
glxinfo shows that DRI is working fine, best as I can tell. not a very
knowledgeable *nix guy yet though.

--
Robert Auch
Senior Systems Administrator
Empire Today, LLC
mailto:<email address hidden>

Revision history for this message
Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Wed, 28 Dec 2005 11:40:59 -0600
From: Robert Auch <email address hidden>
To: <email address hidden>
Subject: Re: Processed: Re: Bug#320375: conquest-gl: fail to start
 (Assertion `window->Window.VisualInfo != ((void *)0)' failed.)

I'm getting this in Debian Etch 2.6.12 (custom) freeglut3 2.4.0-4 with
conquest-gl as well. Let me know what else I can provide.

freeglut (conquestgl): ERROR: Internal error <Visual with necessary
capabilities not found> in function fgOpenWindow
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 4 (X_DestroyWindow)
  Resource id in failed request: 0x0
  Serial number of failed request: 29
  Current serial number in output stream: 33

I can run other OpenGL apps without issue (slune, tuxkart, torcs),
glxinfo shows that DRI is working fine, best as I can tell. not a very
knowledgeable *nix guy yet though.

--
Robert Auch
Senior Systems Administrator
Empire Today, LLC
mailto:<email address hidden>

Revision history for this message
In , Bill Allombert (allomber) wrote :

On Thu, Jul 28, 2005 at 11:52:16PM +0200, Petter Reinholdtsen wrote:
> Package: conquest-gl
> Version: 8.1-2
> Severity: grave
> Justification: renders package unusable
>
> When I try to start conquestgl on my sarge installation, I only get an
> assertion error. This render the package completely useless. As I
> suspect this will be the case for all users of the package, I set the
> severity to grave. If it works for others, please lover the severity
> to important or normal.
>
> This it the output I get:
>
> % conquestgl
> conquestgl: freeglut_window.c:300: fgOpenWindow: Assertion
> `window->Window.VisualInfo != ((void *)0)' failed.
> Abort (SIGABRT)

Hello Petter,

Can you reproduce this problem on Sid or Etch ?

On sarge I get:
   % conquestgl
   conquestgl: freeglut_window.c:300: fgOpenWindow: Assertion
     `window->Window.VisualInfo != ((void *)0)' failed.
   Abort (SIGABRT)

Once upgrading (only) freeglut3 to 2.4.0-5, I get
freeglut (conquestgl): ERROR: Internal error <Visual with necessary
capabilities not found> in function fgOpenWindow
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 4 (X_DestroyWindow)
  Resource id in failed request: 0x0
  Serial number of failed request: 29
  Current serial number in output stream: 33

Once upgrading (only) conquest-gl to 8.1.2-2 I get

conquestgl: symbol lookup error: conquestgl: undefined symbol: dspInitData

Cheers,
--
Bill. <email address hidden>

Imagine a large red swirl here.

Revision history for this message
In , Bill Allombert (allomber) wrote :

On Fri, Apr 21, 2006 at 07:34:32PM +0200, Bill Allombert wrote:
> Once upgrading (only) freeglut3 to 2.4.0-5, I get
> freeglut (conquestgl): ERROR: Internal error <Visual with necessary
> capabilities not found> in function fgOpenWindow
> X Error of failed request: BadWindow (invalid Window parameter)
> Major opcode of failed request: 4 (X_DestroyWindow)
> Resource id in failed request: 0x0
> Serial number of failed request: 29
> Current serial number in output stream: 33
>
> Once upgrading (only) conquest-gl to 8.1.2-2 I get
>
> conquestgl: symbol lookup error: conquestgl: undefined symbol: dspInitData

After upgrading conquest-libs to 8.1.2-2 I get:

freeglut (conquestgl): ERROR: Internal error <Visual with necessary capabilities not found> in function fgOpenWindow
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 4 (X_DestroyWindow)
  Resource id in failed request: 0x0
  Serial number of failed request: 23
  Current serial number in output stream: 26

So it seems conquest-gl need a versionned dependency on conquest-libs
(or conquest-libs shlibdeps should be bumped) to allow for partial
upgrades.

The code before this error:
GL.c:962

  glutInit(argc, argv);
  glutInitDisplayMode(GLUT_DEPTH | GLUT_DOUBLE | GLUT_RGBA | GLUT_ALPHA);

  glutInitWindowPosition(0,0);

  glutInitWindowSize(dConf.initWidth, dConf.initHeight);

  dConf.mainw = glutCreateWindow(CONQUESTGL_NAME);

Removing GLUT_ALPHA from glutInitDisplayMode in this file allow to
bypass the error message and get a window. (I am not sure whether
conquestgl really work but it does not crash).

According to the OPENGL GLUT spec:

   GLUT_ALPHA
          Bit mask to select a window with an alpha component to the
          color buffer(s).

So Jamie, does the error means that my GL driver does not support
alpha transparency, or is it a bug in freeglut ?

You can try the testcase I attached.

Cheers,
--
Bill. <email address hidden>

Imagine a large red swirl here.

Revision history for this message
In , Bill Allombert (allomber) wrote :
Download full text (3.7 KiB)

severity 320375 normal
retitle 320375 conquest-gl: require visual with at least 1bit of alpha channel
quit

On Fri, Apr 21, 2006 at 11:37:39PM +0200, <email address hidden> wrote:
> On Fri, Apr 21, 2006 at 07:34:32PM +0200, Bill Allombert wrote:
> > Once upgrading (only) freeglut3 to 2.4.0-5, I get
> > freeglut (conquestgl): ERROR: Internal error <Visual with necessary
> > capabilities not found> in function fgOpenWindow
> > X Error of failed request: BadWindow (invalid Window parameter)
> > Major opcode of failed request: 4 (X_DestroyWindow)
> > Resource id in failed request: 0x0
> > Serial number of failed request: 29
> > Current serial number in output stream: 33
> >
> > Once upgrading (only) conquest-gl to 8.1.2-2 I get
> >
> > conquestgl: symbol lookup error: conquestgl: undefined symbol: dspInitData
>
> After upgrading conquest-libs to 8.1.2-2 I get:
>
> freeglut (conquestgl): ERROR: Internal error <Visual with necessary capabilities not found> in function fgOpenWindow
> X Error of failed request: BadWindow (invalid Window parameter)
> Major opcode of failed request: 4 (X_DestroyWindow)
> Resource id in failed request: 0x0
> Serial number of failed request: 23
> Current serial number in output stream: 26
>
> So it seems conquest-gl need a versionned dependency on conquest-libs
> (or conquest-libs shlibdeps should be bumped) to allow for partial
> upgrades.
>
> The code before this error:
> GL.c:962
>
> glutInit(argc, argv);
> glutInitDisplayMode(GLUT_DEPTH | GLUT_DOUBLE | GLUT_RGBA | GLUT_ALPHA);
>
> glutInitWindowPosition(0,0);
>
> glutInitWindowSize(dConf.initWidth, dConf.initHeight);
>
> dConf.mainw = glutCreateWindow(CONQUESTGL_NAME);
>
> Removing GLUT_ALPHA from glutInitDisplayMode in this file allow to
> bypass the error message and get a window. (I am not sure whether
> conquestgl really work but it does not crash).
>
> According to the OPENGL GLUT spec:
>
> GLUT_ALPHA
> Bit mask to select a window with an alpha component to the
> color buffer(s).
>
> So Jamie, does the error means that my GL driver does not support
> alpha transparency, or is it a bug in freeglut ?

By looking at the code, glutInitDisplayMode call
glXChooseVisual with attribute GLX_ALPHA_SIZE=1 which according to
glXChooseVisual manpage do

  glXChooseVisual returns a pointer to an XVisualInfo structure describing
  the visual that best meets a minimum specification. The boolean GLX
  attributes of the visual that is returned will match the specified
  values, and the integer GLX attributes will meet or exceed the specified
  minimum values. If all other attributes are equivalent, then TrueColor
  and PseudoColor visuals have priority over DirectColor and StaticColor
  visuals, respectively. If no conforming visual exists, NULL is returned.

  GLX_ALPHA_SIZE
      Must be followed by a nonnegative minimum size specification. If
      this value is zero, the smallest available alpha buffer is
      preferred. Otherwise, the largest available alpha buffer of at least
      the minimum size is preferred.

This means that conquest-gl require a visual with at least on bit...

Read more...

Revision history for this message
Barry deFreese (bddebian) wrote :

I can't reproduce this on an up-to-date Dapper install. Can anyone else? Thanks.

Changed in freeglut:
status: Unconfirmed → Needs Info
Changed in freeglut:
status: Incomplete → Invalid
Revision history for this message
chris nolan (chrisnolan1221) wrote :

The thing is that there is an exemption of the source code which is causing this and it might be possible that the Windows network server is not getting connected. The driver has to be updated. There might be a problem of the script transmission as well, so you can check https://www.oniton.com/blog/microsoft-compatibility-telemetry-windows10/ on it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.