WARNING: at /build/buildd/linux-2.6.32/arch/x86/kernel/hpet.c:392 hpet_next_event+0x7a/0x90()

Reported by Lukas Koranda on 2010-03-27
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
linux (Ubuntu)
Undecided
Tim Gardner
Nominated for Lucid by Lukas Koranda
Nominated for Maverick by Lukas Koranda

Bug Description

Following happens during boot.

Mar 27 20:51:37 LKNB kernel: [ 1.969804] ------------[ cut here ]------------
Mar 27 20:51:37 LKNB kernel: [ 1.969813] WARNING: at /build/buildd/linux-2.6.32/arch/x86/kernel/hpet.c:392 hpet_next_event+0x7a/0x90()
Mar 27 20:51:37 LKNB kernel: [ 1.969817] Hardware name: VPCF11Z1EI
Mar 27 20:51:37 LKNB kernel: [ 1.969820] Modules linked in:
Mar 27 20:51:37 LKNB kernel: [ 1.969825] Pid: 0, comm: swapper Not tainted 2.6.32-17-generic #26-Ubuntu
Mar 27 20:51:37 LKNB kernel: [ 1.969829] Call Trace:
Mar 27 20:51:37 LKNB kernel: [ 1.969837] [<ffffffff81066ccb>] warn_slowpath_common+0x7b/0xc0
Mar 27 20:51:37 LKNB kernel: [ 1.969843] [<ffffffff81066d24>] warn_slowpath_null+0x14/0x20
Mar 27 20:51:37 LKNB kernel: [ 1.969848] [<ffffffff810375ca>] hpet_next_event+0x7a/0x90
Mar 27 20:51:37 LKNB kernel: [ 1.969853] [<ffffffff81037610>] hpet_legacy_next_event+0x10/0x20
Mar 27 20:51:37 LKNB kernel: [ 1.969862] [<ffffffff81092cd4>] clockevents_program_event+0x54/0xa0
Mar 27 20:51:37 LKNB kernel: [ 1.969868] [<ffffffff81094228>] tick_dev_program_event+0x68/0xd0
Mar 27 20:51:37 LKNB kernel: [ 1.969874] [<ffffffff81093b5e>] tick_broadcast_oneshot_control+0x11e/0x120
Mar 27 20:51:37 LKNB kernel: [ 1.969880] [<ffffffff81093370>] tick_notify+0x130/0x200
Mar 27 20:51:37 LKNB kernel: [ 1.969887] [<ffffffff815433f6>] notifier_call_chain+0x56/0x80
Mar 27 20:51:37 LKNB kernel: [ 1.969894] [<ffffffff8108a2d6>] raw_notifier_call_chain+0x16/0x20
Mar 27 20:51:37 LKNB kernel: [ 1.969900] [<ffffffff81092af7>] clockevents_notify+0x37/0x160
Mar 27 20:51:37 LKNB kernel: [ 1.969907] [<ffffffff8130c6c1>] lapic_timer_state_broadcast+0x46/0x48
Mar 27 20:51:37 LKNB kernel: [ 1.969912] [<ffffffff8130ce0b>] acpi_idle_enter_simple+0xa4/0x14b
Mar 27 20:51:37 LKNB kernel: [ 1.969918] [<ffffffff815433b6>] ? notifier_call_chain+0x16/0x80
Mar 27 20:51:37 LKNB kernel: [ 1.969925] [<ffffffff81437faa>] ? menu_select+0x10a/0x2b0
Mar 27 20:51:37 LKNB kernel: [ 1.969931] [<ffffffff81436ef7>] cpuidle_idle_call+0xa7/0x140
Mar 27 20:51:37 LKNB kernel: [ 1.969938] [<ffffffff81011e73>] cpu_idle+0xb3/0x110
Mar 27 20:51:37 LKNB kernel: [ 1.969943] [<ffffffff8153a62c>] start_secondary+0xa8/0xaa
Mar 27 20:51:37 LKNB kernel: [ 1.969950] TCP cubic registered
Mar 27 20:51:37 LKNB kernel: [ 1.969953] ---[ end trace f7cf40bb3d912dbd ]---

Description: Ubuntu Lucid (development branch)
Release: 10.04

Affected kernel linux (2.6.32-21) Lucid 64bit core i7 based system

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lukask 1881 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe8e00000 irq 22'
   Mixer name : 'Realtek ID 275'
   Components : 'HDA:10ec0275,104d3f00,00100005'
   Controls : 4
   Simple ctrls : 3
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xe3080000 irq 16'
   Mixer name : 'Nvidia ID a'
   Components : 'HDA:10de000a,104d3f00,00100100'
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
Frequency: Once a day.
HibernationDevice: RESUME=UUID=47c4072a-b916-4df8-8473-d76706e6cc59
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
MachineType: Sony Corporation VPCF11Z1EI
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-21-generic root=UUID=e7ba0edd-e6d9-4481-a06c-5913b4706157 ro quiet splash
ProcEnviron:
 LANG=cs_CZ.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Regression: No
RelatedPackageVersions: linux-firmware 1.34
Reproducible: No
Tags: lucid kconfig needs-upstream-testing
Uname: Linux 2.6.32-21-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WifiSyslog:
 Apr 29 21:38:24 LKNB NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
 Apr 29 21:38:24 LKNB NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
 Apr 29 21:48:24 LKNB NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
 Apr 29 21:48:24 LKNB NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
dmi.bios.date: 12/07/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0250Y6
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0250Y6:bd12/07/2009:svnSonyCorporation:pnVPCF11Z1EI:pvrC603MEZ6:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCF11Z1EI
dmi.product.version: C603MEZ6
dmi.sys.vendor: Sony Corporation

Monkey (monkey-libre) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
tags: added: kernel-series-unknown
description: updated

Hello,

I am quite new to linux. I have a dual boot machine with windows 7 as the second OS. I have a Dell Studio 14z.

I have ubuntu 9.10 amd64 distribution. This is the second time this bug has appeared. The first time it appeared, ubuntu worked for a while after there was an error. After GRUB loading, it went straight to operating system not found. I formatted my machine and installed both windows 7 and ubuntu 9.10 again.

Now this bug is appearing for the second time. Can you please tell me what I should do to fix it? I really want to continue using Ubuntu. Also, do you recommend that I install Ubuntu 9.04 amd6x/ Ubuntu 9.10 32 bit version to avoid this error.

Thank you in advance.

description: updated
description: updated
Changed in debian:
status: Unknown → Confirmed
JR (juergen-richtsfeld) wrote :

same on my Dell Studio 1557:

[ 1.884299] WARNING: at /build/buildd/linux-2.6.32/arch/x86/kernel/hpet.c:392 hpet_next_event+0x7a/0x90()
[ 1.884303] Hardware name: Studio 1557
[ 1.884305] Modules linked in:
[ 1.884310] Pid: 0, comm: swapper Not tainted 2.6.32-19-generic #28-Ubuntu
[ 1.884313] Call Trace:
[ 1.884321] [<ffffffff81066ceb>] warn_slowpath_common+0x7b/0xc0
[ 1.884326] [<ffffffff81066d44>] warn_slowpath_null+0x14/0x20
[ 1.884330] [<ffffffff810375ca>] hpet_next_event+0x7a/0x90
[ 1.884335] [<ffffffff81037610>] hpet_legacy_next_event+0x10/0x20
[ 1.884342] [<ffffffff81092cf4>] clockevents_program_event+0x54/0xa0
[ 1.884347] [<ffffffff81094248>] tick_dev_program_event+0x68/0xd0
[ 1.884353] [<ffffffff81093b7e>] tick_broadcast_oneshot_control+0x11e/0x120
[ 1.884358] [<ffffffff81093390>] tick_notify+0x130/0x200
[ 1.884365] [<ffffffff81543626>] notifier_call_chain+0x56/0x80
[ 1.884371] [<ffffffff8108a2f6>] raw_notifier_call_chain+0x16/0x20
[ 1.884376] [<ffffffff81092b17>] clockevents_notify+0x37/0x160
[ 1.884382] [<ffffffff8130c6c1>] lapic_timer_state_broadcast+0x46/0x48
[ 1.884387] [<ffffffff8130ce0b>] acpi_idle_enter_simple+0xa4/0x14b
[ 1.884392] [<ffffffff815435e6>] ? notifier_call_chain+0x16/0x80
[ 1.884398] [<ffffffff8143811a>] ? menu_select+0x10a/0x2b0
[ 1.884403] [<ffffffff81437067>] cpuidle_idle_call+0xa7/0x140
[ 1.884410] [<ffffffff81011e73>] cpu_idle+0xb3/0x110
[ 1.884414] [<ffffffff8153a85c>] start_secondary+0xa8/0xaa

YannTech (yanntech) wrote :

Same problem with 2.6.32-20 :

[ 1.977377] ------------[ cut here ]------------
[ 1.977382] WARNING: at /build/buildd/linux-2.6.32/arch/x86/kernel/hpet.c:392 hpet_next_event+0x7a/0x90()
[ 1.977384] Hardware name: PowerEdge R310
[ 1.977385] Modules linked in:
[ 1.977388] Pid: 0, comm: swapper Not tainted 2.6.32-20-server #30-Ubuntu
[ 1.977389] Call Trace:
[ 1.977394] [<ffffffff81066d1b>] warn_slowpath_common+0x7b/0xc0
[ 1.977396] [<ffffffff81066d74>] warn_slowpath_null+0x14/0x20
[ 1.977398] [<ffffffff810375ca>] hpet_next_event+0x7a/0x90
[ 1.977400] [<ffffffff81037610>] hpet_legacy_next_event+0x10/0x20
[ 1.977404] [<ffffffff81092a94>] clockevents_program_event+0x54/0xa0
[ 1.977407] [<ffffffff81093fe8>] tick_dev_program_event+0x68/0xd0
[ 1.977409] [<ffffffff8109391e>] tick_broadcast_oneshot_control+0x11e/0x120
[ 1.977412] [<ffffffff81093130>] tick_notify+0x130/0x200
[ 1.977415] [<ffffffff8155a456>] notifier_call_chain+0x56/0x80
[ 1.977419] [<ffffffff81089fd6>] raw_notifier_call_chain+0x16/0x20
[ 1.977421] [<ffffffff810928b7>] clockevents_notify+0x37/0x160
[ 1.977425] [<ffffffff8130c571>] lapic_timer_state_broadcast+0x46/0x48
[ 1.977427] [<ffffffff8130cae0>] acpi_idle_enter_bm+0x187/0x2be
[ 1.977429] [<ffffffff8155a416>] ? notifier_call_chain+0x16/0x80
[ 1.977433] [<ffffffff81449417>] cpuidle_idle_call+0xa7/0x140
[ 1.977436] [<ffffffff81011e63>] cpu_idle+0xb3/0x110
[ 1.977439] [<ffffffff8154f750>] start_secondary+0xa8/0xaa
[ 1.977441] ---[ end trace fd4f4aa244a253e5 ]---

description: updated
Jeremy Foshee (jeremyfoshee) wrote :

Hi Lukas,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 549841

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

eval- (eval-) wrote :

This bug seems to have been around a while:
http://dunedin.lug.net.nz/forums/showthread.php?t=451783

What I also noticed is that I am losing 1min per hour (system clock falls behind hardware clock.)

Are these perhaps related?

Also, why is this bug still marked incomplete?

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: kernel-core kernel-needs-review lucid
removed: kernel-series-unknown needs-kernel-logs needs-upstream-testing
tags: added: kernel-candidate kernel-reviewed
removed: kernel-needs-review
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: removed: kernel-candidate
Tim Gardner (timg-tpi) wrote :

Lukas - Two things you can try:

1) Install an LTS backported 2.6.35 kernel from http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu
2) Boot with 'clocksource=tsc' (edit /etc/default/grub or hold the shift key to catch the grub boot prompt)

Changed in linux (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress

Hi TIm,
thanks for suggestions. It looks that issue is gone. Not sure if it is latest lucid updates or BIOS update which I did few weeks ago (officialy related to overheating).

Tim Gardner (timg-tpi) wrote :

Seems to have fixed itself.

Changed in linux (Ubuntu):
importance: Medium → Undecided
status: In Progress → Invalid
jedioetzi (jedioetzi) wrote :

still valid for
Linux netxx 2.6.31-20-server #58-Ubuntu SMP Fri Mar 12 05:40:05 UTC 2010 x86_64 GNU/Linux

[ 1.770507] WARNING: at /build/buildd/linux-2.6.31/arch/x86/kernel/hpet.c:390 hpet_next_event+0x75/0x90()
[ 1.770585] Hardware name: X8SIE
[ 1.770637] Modules linked in:
[ 1.770722] Pid: 0, comm: swapper Not tainted 2.6.31-20-server #58-Ubuntu
[ 1.770781] Call Trace:
[ 1.770835] [<ffffffff8105e538>] warn_slowpath_common+0x78/0xb0
[ 1.770894] [<ffffffff8105e57f>] warn_slowpath_null+0xf/0x20
[ 1.771024] [<ffffffff81034335>] hpet_next_event+0x75/0x90
[ 1.771082] [<ffffffff8103437b>] hpet_legacy_next_event+0xb/0x10
[ 1.771143] [<ffffffff810850af>] clockevents_program_event+0x4f/0x90
[ 1.771203] [<ffffffff810865a0>] tick_dev_program_event+0x40/0xd0
[ 1.771263] [<ffffffff81085f36>] tick_broadcast_oneshot_control+0x116/0x120
[ 1.771324] [<ffffffff81085820>] tick_notify+0x130/0x1a0
[ 1.771383] [<ffffffff8152cf37>] notifier_call_chain+0x47/0x90
[ 1.771442] [<ffffffff8107d201>] raw_notifier_call_chain+0x11/0x20
[ 1.771502] [<ffffffff81084eb4>] clockevents_notify+0x34/0xa0
[ 1.771561] [<ffffffff812da04a>] lapic_timer_state_broadcast+0x41/0x43
[ 1.771622] [<ffffffff812da5a7>] acpi_idle_enter_bm+0x185/0x2bf
[ 1.771681] [<ffffffff812da414>] ? acpi_idle_enter_c1+0xae/0xbc
[ 1.771740] [<ffffffff813ff5db>] cpuidle_idle_call+0x9b/0x100
[ 1.771800] [<ffffffff81010e42>] cpu_idle+0xb2/0x100
[ 1.771857] [<ffffffff8152480a>] start_secondary+0xa9/0xab
[ 1.771918] ---[ end trace d61fe533ea4cdb9e ]---

Changed in debian:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.