wifi module rtl8180 freezes the system

Bug #368679 reported by Jérémy Subtil
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Won't Fix
Declined for Intrepid by Jeremy Foshee
Declined for Jaunty by Jeremy Foshee
Declined for Karmic by Jeremy Foshee
Declined for Lucid by Jeremy Foshee
Declined for Maverick by Jeremy Foshee

Bug Description

On computers with some rtl818x chip based wifi cards, when module rtl8180 is modprobed this causes a complete freeze of the system.

This issue is severe for two reasons:
* computers with such wifi cards aren't able to connect to their network via wifi through a native linux driver;
* because rtl8180 is modprobed at startup, when a new user tries Ubuntu on such computer, the liveCD will show a black screen without any error message, and then the user will blame Ubuntu.

Although there are already some similar bug reports, they are all too specific to another hardware so the aim of this report is to centralize any information about actual system freezes caused by rtl8180 modprobes. In addition, this bug has been initially described in previous bug #152527.

Affected Ubuntu releases: Intrepid, Jaunty, Karmic

Affected wifi cards :
* MSI PC54G3 III (chipset RTL8185L)
* Zyxel G-302 V3

* ndiswrapper:
    * works on Intrepid but not on Jaunty
* manual install of Realtek's supported driver:
    * at least it seems it prevents the system from freezing
    * still in testing: some can connect to the network, some not

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
NonfreeKernelModules: nvidia
Package: linux-image-2.6.27-14-generic 2.6.27-14.33
ProcCmdLine: root=UUID=94814e6a-5868-4218-85ea-ff6550520509 ro quiet splash
ProcVersionSignature: Ubuntu 2.6.27-14.33-generic
SourcePackage: linux
UnreportableReason: Ceci n'est pas un authentique paquet Ubuntu

Revision history for this message
Jérémy Subtil (bigmadwolf) wrote :
Revision history for this message
In , Olivier (olivier-redhat-bugs) wrote :

Created attachment 344269
sosreport of the system

Description of problem:

Ther system experiences hard hang when using WIFI with the rtl8180 kernel module. The system ends in such a state that sysrq is inefficient (sysrq-t, sysrq-m, sysrq-c do nothing) and quite often require a complete electrical unplug for several seconds to be able to reboot.

Console logs or /var/log/message show no oops or kernel backtrace.

Blacklisting the module rtl8180 or removing the Belkin WIFI G PCI card cures the problem but does not help with WIFI connectivity ^_~

Version-Release number of selected component (if applicable):

kernel-PAE- (But occurs on older kernel as well, including F10)

How reproducible:

100% reproducible

Steps to Reproduce:

1. Install the Belkin Wireless G dektop PCI card Based on the Realtek 818x
2. Boot the system

Actual results:

System will hang either at login or at logout

Expected results:

System remains stable and functional

Additional info:

The WIFI connection uses hidden ESSID and WPA/WPA2 security. The problem occurs either when NetworkManager connects to the network or when it terminates (logging out from the user session leads to a 100% hang).

Same happens if NetworkManager exits or needs to reconnect. The same hardware works perfectly under Windows with Belkin's provided driver though.

I am attaching the sosreport of the system, unfortunately I am unable to debug this issue much further and I could not come up with a usable workaround for the issue.

Revision history for this message
Massimo (massimobattiato) wrote :

Bug related to Wi-FI card model Zyxel G-302 V3, Ubuntu 8.10, 9.04 (installed) and either CD live.

In order to report this bug, I'll give answers to questions I found here:
paragraph "Stock Reply for "random freeze" bugs".

- First freeze occurred while launching Live CD's Ubuntu 8.10 and 9.04, 32bit: black screen and freezed mouse's pointer.
- After installation of Ubuntu 9.04 32bit, freeze occurred many times during boot and randomly during session.
- No typical applications or actions preceded the freeze but only system boot.
- Not related with Compiz on/off.
- No errors messages (EE) reported in Xorg.0.log.
- All the freezes solved removing the Zyxel G-302 V3 card.

Revision history for this message
In , Bug (bug-redhat-bugs) wrote :

This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

I have a D-Link DWL-520 (rev.d) card, which uses this chipset.

I have found that Debian-based distros don't load the rtl8180 module for this card automatically for some reason. IIRC, when I try using the driver manually, it doesn't work. When trying Fedora (10) or Arch Linux, they load the module automatically. Unfortunately, it only works at a low speed for a limited amount of time.

I have been able to use Realtek's native Windows XP-64 drivers with ndiswrapper (using the amd64 version of Ubuntu or other Linux), but the native 32-bit XP drivers don't work for me with ndiswrapper (I tried Xubuntu 8.10 32-bit).

description: updated
Revision history for this message
Jérémy Subtil (bigmadwolf) wrote :

I've been able to load rtl8180 module whithout freeze in Intrepid by compiling the "official" source code v1030 provided by Realtek (http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=1&Level=6&Conn=5&DownTypeID=3&GetDown=false&Downloads=true#352).

My wifi card MSI PC54G3 III can now connect to my WPA network using wpa-supplicant, but it can't get any IP adress by DHCP using dhclient. I haven't tried to set a custom IP adress yet.

description: updated
description: updated
Revision history for this message
aatoma (antonio-toma) wrote :

In Jaunty I was still able to compile and use the Realtek provided Linux driver, as pointed out by Jérémy, but the upgrade to 2.6.31 kernel in Karmic broke that.
Now this bug is preventing me to use wireless. Any news about this bug?

Revision history for this message
mf (mat-fletcher) wrote :

I use rtl8180. Ubuntu 9.04. and and ubuntu 9.10

If i try to connect to a Wep netwrok i get a freeze and have to hard power cycle the machine to get it back. Nothing is written to /var/log/messages

I can live with this since i dont really use wep anywhere important.

Main issue is that the when connected to wpa and wpa2 networks my connection drops out at random. Usually when i most need it. I am currently unable to download more than 2MB of data.

Everything appears to still be connected but the traffic just stops. I have to stop the networking via Gnome network manager and start it again, where it will work straight away until the next time it craps out.

It is unusable in this state.

I've rebuilt this system a few times and have the same issue each time.

Card works fine in windows so not a hardware fault.

Revision history for this message
aceperry (perrychow) wrote :

I have a similar problem as mf in post #6. Using the Zonet ZEW1505 card with rt8185L chipset and the rtl8180 kernel driver, running wpa2, the connection starts up ok, weak signal compared to older wireless, and then drops out randomly. Sometimes the connection doesn't come back without a reboot of the computer. I'm going to try the windows driver as soon as I figure out how to get jaunty to use that exclusively.

Revision history for this message
aceperry (perrychow) wrote :

Oops, I meant Karmic and not jaunty on my last message.

tags: added: karmic
Revision history for this message
In , Skippy (skippy-redhat-bugs) wrote :

I can confirm this bug for Fedora 12 with the following wifi card : Zyxel G-302 v3.

For some other reason I cannot achieve a proper install right now so I can confirm only with the live CD, but symptoms are exactly the same as above : boot ok, user session ok, if I click on the NetworkManager icon I can select the network, then connect to it, enter my WEP key, and then the system will freeze (while asking for the keyring password, secondarily). If I don't try to connect, everything works fine but the system won't shutdown (didn't try to logout).

Similar issues happen with Ubuntu, cf https://bugs.launchpad.net/ubuntu/+source/linux/+bug/368679

Revision history for this message
Skippy le Grand Gourou (lecotegougdelaforce) wrote :

Having a Zyxel G-302 v3, I can confirm this bug. The system will freeze out at any moment : it can be during the boot or during the user session, but it will freeze for sure if you try to connect to a wifi network.

For information, similar issues occur with Fedora, though it happens only while trying to connect or during shutdown, see https://bugzilla.redhat.com/show_bug.cgi?id=501109

Revision history for this message
Jérémy Subtil (bigmadwolf) wrote :

This issue is present since Ubuntu Jaunty. To fix it, we do need to report it upstream as it sounds lik the other GNU/Linux distributions are affected as well.

Until there is no fix released for this bug, rtl8180 kernel module should be blacklisted in Lucid. It is inconceivable to let computers with such hardware freezing at boot with any error message and any log. IMHO the worst thing is that this is impossible to run the Ubuntu Live CD at all, so it gives a very bad impression for the first time Linux user.

Revision history for this message
Skippy le Grand Gourou (lecotegougdelaforce) wrote :

You're probably right on your first point, though I'm not sure how to file the bug upstream. A concerted complaint from every distro accompagnied by a blacklist would probably be more efficient. The question is : do some cards work successfully with this driver ?

And you're definitely right on the second point. PLEASE blacklist this buggy driver or at least (in case it may work for lucky people) warn the user from activating it !!!

BTW, just installed Debian stable, same issue.

Changed in fedora:
status: Unknown → Confirmed
Revision history for this message
Marc Schaefermeyer (mtschaef) wrote :

I have a Dell C600 with a D-Link Air DWL-650 that apparently uses the RTL8180L as found when issuing the "sudo lspci"
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b MAC (rev 20)
On a Fresh install of 9.10 the wireless card works great. When I update to the latest header "2.6.31-16" the card is not found. I have to add the driver via the "ndisgtk" which finds the card. But as soon as it connects to my wireless network everything freezes. The only way to get around it is to power down and pull the wireless pcmci card and connect via an RJ45 cable.
I have tried compiling a new kernal via multiple different posts, to no avail.
My work around is to reload from CD the 9.10 and not update to the latest kernal.
The kernal that works is the "linux-image-2.6.31-14-generic".

Revision history for this message
Jeremy Salwen (jeremy.salwen) wrote :

I would just like to note that I am getting the exact same problem. When I modprobe the rtl8180 driver (for an 8185 card), the system immediately freezes. It used to do so on startup until I removed the card. Now the driver doesn't load automatically, so I can boot up, but as soon as I modprobe it, instant complete freeze (SysRq commands don't even work). I've repeatedly read about how it is necessary to report an upstream bug, but has anyone done it? How would you do so?

Revision history for this message
Daniel Letzeisen (dtl131) wrote :
Changed in debian:
status: Unknown → New
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
In , Sylvain (sylvain-redhat-bugs) wrote :

I too confirm this kernel hang with a TRENDdet TEW-423PI (C1.0R) on a up to date Fedora 12 the only message when manually activating the connection was some "invalid parameter" message when using the GUI
Otherwise when on startup or command line nothing is showing but only the endless hang

BTW this is a blocker on the rescue mode if the interface is checked on as managed by the NetworkManager
My workaround has been to let this card disabled :(
obviously that was not my goal

Revision history for this message
In , Bug (bug-redhat-bugs) wrote :

This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 11 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora please change the 'version' of this
bug to the applicable version. If you are unable to change the version,
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:

Revision history for this message
In , John (john-redhat-bugs) wrote :

Created attachment 410552
rtl8180: fix tx status reporting

Revision history for this message
In , John (john-redhat-bugs) wrote :


I don't get any such hang on F-12 w/ my cardbus rtl8185 device. However, I did get rather poor performance.

Are you still seeing this hang with the test kernels above?

Revision history for this message
In , Steven (steven-redhat-bugs) wrote :

I just installed f12 on my wife's computer (she finally got frustrated enough with Windows to let me do it), and it hit this bug.

I have the following card:


From lspci -vv

02:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
 Subsystem: ZyXEL Communication Corporation Device 340d
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (8000ns min, 16000ns max), Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 11
 Region 0: I/O ports at 2000 [size=256]
 Region 1: Memory at e8100000 (32-bit, non-prefetchable) [size=512]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
  Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: rtl8180
 Kernel modules: rtl8180

Seems to be a race condition. It gets past setting up the wlan0 every other boot or so. Once it is up and running, everything is fine. I tried suspend and resume once, and that locked up on resume too (even though this is a desktop, it should still support s2r).

I'm currently doing a "yum update", I'll report again with the results of the latest kernel.

Revision history for this message
In , Steven (steven-redhat-bugs) wrote :

After doing a "yum update" and updating all packages since the fresh f12 install (which included the kernel package), I have yet to hit this bug.

I've rebooted 4 times and suspend and resumed twice. So far, so good.

Revision history for this message
In , Steven (steven-redhat-bugs) wrote :

Spoke too soon. Seems the race condition is smaller. While showing my wife how to use her box, it locked up on suspend and resume while (I think) initializing the network.

Revision history for this message
In , John (john-redhat-bugs) wrote :

Steven, and logs available? Perhaps you could capture a trace using netconsole (over a wired port)?

Revision history for this message
In , Steven (steven-redhat-bugs) wrote :

John, investigating this further, the lockup seemed to have nothing to do with the network card. It looks like a drm/i915 bug. But it takes out the network too, although I don't know why.

It looks like I'm hitting this bug:

As far as I can tell from the logs when it locks up now. It does not seem to be related to the wifi nic, but to the video. I don't understand why I lose my wireless on the X lockup. I'm fine on serial. I'll try again with a wired connection, but as far as I'm concerned, it looks like this BZ is done.

I would like a working system before I conclude that though ;-)

Revision history for this message
In , Steven (steven-redhat-bugs) wrote :

Interesting, after pulling the pci wireless card, I can not make X lockup. I wonder if it is related.

Revision history for this message
In , Steven (steven-redhat-bugs) wrote :

Nevermind, I was able to finally reproduce the hang without the wireless card.

Revision history for this message
In , John (john-redhat-bugs) wrote :

I can't recreate any problems -- this driver works reasonably well for me.

Revision history for this message
In , Sylvain (sylvain-redhat-bugs) wrote :

(In reply to comment #14)
> I can't recreate any problems -- this driver works reasonably well for me.
It just means the card you own works fine with it....
Btw do you own a realtek branded one ?
Thanks in advance

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Declining the Maverick specific nomination for now and leaving this open against the actively developed Ubuntu kernel (which happens to be Maverick at this time). Will re-open the nomination should a fix be narrowed down which we can confirm specifically resolves this issue in Maverick.


Revision history for this message
CirclingTheSun (circlingthesun) wrote :

I'm experiencing this problem on my Msi Wind u100 that has the rlt8187 chipset.
The system freezes shortly after suspend.This only happens when I'm running on battery. When I initially boot on battery the wi-fi works fine. Then after I suspend and resume it freezes after about 5 seconds. Resuming without the wi-fi turned on works but the system freezes as soon as I toggle it on.
I attached my kern.log with all messages from resume until the system freezes.

Revision history for this message
CirclingTheSun (circlingthesun) wrote :

Correction: its the rtl8187se chipset

Revision history for this message
David (david.regev) wrote :

I’m experiencing the same issue as CirclingTheSun on the same machine. The strange thing is that these freezes were rare when I was running Lucid, but have started occurring consistently after upgrading to Maverick. Specifically, if I am on battery and the machine has resumed from suspect, then the system freezes after a few seconds. If wireless is disabled, this does not happen, but the freeze happens anyway a few seconds after you re-enable it.

A similar related issue that I saw already with Lucid: if a wireless network’s settings change (such as opening it up) while connected to it, the whole system freezes. This happens even when plugged in.

The original behaviour that I described has made computing on the go quite difficult. If there’s something I can do to help, I would be glad to do it.

Revision history for this message
Bruce Le (thelionkrap) wrote :

I have the Belkin F5D7000 v7032 and it is causing the described bug on ubuntu Maverick 10.10. I am not sure of the exact chipset the card uses, but I know that it is driver rtl8180 that causes the freeze, and when I blacklist that driver, ubuntu boots normally, but obviously the wifi card does not work. This behavior also happens in Fedora 14.

Revision history for this message
David (david.regev) wrote :

I just checked if this was fixed in the Natty beta. It’s not. I’m surprised such a regression has remained for so long. As I explained, this is a pretty severe bug. It makes it nearly impossible, for example, to load up a bunch several web pages, suspend, and then resume on the go while still being able to use WiFi.

Is there anything at all I can do to help get this fixed?

Revision history for this message
David (david.regev) wrote :

I just discovered a workaround, courtesy of bug 656745 comment 0. This is what it said:

in /etc/default/grub change:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=off"
and run "sudo update-grub"

Revision history for this message
floid (jkanowitz) wrote :

Does pcie_aspm=off as described in #21 do anything in systems that predate PCI-E?

Revision history for this message
jhansonxi (jhansonxi) wrote :

With Ubuntu 10.04 (Lucid Lynx) on an old Intel D845GBV (PCI/AGP) motherboard and a CompUSA 1244-00000403-010 PCI wireless card with an RTL8185L chip, "pcie_aspm=off" did not prevent the system from hard freeezing (not even magic sysreq keys work) during boot. With "acpi=off" the system boots successfully.

Revision history for this message
Brad Figg (brad-figg) wrote : Unsupported series, setting status to "Won't Fix".

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Rüdiger Kupper (ruediger.kupper) wrote :

This problem persists in the current Natty release.

Revision history for this message
Albert Pool (albertpool) wrote :

Thank you for letting us know, Mr. Kupper. I was just going to buy a second-hand RTL8180, but that will be another card after reading this.

Revision history for this message
Rüdiger Kupper (ruediger.kupper) wrote :

Glad I could help, even more glad will I be when this bug can be fixed.
(As a side-note, the card works with ndis-wrapper and the windows drivers, if this is an option for you. But you'll need to blacklist the driver in order to boot.)

Revision history for this message
Rüdiger Kupper (ruediger.kupper) wrote :

Re-opening for Natty as bug #839019.

Changed in fedora:
importance: Unknown → High
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.