ofono does not detect ZTE MF628 HSPDA USB modem

Bug #738178 reported by André Carvalho on 2011-03-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Connection Manager
Undecided
Unassigned
ofono (Ubuntu)
Undecided
Unassigned

Bug Description

Connman does not seem to be able to recognise my ZTE HSDPA USB Modem, model MF628 when I plug it in, nor can I manually configure it through the UI.

connman 0.69
ofono 0.41

Kalle Valo (kvalo) wrote :

Do you have ofono installed? If yes, what's the usb id of your modem?

It would help a lot if you can get a debug log. Just run this command before plugging in your modem:

indicator-network-debug start

More info here:

https://wiki.ubuntu.com/ConnMan/Debugging

All right, I followed the steps and here is my syslog file. I absolutely do not know how to lookup the ID's, but if it is helpful, I also attach the lspci -vnvn log file.

Kalle Valo (kvalo) on 2011-03-22
description: updated
Kalle Valo (kvalo) on 2011-03-22
Changed in connman:
status: New → Invalid
summary: - Connman does not detect Wireless Broadband modem
+ ofono does not detect ZTE MF628 HSPDA USB modem

André Carvalho <email address hidden> writes:

> All right, I followed the steps and here is my syslog file.

Thanks.

> I absolutely do not know how to lookup the ID's, but if it is helpful,
> I also attach the lspci -vnvn log file.

Ah, my bad. You can get usb ids with lsusb command. More info here:

https://wiki.ubuntu.com/ConnMan/ReportingBugs

> ** Attachment added: "Syslog"
> https://bugs.launchpad.net/connman/+bug/738178/+attachment/1929894/+files/syslog.txt

Ok, so your modem id is 19d2:0015 (after usb modeswitch):

Mar 22 12:30:56 peppermint-laptop usb_modeswitch: switched to 19d2:0015 (Qualcomm, Incorporated: ZTE CDMA Technologies MSM)

Unfortunately that id is not yet supported by ofono.

What you could do is to add the id yourself:

1. edit /lib/udev/rules.d/97-ofono.rules

2. Add the two lines below *before* the LABEL="ofono_end" line:

ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="0015", ENV{OFONO_IFACE_NUM}=="03", ENV{OFONO_ZTE_TYPE}="modem"
ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="0015", ENV{OFONO_IFACE_NUM}=="01", ENV{OFONO_ZTE_TYPE}="aux"

3. Run 'indicator-network-debug start' to start logging

4. Plug in your modem again and send the log here.

--
Kalle Valo

I did what you asked and still nothing.

Moving to Ubuntu package; this bug will need to be re-triaged to confirm and report upstream.

I'll try to see how far I can get with my MF636 (close enough), even if I don't have a SIM to put in it.

affects: ofono → ofono (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ofono (Ubuntu):
status: New → Confirmed
piotr zimoch (ebytyes) on 2013-05-21
Changed in ofono (Ubuntu):
status: Confirmed → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
piotr zimoch (ebytyes) on 2013-05-22
Changed in connman:
status: Invalid → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers