Compiz high CPU and UI freeze on NVIDIA after fix for #269904 in trusty-updates

Bug #1424013 reported by Eloy Paris on 2015-02-20
98
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Compiz
High
Christopher Townsend
0.9.11
High
Christopher Townsend
compiz (Ubuntu)
High
Christopher Townsend
Nominated for Trusty by Stephen M. Webb
Trusty
Undecided
Unassigned

Bug Description

[ Impact ]

Immediately after the fix for #269904 landed in trusty-updates via compiz 1:0.9.11.3+14.04.20150122-0ubuntu1, my 14.04 machine with an NVIDIA card and using the nvidia-304 driver became unusable -- symtoms include compiz process high CPU (100%), UI freeze right after logging in (machine still up, reachable via SSH from the network), and a flood of these messages on the system log.

[ Test Case ]

Requires a GeForce 6150SE or similar integrated GPU from nVidia. Problem manifests immediately on login.

[ Regression Potential ]

The fix involves a specific hardware blacklist. Anticipated regressions include fixed support for the specific hard in future nVidia driver releases and potentially additional unidentified hardware affected by this bug needing to be added to the blacklist.

Note that there is a manual workaround to the problem consisting of disabling the X11 Sync feature through CCSM.

[ Other Info ]

This fix was cherry-picked from the Ubuntu "Vivid Vervet" development release where it has been in regular use for some weeks.

Related branches

Ryan Tandy (rtandy) wrote :

Hi,

This may be a duplicate of bug 1404015.

Which NVIDIA GPU do you have?

Christopher Townsend (townsend) wrote :

Hi Eloy,

Could you open CCSM and disable the X11 Sync and see if the issue still occurs?

CCSM->OpenGL and uncheck "X11 Sync objects"

Thanks!

Eloy Paris (peloy-chapus) wrote :

Hi Ryan,

Thanks for the quick reply. I indeed have a GeForce 6150SE so bug 1404015 could be a match in my case. I will upgrade to the latest version of compiz in trusty-updates, disable x11-sync, and report back.

The question I'd have is how to explain that going back to the previous compiz version in trusty-updates makes everything work again, with no other changes. Perhaps the new compiz stresses more the driver or exercises the "x11-sync" path?

I also tried nouveau after I upgraded to the latest compiz in trusty-updates and the machine became unusable, but I also experienced freezes. Perhaps that is due to bug 1181902 so that's something else I can try.

Christopher Townsend (townsend) wrote :

Hey Eloy,

Regarding the question of why going back to the previous COmpiz version works, my guess is that a bug exists in the GPU and/or the Nvidia 304 in which it doesn't handle the GL_EXT_x11_sync_object OpenGL extension. So far in all of the user testing of this patch, only the GeForce 6150SE has had problems.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Helio Neto (remiariro) wrote :

My GeForce 7025 is also affected the same way.

Christopher Townsend (townsend) wrote :

Hmm, we now have two different GPU's mentioned as being negatively affected by the X11 Sync Nvidia patch. However, both of these GPU's are integrated in the motherboard chipset. On top of that, Nvidia has dropped driver support for these GPU's.

I'm thinking about maybe adding some sort of blacklist for 6000/7000 series GPUs or systems with older drivers installed. I'm not really sure if the issue is the GPU or the driver, but it may not matter since users of the older GPUs will be using older drivers any ways.

Ryan Tandy (rtandy) wrote :

For what it's worth, we have not had problems with nvidia-304 on more recent GPUs, so I'd be inclined to blame the hardware (maybe that generation, maybe the integrated type like you mentioned) sooner than the driver. But you're right that blacklisting the older driver would probably eliminate the entire class of problems :)

Christopher Townsend (townsend) wrote :

Hey Ryan,

Thanks for the additional info. Hmm, it seems there are folks who still use the 304 driver on newer machines. I'm also not sure if folks are having the refresh issue using 304 drivers on newer GPUs, so I don't think it's a good idea to blacklist the 304 driver.

I found a list of integrated GPUs here: http://www.nvidia.com/object/mobo_gpu_tech_specs.html

If I can somehow match up the GPUs to the OpenGL renderer string in a reliable way, then that may be the way to go.

Just need to be careful about this...

Hey All,

Could you please do the following to help me figure out what render strings I should key on?

1. Install glxinfo on the machine.
2. Then run 'glxinfo | grep "OpenGL renderer string' from a terminal.
3. Paste the output in this bug.

Thanks!

On Fri, Feb 20, 2015 at 10:09:41PM -0000, Christopher Townsend wrote:
>Hmm, it seems there are folks who still use the 304 driver on newer
>machines.

I can give two examples of that, both probably fairly uncommon:

* we (my employer) netboot a variety of hardware from a single squashfs
   image, so nvidia-304 is lowest-common-denominator until we get the
   older hardware phased out.

* I still run nvidia-304 on my laptop because the screen brightness
   can't be adjusted on newer drivers (bug 1241745).

On Fri, Feb 20, 2015 at 10:13:50PM -0000, Christopher Townsend wrote:
>Could you please do the following to help me figure out what render
>strings I should key on?
>
>1. Install glxinfo on the machine.
>2. Then run 'glxinfo | grep "OpenGL renderer string' from a terminal.
>3. Paste the output in this bug.

OpenGL renderer string: GeForce 6150SE nForce 430/integrated/SSE2/3DNOW!

Thanks for looking into this!

Changed in compiz:
status: New → Confirmed
importance: Undecided → High
Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz:
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
milestone: none → 0.9.12.2
Eloy Paris (peloy-chapus) wrote :

Hi Christopher,

Here's my OpenGL renderer string:

$ glxinfo | grep "OpenGL renderer string"
OpenGL renderer string: GeForce 6150SE nForce 430/integrated/SSE2/3DNOW!

Cheers,

Eloy Paris.-

Hi all! I reported bug #1425701 which also solved disabling X11 sync. My output here:

lucas@UbuntuDesktop:~$ glxinfo | grep "OpenGL renderer string"
OpenGL renderer string: GeForce 7050 PV / nForce 630a/integrated/SSE2

Let me know if I can collect some other usefull information
Regards

Lucas

Changed in compiz:
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
Eloy Paris (peloy-chapus) wrote :

Hi Christopher,

On Fri, Feb 20, 2015 at 06:51:23PM -0000, Christopher Townsend wrote:

> Hi Eloy,
>
> Could you open CCSM and disable the X11 Sync and see if the issue still
> occurs?
>
> CCSM->OpenGL and uncheck "X11 Sync objects"

I am sorry for the delay in getting back to you on this. I suspect that
by now you have a pretty good idea of what is going on but I still went
ahead and made the change that you requested -- I can confirm that I can
use the latest version of Compiz in trusty-updates on the machine I was
having problems if I disable "X11 Sync objects".

The reason for the delay is that this machine is used by three other
users so I needed to find a way to make the change from the CLI so
"X11 Sync objects" is disabled for all of them at login time because
otherwise they couldn't even run CCSM because the GUI is frozen.

For reference, I accomplished this by creating /etc/dconf/profile/user
with the following contents:

user-db:user
system-db:system-wide

Then I created /etc/dconf/db/system-wide.d/00_compiz_site_settings with
these contents:

[org/compiz/profiles/unity/plugins/opengl]
enable-x11-sync=false

and then I ran "dconf update".

Anyway, is there a performance penalty by running with enable-x11-sync
disabled? Just wondering if I should go back to the previous Compiz
version or if it's okay to run the latest plus this workaround.

Cheers,

Eloy Paris.-

Hi Eloy,

Thanks for the info. I'm currently working on a more permanent fix in Compiz in which I will "blacklist" known GPU's that are affected by this.

There shouldn't be any performance penalty when running with X11 Sync turned off. What that is supposed to do is keep the GPU's rendering in Sync w/ X11. Many folks over time have been affected by issues where the rendering is done out of sync resulting in weird artifacts on the screen such as black borders and such. See bug #269904 if you want more details.

Eloy Paris (peloy-chapus) wrote :

Thanks for your work on this issue and for the additional insight,
Christopher.

I don't think I ever experienced the artifacts in #269904, and if I did,
it was a long time ago and not with this machine. I hope I won't start
experiencing them now ;-)

Whatever the case, I will try to avoid buying a machine with an NVIDA
card in the future -- I have had better luck with Intel GPUs.

Cheers!

Eloy Paris.-

Hi All,

I believe I have a fix/workaround for this issue in which I blacklist the affected GPUs from using the X11 Sync stuff. However, I do not have a machine that I can test this with, so I'm asking for your help.

I have versions of Compiz built for Vivid and Trusty w/ this fix built in a PPA. Could you please add the PPA (ppa:townsend/compiz-nvidia-refresh-test) and give it try and let me know? Please make sure the X11 Sync objects option in CCSM is enabled to prove the blacklist is actually working.

Thanks!

Trevor (karatemantj-6) wrote :

Christopher,

I just added your PPA and can confirm it has fixed the issue for me.

OpenGL renderer string: GeForce 7025 / nForce 630a/integrated/SSE2

I've been beating my head against the wall trying to figure this one out. Thanks for your hard work!

Thanks,
Trevor

PPA is working for me too (GeForce 7050 PV / nForce 630a/integrated/SSE2)
Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.12.1+15.04.20150227-0ubuntu1

---------------
compiz (1:0.9.12.1+15.04.20150227-0ubuntu1) vivid; urgency=medium

  [ Chris Townsend ]
  * Add a blacklist of Nvidia integrated GPU's affected by the Nvidia
    X11 Sync patch. (LP: #1424013)

  [ Martin Wimpress ]
  * Tweak 'recommends' runtime dependencies for compiz-gnome and compiz-
    mate.
 -- CI Train Bot <email address hidden> Fri, 27 Feb 2015 15:37:04 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-03-02
Changed in compiz:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2015-03-13
description: updated

Hello Eloy, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/compiz/1:0.9.11.3+14.04.20150313-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Ryan Tandy (rtandy) wrote :

Hi,

With compiz from trusty-proposed, the blacklist seems to be working fine for GeForce 6150SE.

Thanks for the fix and backport!

tags: added: verification-done
removed: verification-needed

Hi,

This bug also affected my system (exact same symptoms) but upgrading compiz to 0.9.11.3+14.04.20150313-0ubuntu1 did not fix it.

CPU: AMD Athlon Dual Core Processor 4850e
MB: Asus M2NPV-VM Nvidia GeForce 6150 + nForce 430

Ubuntu Trusty 14.04

sudo modinfo nvidia_304_updates

filename: /lib/modules/3.13.0-49-generic/updates/dkms/nvidia_304_updates.ko
alias: char-major-195-*
version: 304.125
supported: external
license: NVIDIA
...

Any ideas?

@Justin,

1. Did you reboot or at least restart Compiz when you applied the update?
2. If so, could you please provide the output from the instructions in comment #10?

Thanks!

pataluna (pantaluna) wrote :

RE: Testing request.

Hi,

I have installed on top of Ubuntu 14.0.4.02 LTS the update of compiz which is in the repo trusty-proposed and it works fine.
Thanks!

Procedure:
    # 1. Added repo trusty-proposed.
    # 2. Package upgrade.
    # compiz:all/trusty-updates 1:0.9.11.2+14.04.20140714-0ubuntu1 upgradeable to 1:0.9.11.3+14.04.20150122-0ubuntu1
    $ apt-get install --only-upgrade compiz

FYI:
- $ glxinfo | grep "OpenGL renderer string"
        OpenGL renderer string: GeForce 7050 PV / nForce 630a/integrated/SSE2

- GPU Hardware: nVidia GeForce 7050 PV / nForce 630a (rev a2).

- nVidia Driver http://www.nvidia.com/Download/driverResults.aspx/77034/en-us
 Linux x64 (AMD64/EM64T) Display Driver
  Version: 304.1230
  Release Date: 2014.7.10
  Operating System: Linux 64-bit
  Language: English (US)
  File Size: 68.00 MB

benpicco (benpicco) wrote :

I've upgraded to 15.04 and now I'm hitting the very same bug.
Compiz will use 100% CPU and the UI freezes, the offending compiz instance will persist consuming CPU time even after systemctl restart lightdm and can only be killed by SIGKILL.

I'm also seeing

[17409.810980] NVRM: GPU at PCI:0000:01:00: GPU-50e94984-5501-8f36-bc04-b29c484a5f1e
[17409.810988] NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ChID 0003, Class 00008397, Offset 00000e08, Data 04b00000
[17410.915719] NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ChID 0003, Class 00008397, Offset 00000f10, Data 44960000
[17421.432239] NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ChID 0003, Class 00008397, Offset 00000f10, Data 44960000
[17431.525701] NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ChID 0003, Class 00008397, Offset 00000f10, Data 44960000

in dmesg

OpenGL renderer string: GeForce GTX 260/PCIe/SSE2
NVIDIA Driver Version: 340.76
Linux rechenknecht2k7 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Tell me if this is a different bug and I should open a new issue.

Helio Neto (remiariro) wrote :

Sorry for the long delay, I haven't had access to the affected machine since my last post.

    OpenGL renderer string: GeForce 7025 / nForce 630a/integrated/SSE2

I can confirm that 0.9.11.3+14.04.20150313-0ubuntu1 in Trusty Proposed has fixed the issue for me.
Thank you!

@benpicco,

To see if your problem is the problem described in this bug, try turning off the X to GL sync.

If you haven't already, install compizconfig-settings-manager.

After that, start ccsm and then go to the OpenGL tab. Uncheck "X11 Sync objects". If this makes your issue go away, then you are dealing with this particular bug.

That said, looking at your log snippet, I'm thinking this is an issue either in the NVRAM of your card perhaps exposed by the driver or in the driver itself.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11.3+14.04.20150313-0ubuntu1

---------------
compiz (1:0.9.11.3+14.04.20150313-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * removed texture caching from animations (LP: #729979, #1072206)

  [ Chris Townsend ]
  * Add a blacklist of Nvidia integrated GPU's affected by the Nvidia
    X11 Sync patch. (LP: #1424013)
 -- CI Train Bot <email address hidden> Fri, 13 Mar 2015 17:25:30 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Von (daaxix) wrote :

This bug appears to be back after the latest updates last week.

Compiz freezes, 99% CPU, unchecking X11 Sync fixes it.

OpenGL Renderer String : GeForce 7300 LE/PCIe/SSE2

Note that my card is NOT an integrated card, but a standalone OEM card in a Dell computer.

I'm on 14.04, 3.13.0-52-generic.

Thanks

Hi Von,

Hmm, the last 14.04 update for Compiz came out nearly two weeks ago, but the fix put in that potentially causes your issue came out in mid February, so why you would see this with the last update has me scratching my head.

Are you using the nvidia binary driver or nouveau? I'm also curious when the last update came for your video driver.

Thanks!

Frans Timmers (frans-timmers) wrote :

After implementation of this change the system start OK but with a black screen, where only the mouse pointer is visible. The system has an NVIDIA video card. Implementation the change seems linked to changes for OpenGL, so I cannot install these without installing this one. The only solution was to restore the system and to not implement the Compiz and OpenGL updates,
Although I do not know enough about Linux to be absolutely sure that this problem is caused by this update I do hope this can be solved.
Kind regards,
Frans Timmers.

Andrei Levin (andrei-levin) wrote :

After todays update I also find this bug. Fortunately after several hours of search I find this bug report. (Geforce 7300 GS). Disabling X11 Sync objects solve the problem

Von (daaxix) wrote :

@Townsend, this computer was not updated frequently, so I may have picked up the issue from Feb. I'm using the nvidia binary driver.

Thanks,

--Von

Von (daaxix) wrote :

Ok, this bug is back again.

Here is what occured.

After unchecking the X11 sync a few weeks ago, I noticed that all of my window menus were missing.

While poking around in CCSM to remedy this problem I accidentally clicked on "restore defaults." This caused unity to be disabled somehow.

After restoring unity and compiz settings, I tried to log in but got artifacts and the 100% cpu with compiz problem.

I just need the computer to work, but it is failing. I cannot use Nouveau because I get the "GPU lockup" issue.

Townsend, I installed your ppa and it didn't fix it, there was no change.

I've removed (and purged) all nvidia drivers, unity, ubuntu-desktop, lightdm and reinstalled them. I've deleted my xorg.conf and let a new one be made.

I'm at a loss with nothing else to do, any suggestions are welcome.

Thanks,
I unchecked X11 sync again, but there is no change. Unity bar is artifacted and compiz is using large amounts of CPU.

I double checked glxinfo output in case something got messed up there, but it remains the same as before.

PorkCharSui (porkcharsui) wrote :

Hello everybody,

This bug still exists. It happens on several of my systems (sysop @ university).

My test system:
 HP Compaq 8200 Elite CMT (hardware spec: http://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c02779501)
with an extra video-card:
 Geforce 7300 GS

I've tried nouveau and proprietary drivers.

I'm running Ubuntu 14.04.2. Packages are as up-2-date as they're going to get.

uname -a:
 Linux HOSTNAME 3.13.0-55-generic #92-Ubuntu SMP Sun Jun 14 18:32:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

We use lightdm, but light-locker is removed, because it causes trouble on other fronts. We also offer a multitude of WM's to our users, with all the trouble that causes :(. We've installed ubuntu-desktop, xubuntu-desktop, kde-workspace, gnome(classic), i3-wm, XMonad, Openbox.

Most of our systems have very similar hardware, they're all HP Compaq systems (some a bit older, some newer). The trouble seems to be with the older NVIDIA card, because that's the same on all the troublesome systems.

The fix Eloy Paris mentioned in comment #14 is the only thing so far that resolves the issue. Thankfully we use Puppet to manage our workstations, so implementing it wasn't too difficult, but I would very much like to see a more permanent solution.

Stephen M. Webb (bregma) on 2015-08-20
Changed in compiz:
status: Fix Committed → Fix Released
Sam Hodge (q-sam) wrote :
Download full text (4.2 KiB)

It is working out badly for me to on a Dell Precision M65 with Quadro FX 350M card

samh@trevor:~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G72GLM [Quadro FX 350M] (rev a1)
samh@trevor:~$ sudo grep -rn "NVRM: Xid" /var/log/
/var/log/syslog:3853:Oct 3 16:22:42 trevor kernel: [ 38.001453] NVRM: Xid (PCI:0000:01:00): 1, Channel 00000002 Method 00000060 Data beef0233
/var/log/syslog:3854:Oct 3 16:22:42 trevor kernel: [ 38.217918] NVRM: Xid (PCI:0000:01:00): 1, Channel 00000002 Method 00000060 Data beef0233
/var/log/syslog:3855:Oct 3 16:22:42 trevor kernel: [ 38.283735] NVRM: Xid (PCI:0000:01:00): 7, Ch 00000000 M 00000154 D 00000000 intr 00010001
/var/log/kern.log:2875:Oct 3 16:22:42 trevor kernel: [ 38.001453] NVRM: Xid (PCI:0000:01:00): 1, Channel 00000002 Method 00000060 Data beef0233
/var/log/kern.log:2876:Oct 3 16:22:42 trevor kernel: [ 38.217918] NVRM: Xid (PCI:0000:01:00): 1, Channel 00000002 Method 00000060 Data beef0233
/var/log/kern.log:2877:Oct 3 16:22:42 trevor kernel: [ 38.283735] NVRM: Xid (PCI:0000:01:00): 7, Ch 00000000 M 00000154 D 00000000 intr 00010001
/var/log/auth.log:95:Oct 3 16:27:19 trevor sudo: samh : TTY=tty1 ; PWD=/home/samh ; USER=root ; COMMAND=/bin/grep -rn NVRM: Xid /var/log/
/var/log/auth.log:142:Oct 3 16:37:28 trevor sudo: samh : TTY=tty1 ; PWD=/home/samh ; USER=root ; COMMAND=/bin/grep -rn NVRM: Xid /var/log/
/var/log/auth.log:209:Oct 3 16:58:57 trevor sudo: samh : TTY=pts/0 ; PWD=/home/samh ; USER=root ; COMMAND=/bin/grep -rn NVRM: Xid /var/log/
/var/log/auth.log:227:Oct 3 17:02:05 trevor sudo: samh : TTY=pts/0 ; PWD=/home/samh ; USER=root ; COMMAND=/bin/grep -rn NVRM: Xid /var/log/
/var/log/auth.log:233:Oct 3 17:02:48 trevor sudo: samh : TTY=pts/0 ; PWD=/home/samh ; USER=root ; COMMAND=/bin/grep -rn NVRM: Xid /var/log/
samh@trevor:~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G72GLM [Quadro FX 350M] (rev a1)
samh@trevor:~$ sudo modinfo nvidia_304
filename: /lib/modules/3.19.0-25-generic/updates/dkms/nvidia_304.ko
alias: char-major-195-*
version: 304.128
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm
vermagic: 3.19.0-25-generic SMP mod_unload modversions
parm: NVreg_EnableVia4x:int
parm: NVreg_EnableALiAGP:int
parm: NVreg_ReqAGPRate:int
parm: NVreg_EnableAGPSBA:int
parm: NVreg_EnableAGPFW:int
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UseVBios:int
parm: NVreg_RMEdgeIntrCheck:int
parm: NVreg_UsePa...

Read more...

Sam Hodge (q-sam) wrote :

Comment #14 did the trick

Mauricio (mruibal) wrote :

I have problems also with my nvidia 7300 go in Acer Aspire 5635 WLMi laptop, the nvidia 304 driver is not working, it freezes afer login screen (login screen seems to work ok). But this driver, nvidia 304, is working ok in Ubuntu 12.04.
In Ubuntu 14.04 I was force tu use the nvidia 173 driver with works ok but is not vdpau usable and is a true shame.
Thank you all!

asala (asala) wrote :

Having similar problems with compiz on nvidia 7300 LE, driver 304, on Ubuntu 15.10.
 Pleas add this card model to the "blacklisted" ones. XFCE works flawlessly.

Christian Brandt (brandtc) wrote :

The bug is back at 16.04 32bit with a slight variation: relates also to dedicated GPUs, normal desktop works somewhat slow but normal, changing resolution or inflicting high video load makes compiz and therefore X11/lightdm crash/blackscreen/restart lightdm (eg starting frozen bubble in full screen will restat lightdm). Using dconf write /org/compiz/profiles/unity/plugins/opengl/enable-x11-sync false fixes all problems.

Ubuntu is pretty mint 16.04 install with current upgrades and NVidia drivers:
nvidia-304 304.131
compiz 1:0.9.12.2+16.04.20160415-0ubuntu1all

00:00.0 Host bridge: Intel Corporation 82P965/G965 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82P965/G965 PCI Express Root Port (rev 02)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801HB (ICH8) 4 port SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: NVIDIA Corporation G73 [GeForce 7600 GS] (rev a1)
03:00.0 SATA controller: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 02)
03:00.1 IDE interface: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 02)
04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 22)

Christian Brandt (brandtc) wrote :

I need to correct my last statement, enable-x11-sync false does NOT fix all problems.

It merelly makes the system a lot more stable but it still displays often graphical distortions and such. I opened a seperate bug report: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-304-updates/+bug/1579501 with more details and logs.

I found the black-screen problem on a Lenovo 3000 N100 laptop after doing an update on 14.04 LTS recently (early September 2016). This is a 32-bit machine.

As a workaround I installed flashback:
apt-get install inxi gnome-session-flashback compizconfig-settings-manager

I could then select either of the Gnome options and log in OK (i.e. it works with both Metacity and Compiz, but the normal Ubuntu session fails).

OpenGL renderer string: GeForce Go 7300/PCIe/SSE2

Turning off X11 Sync Objects did not fix it.
I then tried some different drivers using
  System Settings -> Software and Updates -> Additional Drivers
X.Org with Nouveau did not work at all
Nvidia 173 works OK.

Summary: using the older Nvidia 173 driver is an adequate workaround for me, but it looks as if this problem is more complex than just 'Sync Objects'.

Sami Nieminen (sami-nieminen) wrote :

Bug also affects the following hardware:

OpenGL renderer string: GeForce 6800 GT/AGP/SSE2

Disabled X11 Sync Objects and now it works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers