[regression-r3320] Animations and modules/plugins missing in Ubuntu 12.10 and 13.04

Reported by Tanker Bob on 2012-10-20
104
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Compiz
Wishlist
Sam Spilsbury
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Original report:
================

Upon upgrading to Ubuntu 12.10 and setting compiz up with CCSM, I noticed that the animations like "Flame" are missing and there are no modules for Animations Add-on, Cube Deformation and Reflection, Cube Gears, Reflection and others. I rechecked to find that compiz-plugins-extra is installed, and even reinstalled it to be sure. All compiz components list as 9.8.4 in Synaptic. So, all compiz modules are installed, yet the extras do not appear to be loading or running. I attached an image of the the applicable CCSM panels.

Note:
=====

* Currently broken and excluded from compilation: animationaddon, bicubic, blur, colorfilter, group, loginout, reflex, stackswitch and trip

* Currently not working correctly (but enabled, compiled and available): td (3d windows for the cube)

* Also not working anymore: All the plugins from the unsupported package/Compiz git repo.
I will only list the most important ones here:

animationjc, extra-animations, simple animations - Great additional animations

screensaver - Uses the cube or flying windows as screensaver

atlantis - Cube Atlantis, a Compiz classic

Already fixed and available via current trunk:
==============================================

Cube Add-on (Cube Reflection & Deformation):
http://bazaar.launchpad.net/~compiz-team/compiz/0.9.9/revision/3541

Firepaint:
http://bazaar.launchpad.net/~compiz-team/compiz/0.9.9/revision/3534

Gears

Show Mouse:
http://bazaar.launchpad.net/~compiz-team/compiz/0.9.9/revision/3543

Thumbnail

Wallpaper:
http://bazaar.launchpad.net/~compiz-team/compiz/0.9.9/revision/3548

Wizard:
http://bazaar.launchpad.net/~compiz-team/compiz/0.9.9/revision/3538

Tanker Bob (tankerbob) wrote :
MC Return (mc-return) on 2012-10-20
Changed in compiz:
status: New → Confirmed
Hristian (xfire-best) on 2012-10-20
Changed in compiz:
assignee: nobody → Hristian (xfire-best)
assignee: Hristian (xfire-best) → nobody
Sean Channel (sean-channel) wrote :

+1 boo hoo, me too. It's understandable and probably best to not ship the breaky stuff. Frankly you'll have more headaches than satisfaction from these causing problems if they have any tendency to do that.

..but it sure would be nice to have all that purdy eye candy!

MC Return (mc-return) on 2012-11-20
summary: - Animations and modules missing in Ubuntu 12.10
+ [regression-r3320] Animations and modules/plugins missing in Ubuntu
+ 12.10 and 13.04
tags: added: animationaddon bicubic blur colorfilter cubeaddon gears group loginout quantal raring reflex regression-r3320 stackswitch thumbnail trip wallpaper
MC Return (mc-return) on 2012-11-20
description: updated
Changed in compiz:
importance: Undecided → Wishlist
status: Confirmed → In Progress
milestone: none → 0.9.9.0
assignee: nobody → Sam Spilsbury (smspillaz)
Michael Bitches (bitzesmichail) wrote :

Patch for showmouse ( same bug/patch with firepaint, the two plugins share a lot of code ).

I uploaded a patch for firepaint in https://bugs.launchpad.net/compiz/+bug/1048505

MC Return (mc-return) on 2012-12-29
description: updated
MC Return (mc-return) wrote :

I am not sure if it is a good idea to link branches to this bug, so I will just add the links to branches fixing/re-enabling some of the missing plugins (at least for GL builds) here:

Cube Add-On aka Cube Reflection and Deformation (Thanks a lot, Sam !):
https://code.launchpad.net/~smspillaz/compiz/compiz.feature_1069112.cubeaddon/+merge/141258

Firepaint aka Paint fire on the screen (Thanks a lot, Michail Bitzes !):
https://code.launchpad.net/~mc-return/compiz/compiz.merge-fix1048505-firepaint-does-not-paint-fire/+merge/141453

Screensaver:
https://code.launchpad.net/~mc-return/compiz/compiz0.9.9.merge-plugin-screensaver/+merge/141533

Showmouse aka Show mouse (Thanks a lot, Michail Bitzes !):
https://code.launchpad.net/~mc-return/compiz/compiz.merge-fix1048267-showmouse-does-not-work/+merge/141444

Thumbnail aka Window Previews:
https://code.launchpad.net/~mc-return/compiz/compiz.merge-enable-thumbnail-for-GL-builds/+merge/141554

Wizard:
https://code.launchpad.net/~mc-return/compiz/compiz0.9.9.merge-plugin-wizard/+merge/141459

MC Return (mc-return) on 2013-01-09
description: updated

The attachment "showmouse.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Daniel van Vugt (vanvugt) wrote :

Please treat each plugin as a separate bug. You can find a list of the relevant plugin bugs here:
    https://bugs.launchpad.net/compiz/+bugs?field.tag=gles
and in comment #5 above.

Sorry I chose the status "Invalid" but I don't know how else to mark this bug as duplicate of a dozen different bugs.

Changed in compiz:
status: In Progress → Invalid
Changed in compiz (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.9~daily13.01.14-0ubuntu1

---------------
compiz (1:0.9.9~daily13.01.14-0ubuntu1) raring; urgency=low

  [ sampo555 ]
  * compiz crashed with SIGSEGV in DodgeAnim::applyDodgeTransform() (LP:
    #1048840)
  * compiz crashing if window un-/minimize animation is "Random" (LP:
    #1098185)

  [ Daniel van Vugt ]
  * Several leaks in new GLProgram from compileProgram() from
    GLScreen::getProgram() from GLWindowAutoProgram::getProgram() (LP:
    #1097644)

  [ Sam Spilsbury ]
  * Several leaks in ccsIntegratedSettingListAppend() ... from
    ccsGNOMEIntegrationBackendGetIntegratedSetting() from readSetting
    (gsettings.c:375) (LP: #1097661)

  [ MC Return ]
  * Thumbnail Window Previews: Flickering of background/glow and window
    title text (LP: #1098758)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3561
 -- Automatic PS uploader <email address hidden> Mon, 14 Jan 2013 04:03:09 +0000

Changed in compiz (Ubuntu):
status: Invalid → Fix Released
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Danny Graham (dermidgen) wrote :

There are still several remaining plugins that have not been ported and are still listed for exclusion:

#NOT RELATED TO GLES
* Currently broken and excluded from compilation: animationaddon, bicubic, blur, colorfilter, group, loginout, reflex, stackswitch and trip

#ES2/GLES RELATED
* Currently broken and excluded from compilation: freewins, gears, td, colorfilter, mblur, bench, showrepaint, widget, thumbnail, wizard

As noted https://bugs.launchpad.net/compiz/+bug/1069112/comments/7 - There are still a batch of plugins that generally need to be ported and not all of these are GLES related.

PBQHIEU (phanbqhieu) wrote :

:)

Changed in compiz (Ubuntu):
assignee: nobody → PBQHIEU (phanbqhieu)
MC Return (mc-return) on 2013-06-21
description: updated
description: updated
MC Return (mc-return) on 2013-06-28
Changed in compiz:
status: Invalid → Triaged
Changed in compiz (Ubuntu):
assignee: PBQHIEU (phanbqhieu) → nobody
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers