Menu bar - Shadows are not clipped until animations are finished

Bug #976469 reported by Sam Spilsbury on 2012-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Compiz Animations Plugin
Medium
Sam Spilsbury
Compiz Main Plugins
Medium
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Undecided
Unassigned

Bug Description

See: https://bugs.launchpad.net/compiz-core/+bug/659816/comments/10

"and when you switch between menuitems in the panel you see the shadow appearing on top and then being cut"

The problem is that the animation plugin sets PAINT_WINDOW_TRANSFORMED_MASK even when it doesn't really need it. (Shadow clipping is disabled on transformed windows)

Related branches

Changed in compiz-animation-plugin:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-plugins-main:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.7.2
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-animation-plugin at revision 396

Changed in compiz-animation-plugin:
status: In Progress → Fix Committed
Changed in compiz-plugins-main:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-plugins-main at revision 26

Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
Andrea Cimitan (cimi) wrote :

not fixed for me in unity staging PPA

Andrea Cimitan (cimi) wrote :
Andrea Cimitan (cimi) wrote :
John Lea (johnlea) on 2012-04-10
summary: - Shadows are not clipped until animations are finished
+ Menu bar - Shadows are not clipped until animations are finished
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
Andrea Cimitan (cimi) wrote :

Still seeing it live live is more visible, recording skips frames, but you can see sometimes the shadow even not being clipped.
Daniel, opinions?

If I remember I noticed this before the clipping code went in, it's just more visible now.

Andrea Cimitan (cimi) wrote :

Maybe extending the clip match code mMenusClipGroup (CompMatch ("type=Dock | type=DropdownMenu | type=PopupMenu")) with a unity panel case?

I have the feeling the unity menus lose their type (or something happens) when you switch between them. It could be that unity tells compiz about their type slowly

Daniel van Vugt (vanvugt) wrote :

Cimi, I think this bug is mostly a duplicate of bug 659816, which is _not_ fixed and I commented on yesterday.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.7.0~bzr19-0ubuntu10

---------------
compiz-plugins-main (1:0.9.7.0~bzr19-0ubuntu10) precise; urgency=low

  [ Sam Spilsbury ]
  * debian/patches/fix_963767.patch : fix LP: #963767, scale correctly

  [ Didier Roche ]
  * debian/patches/ubuntu_config.patch:
    Fix typos in animation.xml.in causing mismatched animations of menus and
    tooltips (LP: #977743)
  * debian/patches/fix_976469.patch:
    - Shadows are not clipped until animations are finished (LP: #976469)
  * debian/patches/fix_940603.patch:
    - white box randomly shows up at top left corner blocking applications from
      using stuff under it (LP: #940603)

  [ Oliver Grawert ]
  * update GLES2 patch for latest changes.
  * thanks to Łukasz 'sil2100' Zemczak <email address hidden> for
    merging the packaging changes into the right branches.
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 09:19:07 +0200

Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Main Plugins 0.9.7.2

Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-27
Changed in compiz-animation-plugin:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers