Login settings are not saved

Bug #180132 reported by fi-dschi on 2008-01-03
18
Affects Status Importance Assigned to Milestone
Coccinella
Wishlist
buzzdee

Bug Description

I am only able to log in when password is not sent encrypted, but my server provides ssl. When I restart Coccinella it says it can't connect so I go to the login window and have to switch "unencrypted password" and wncrypted connection back on every time. The login settings should be saved and restored for future sessions.

2008/1/3, fi-dschi <philipp_blau>:
> I am only able to log in when password is not sent encrypted, but my
> server provides ssl. When I restart Coccinella it says it can't connect
> so I go to the login window and have to switch "unencrypted password"
> and wncrypted connection back on every time. The login settings should
> be saved and restored for future sessions.

You have to edit this in the profile editor. The advantage is that
people not accidentally can mess with their profile options. Not sure
if this should be changed and if yes, how. Maybe you have some ideas?

--
Mvg, Sander Devrieze.

OK, thank you. But I still think that it would be better and very much easier to understand and use if the settings in the connect window and the profile settings would always be the same. The most easy would perhaps be if there was only one place to configure these settings.

By the way, just to let you know: I had some problems to open the profile editor, because from where should I know that it is only active when I am not logged in. Perhaps one could solve this problem with the above one.

These both are no logical problems but I think applications should also be as much intuitive as possible.

Regards,
fi-dschi

2008/1/3, fi-dschi <philipp_blau>:
> OK, thank you. But I still think that it would be better and very much
> easier to understand and use if the settings in the connect window and
> the profile settings would always be the same. The most easy would
> perhaps be if there was only one place to configure these settings.

The reason why the login dialog is read-only is that it allows
visitors to connect to their account without altering your profile and
without saving their details. How would you change the dialog without
losing this functionality?

So now I got it. You want visitors of yours to be able to use your coccinella on your pc. That didn't come to my mind until now.

So my suggestion is to add an extra tab or something to the login window which lets the user switch to a temporary login form.
Another idea: Install a dropdown menu on top of the login window which lets you choose out of several already-arranged profiles and also includes an item like "new profile for this session only".

fi-dschi

Mats (matsben) wrote :

I can only agree with the bug reporter that the current solution isn't the best. I'd like to have a single dialog for all this. The problem is that it will clutter the login dialog with at least two more buttons (new/remove profile) and you wont be able to make temporary changes. We used to have an "Edit Profiles" button in the Login dialog but that one was removed.

Mats (matsben) wrote :

The reason the profile editor can't be used while logged in is because when you create a new profile you will be asked to also create a new account at the same time, but we can't have multiple connections.

Mats (matsben) wrote :

Placing the "New/ Profile" in the menu is an idea. That would solve one of the two extra buttons. Maybe also "Delete Profile" could be there, but that is less intuitive.

sander (s-devrieze) wrote :

/me is thinking about a good replacement for both the current Login
dialog and the Edit Profiles dialog. But it is hard, very
hard...suggestions welcome ;-)

You know pidgin? They have a very nice list (not dropdown) of all available profiles alone in one window. By double-clicking on one you can change its preferences. This could be accessible through the menu as "profiles...", another item could be "guest log-in" which opens a login window where nothing is saved.
At the moment I have no time at all but I can't get this issue out of my mind. The coccinella has just succeeded in grabbing my attention :)

sander (s-devrieze) wrote :
Download full text (5.5 KiB)

Ok, this is the idea (warning: you probably need to reread this a few times to understand):

* Remove the Edit profiles entry from the File menu
* Create a special profile called "Guest Login" (or simply "Guest").
* When this Guest profile is selected in the Login dialog, focus will be on the Contact ID field and the whole dialog will look like it looks like now (password field, More... option, etc). The user can configure all options with this special profile. This profile can't be deleted using the interface (only possible when manually editing the config file). The name of this profile should be translatable in other languages.
* The user cannot set a default profile any more. Coccinella always will set the last used profile as the default. Only exception is when the user has enabled auto-login. In this case, the Guest profile *never* will be remembered as last used account.
* The account created in the assistant will thus be the default account initially.
* When a normal user defined profile that does not contain a saved password (not defined by the user) is selected in the Login dialog, only the Password field is showed and the focus change to this field. The Contact ID field and More... should not be showed. Return will simulate pressing on the Login button.
* When a normal user defined profile does contain a password, nothing else will be showed. Thus only the Profile line and the Login and Cancel button will be showed (besides the header and intro text).
* The user should be able to create special predefined profiles like the Google Talk or jabber.org profiles by himself. This can be done by using a variable that consists of illegal characters for a JID (don't know which characters are illegal in a JID). E.g. %<email address hidden>. When a user selects a special profile like this in the Login dialog, the variable %s is replaced by a string (translatable!), e.g. "MyName". For such profiles, the Login dialog will show the Contact ID field and the focus should be in this field. Also, the text "MyName" should be selected so that the user can simply start typing. Normally, such a profile will not contain a saved password and thus also the Password field is showed an is empty. More... is not showed.
* Next to the Profile dropdown list in the Login dialog, there are 3 small icon buttons on the same line (similar size as the show business card icons used in some other dialogs). All these buttons have balloon help texts.
* The first button is the "Edit Profile" button. When the users clicks on this button the currently selected profile in the dropdown list will be selected and an Edit Profile dialog for this selected profile will be opened. This dialog will look similar to the current Edit Profiles dialog with these differences: different intro text, the profile dropdown list is replaced by a text field so that users also can change the profile name (remember Mats that we discussed how to implement this new feature before ;-) ), the Nickname field will be removed (can be done later: this is a PEP feature and should be somewhere else in the interface so that the user can change his nickname at any time...maybe Action menu or the planned presence control ...

Read more...

Sounds good, but as you said: I will have to read it again.

@Sander: Could you please remove my email adress from the posts in which you quoted me (this thread only)? How come that it is displayed? I have set my email to be invisible in launchpad!

sander (s-devrieze) wrote :

It's because I replied to these messages by email. I'll try to contact the Launchpad people as I can't edit comments.

@fi-dschi: As requested, I've had your email address removed from the comments. I'm sorry that it appeared there despite your having chosen to hide your email address elsewhere in Launchpad. We're looking at ways of hiding email addresses in comments for people who have chosen to hide their email address.

Thanks.

sander (s-devrieze) on 2008-03-11
Changed in coccinella:
assignee: nobody → matsben
importance: Undecided → Wishlist
Mats (matsben) wrote :

The login dialog now detects any options changed for a profile and asks if you want to save it. It also makes it possible to enter a new JID and login options which differ from the one associated with the selected profile. Then it asks if you want to creat a new profile with this JID.

Changed in coccinella:
status: New → In Progress
buzzdee (sebastia) wrote :

I think I have the same problem, using Coccinella from SVN in OpenBSD.

In the preferences.rdb, there the profile is saved as:
*profiles: my-server.de {my-server.de username password}

Whatever I change in either the menu, "Profile editor" or in the login window under "More..." e.g. login invisible, Coccinella detects my changes, and asks me to save them to my profile, and I click yes.
However, the profile in the preferences.rdb file is not updated, no -invisible 1 shows up there.
The same with other preferences.

The preferences.rdb file is only updated/saved when I correctly quit Coccinella. When it gets killed, or I press Ctrl-C in the console, the preferences.rdb file is not updated.

I think the preferences.rdb file should be updated/saved immediately after pressing the save button in the profile editor, or when acknowleding on the login window.

buzzdee (sebastia) on 2009-10-14
Changed in coccinella:
milestone: none → 0.96.16
assignee: Mats (matsben) → buzzdee (sebastia)
sander (s-devrieze) wrote :

The advanced login settings are indeed not saved if you enable auto-login; this is a known bug. If you manually log in, all works correctly AFAIK.

"I think the preferences.rdb file should be updated/saved immediately after pressing the save button in the profile editor, or when acknowleding on the login window."

+1. I also think it may be interesting to apply changes on-the-fly as in Gnome and Mac OS X (no Save button needed).

buzzdee (sebastia) wrote :

After some research I think, the Profile Editor was at some Point embedded in the Preferences, and then later it became an own window.
As long as the Profile Editor was embedded in the Preferences Window, Clicking there on Save, the ::PrefUtils::SaveToFile was called from ::Preferences::SavePushBt.

Since it was moved out "stand alone" accessible from the file menu, the call to PrefUtils::SaveToFile was not done.

in svn revison #2753 I added a call to ::PrefUtils::SaveToFile in the ::Profiles::SaveDlg method.

Regarding applying changes on the fly, I'm not sure whether this is necessary/all good?
Actually, I want to press the save button, when I want to save sth. and want to press cancel otherwise ;)
At least, this should then be done everywhere in the application, and not only for the Profiles.

Changed in coccinella:
status: In Progress → Fix Committed
buzzdee (sebastia) wrote :

svn revision #2754 now also immediately saves the profile after making changes to the profile on Login.
When the user is asked about whether to save the changes to his profile.

buzzdee (sebastia) on 2009-12-03
Changed in coccinella:
status: Fix Committed → Fix Released
sander (s-devrieze) wrote :

"Regarding applying changes on the fly, I'm not sure whether this is necessary/all good?
Actually, I want to press the save button, when I want to save sth. and want to press cancel otherwise ;)"

See: http://developer.gnome.org/projects/gup/hig/2.0/windows-utility.html

An additional idea is to change the functionality of the "Factory Defaults" button so that *only* the current preferences windows is reset to the default settings, instead of changing everything.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers