netplan render drops bridge_stp setting

Bug #1721157 reported by Ryan Harper on 2017-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
High
Unassigned
cloud-init (Ubuntu)
Medium
Unassigned

Bug Description

cloud-init tip fails to render a netplan bridge configuration with a stp value.

% cat network_configs/bridge-simple.yaml
showtrace: true
network:
    version: 1
    config:
        # Physical interfaces.
        - type: physical
          name: eth0
          mac_address: "52:54:00:12:34:00"
          subnets:
              - type: dhcp4
        - type: physical
          name: eth1
          mac_address: "52:54:00:12:34:02"
        # Bridge
        - type: bridge
          name: br0
          bridge_interfaces:
            - eth1
          params:
              bridge_fd: 150
              bridge_stp: 'off'

Currently renders a netplan config of:

network:
    version: 2
    ethernets:
        eth0:
            dhcp4: true
            match:
                macaddress: '52:54:00:12:34:00'
            set-name: eth0
        eth1:
            match:
                macaddress: '52:54:00:12:34:02'
            set-name: eth1
    bridges:
        br0:
            interfaces:
            - eth1
            parameters:
                forward-delay: 150

netplan in artful with bridge stp support enables STP by default (unless disabled)
This prevents setting some values of forward-delay. In any case, we should translate
the bridge_stp value to the netplan boolean.

Related branches

Ryan Harper (raharper) wrote :

I filed this thinking systemd/networkd was broken, but learned a little more about ForwardDelay and STP, but turns out it was behaving correctly though it wasn't obvious. For reference (bug is invald)

https://bugs.launchpad.net/cloud-init/+bug/1721157

Joshua Powers (powersj) on 2017-10-04
Changed in cloud-init:
status: New → Confirmed
importance: Undecided → High
Scott Moser (smoser) on 2017-10-05
Changed in cloud-init (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in cloud-init:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 17.1-17-g45d361cb-0ubuntu1

---------------
cloud-init (17.1-17-g45d361cb-0ubuntu1) artful; urgency=medium

  * New upstream snapshot.
    - net: Handle bridge stp values of 0 and convert to boolean type
      [Chad Smith]
    - tools: Give specific --abbrev=8 to "git describe"
    - network: bridge_stp value not always correct [Ryan Harper] (LP: #1721157)
    - tests: re-enable tox with nocloud-kvm support [Joshua Powers]

 -- Ryan Harper <email address hidden> Thu, 05 Oct 2017 16:15:34 -0500

Changed in cloud-init (Ubuntu):
status: Confirmed → Fix Released

This bug is believed to be fixed in cloud-init in 1705804. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers