Comment 11 for bug 1690430

Ryan Harper (raharper) wrote :

In addition to the above covering (a) of the SRU tests, on Azure, we've tested the following observing no failures.

(b) Azure (upgrade instance with no sriov devices and reboot)
    1. ssh in, add proposed, install cloud-init, reboot
    2. ssh in and check for errors

(c1) Azure (launch sriov instance, upgrade cloud-init, reboot)
    1. ssh in
    2. confirm sriov by precense of second nic (mlx4_core driver)
    3. add xenial-proposed, apt update and apt install cloud-init, reboot
    4. ssh in and check for errors

(c2) Azure (launch sriov instance with captured image using upgraded cloud-init)
    1. Use c1, remove /var/lib/cloud /var/lib/waagent /var/log/cloud-init*
       /etc/network/interfaces.d/50-cloud-init.cfg
       /etc/udev/rules.d/70-persistent-net.rules
       /etc/systemd/network/50-cloud-init.link
    2. capture image in portal
    3. create new image from template for fresh boot of cloud-init from proposed
    4. ssh into instance
    5. confirm sriov by precense of second nic (mlx4_core driver

(d) Azure (launch non-sriov instance with captured image using upgraded cloud-init)
    1. Use b, remove /var/lib/cloud /var/lib/waagent /var/log/cloud-init*
       /etc/network/interfaces.d/50-cloud-init.cfg
       /etc/udev/rules.d/70-persistent-net.rules
       /etc/systemd/network/50-cloud-init.link
    2. capture image in portal
    3. create new image from template for fresh boot of cloud-init from proposed
    4. ssh into instance