click-update-manager fails to run tests against Qt 5.2

Bug #1271172 reported by Timo Jyrinki on 2014-01-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Click Update Manager
Undecided
Timo Jyrinki
click-update-manager (Ubuntu)
High
Timo Jyrinki

Bug Description

The tests need to be run in headless mode successfully.

Update: minimal platform plugin seemingly not needed in this case.

Related branches

Changed in click-update-manager:
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: New → In Progress
Bill Filler (bfiller) on 2014-01-21
Changed in click-update-manager (Ubuntu):
assignee: nobody → Roberto Alsina (ralsina)
status: New → In Progress
importance: Undecided → High

The Click Updates are being integrated into SystemSettings/Updates, the functionality should be moved completely into system settings, and this project won't longer be needed.
A branch is already proposed and should be landing this week.

dobey (dobey) wrote :

Timo, when filing bug reports, please actually describe the problem, and not simply suggest a fix. For example, actually including the block of the build log that shows the failure, in the description, would go a long way to understanding *why* the change is needed. Simply stating it is needed, doesn't provide any useful information to other developers.

Timo Jyrinki (timo-jyrinki) wrote :

Hmm, sorry, this bug indeed does not have the link either here or in the merge request. This was identical to the linked gsettings-qt bug in symptoms so I guess that's why I managed to omit the log link in a hurry.

The build log is here:
https://launchpadlibrarian.net/162998333/buildlog_ubuntu-trusty-i386.click-update-manager_1%3A0.1%2B13.10.20131007-0~37%2B201401211001~ubuntu14.04.1_FAILEDTOBUILD.txt.gz

Which seems similar to the gsettings-qt bug https://bugs.launchpad.net/gsettings-qt/+bug/1259145, and I indeed tested the merge proposal at https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+build/5484663

dobey (dobey) wrote :

What about the warnings from Qt that occur there now:

QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?
QWARN : qmltestrunner::PageUpdate::test_check_children() QFontDatabase: Cannot find font directory '/usr/lib/i386-linux-gnu/fonts' - is Qt installed correctly?

What does setting the platform to "minimal" actually do there? Would not adding "-screen 0 640x480x24" to the xvfb-run args list, be a better fix?

Timo Jyrinki (timo-jyrinki) wrote :

The warnings are because the minimal plugin does not use fontconfig but falls back to another method, QTBUG-36243.

summary: - click-update-manager fails to run tests against Qt 5.2, use
- QT_QPA_PLATFORM=minimal
+ click-update-manager fails to run tests against Qt 5.2
description: updated
dobey (dobey) on 2014-01-24
Changed in click-update-manager (Ubuntu):
assignee: Roberto Alsina (ralsina) → Timo Jyrinki (timo-jyrinki)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:click-update-manager at revision 38, scheduled for release in click-update-manager, milestone Unknown

Changed in click-update-manager:
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

Confirmed to be fixed, it was just that the PPA recipe build had failed due to infrastructure once. Now seems all correct: https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+sourcepub/3945609/+listing-archive-extra

Changed in click-update-manager (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click-update-manager - 0.1+14.04.20140306-0ubuntu1

---------------
click-update-manager (0.1+14.04.20140306-0ubuntu1) trusty; urgency=low

  [ CI bot ]
  * No change rebuild against Qt 5.2.1.

  [ Diego Sarmentero ]
  * change modelChanged for updateAvailableFound. To run the tests you
    need to have the last branch of lp:clickmanager-plugin installed.
  * Show "Updates Not Found" not as title. (LP: #1232117)
  * Show app size in the proper way (BUG: #1232256). (LP: #1232256)
  * Fix desktop file to show icon in launcher. (LP: #1238835)

  [ Timo Jyrinki ]
  * Use xvfb -screen 0 640x480x24 for running tests. (LP: #1271172).
    (LP: #1271172)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Leo Arias ]
  * Cleaned the autopilot test cases. (LP: #1234379)
 -- Ubuntu daily release <email address hidden> Thu, 06 Mar 2014 10:37:32 +0000

Changed in click-update-manager (Ubuntu):
status: Fix Committed → Fix Released
Changed in click-update-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers