cinder.tests.keymgr.test_barbican fails with barbicanclient 3.0.0

Bug #1388461 reported by Alan Pevec
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Cinder
Fix Released
Critical
Brianna Poulos
Juno
Fix Released
Critical
Brianna Poulos

Bug Description

  File "cinder/tests/keymgr/test_barbican.py", line 25, in <module>
    from barbicanclient.common import auth
ImportError: cannot import name auth

auth was removed in "Refactored Client to use Keystone Sessions"
http://git.openstack.org/cgit/openstack/python-barbicanclient/commit/?id=ddec180c419132589fac4d689ec1904b1b698f24

Revision history for this message
Alan Pevec (apevec) wrote :
Revision history for this message
Brianna Poulos (brianna-poulos) wrote :

Thank you for assigning the bug to me. I will update test_barbican.py and barbican.py in cinder to work with the new barbican client (3.0.0) this week.

Revision history for this message
Juan Antonio Osorio Robles (juan-osorio-robles) wrote :

python-barbicanclient has been fixed to support the global requirements, and the fix is available as of python-barbicanclient 3.0.1

Revision history for this message
Ihar Hrachyshka (ihar-hrachyshka) wrote :

I see the failure with python-barbicanclient 3.0.1 here: http://logs.openstack.org/periodic-stable/periodic-cinder-python26-juno/37e6324/console.html

Is there more work to do/patches to merge to fix it?

Revision history for this message
Brianna Poulos (brianna-poulos) wrote :

I am working on a patch to fix this, which I will submit by the end of this week.

Revision history for this message
Jay Bryant (jsbryant) wrote :

Cinder needed this fixed ASAP so we merged patches for master and Juno under this bug: https://bugs.launchpad.net/cinder/+bug/1389419

Revision history for this message
Brianna Poulos (brianna-poulos) wrote :

Thank you for pointing to the other bug. I apologize for the problems with the unit test. I will use this bug to update the unit test to not rely on barbican client, and update barbican.py so that it works with version 3.0.0. (Unless it would be better to separate the two).

Revision history for this message
John Griffith (john-griffith) wrote : Re: [Bug 1388461] Re: cinder.tests.keymgr.test_barbican fails with barbicanclient 3.0.0

No problem at all. Yeah, using that bug and combining the work should be
fine.

Thanks,
John
On Nov 5, 2014 5:55 PM, "Brianna Poulos" <email address hidden> wrote:

> Thank you for pointing to the other bug. I apologize for the problems
> with the unit test. I will use this bug to update the unit test to not
> rely on barbican client, and update barbican.py so that it works with
> version 3.0.0. (Unless it would be better to separate the two).
>
> --
> You received this bug notification because you are a member of Cinder
> Bug Team, which is subscribed to Cinder.
> https://bugs.launchpad.net/bugs/1388461
>
> Title:
> cinder.tests.keymgr.test_barbican fails with barbicanclient 3.0.0
>
> Status in Cinder:
> Confirmed
> Status in Cinder juno series:
> Confirmed
>
> Bug description:
> File "cinder/tests/keymgr/test_barbican.py", line 25, in <module>
> from barbicanclient.common import auth
> ImportError: cannot import name auth
>
> auth was removed in "Refactored Client to use Keystone Sessions"
>
> http://git.openstack.org/cgit/openstack/python-barbicanclient/commit/?id=ddec180c419132589fac4d689ec1904b1b698f24
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cinder/+bug/1388461/+subscriptions
>

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to cinder (master)

Fix proposed to branch: master
Review: https://review.openstack.org/133113

Changed in cinder:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to cinder (master)

Reviewed: https://review.openstack.org/133113
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=2d52d4177ca7cf41ee8162f07e444d9b75c377dd
Submitter: Jenkins
Branch: master

commit 2d52d4177ca7cf41ee8162f07e444d9b75c377dd
Author: Brianna Poulos <email address hidden>
Date: Thu Nov 6 13:07:16 2014 -0800

    Fix wrapper to work with barbicanclient 3.0.1

    Due to the updates to the python-barbicanclient in version 3.0.1, the cinder
    barbican wrapper no longer functions. This patch updates the cinder barbican
    wrapper and test cases to work with barbicanclient 3.0.1.

    Change-Id: Ibef4abd5fd9b12962420eaa5d7ebf62700171861
    Closes-Bug: #1388461

Changed in cinder:
status: In Progress → Fix Committed
Revision history for this message
Brianna Poulos (brianna-poulos) wrote :

Should this same fix be added to Juno as well?

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to cinder (stable/juno)

Fix proposed to branch: stable/juno
Review: https://review.openstack.org/135336

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to cinder (stable/juno)

Reviewed: https://review.openstack.org/135336
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=fd323fed3562b3f7d2a4b044c0854fe007c1a3d0
Submitter: Jenkins
Branch: stable/juno

commit fd323fed3562b3f7d2a4b044c0854fe007c1a3d0
Author: Brianna Poulos <email address hidden>
Date: Thu Nov 6 13:07:16 2014 -0800

    Fix wrapper to work with barbicanclient 3.0.1

    Due to the updates to the python-barbicanclient in version 3.0.1, the cinder
    barbican wrapper no longer functions. This patch updates the cinder barbican
    wrapper and test cases to work with barbicanclient 3.0.1.

    Change-Id: Ibef4abd5fd9b12962420eaa5d7ebf62700171861
    Closes-Bug: #1388461
    (cherry picked from commit 2d52d4177ca7cf41ee8162f07e444d9b75c377dd)

Alan Pevec (apevec)
tags: removed: juno-backport-candidate
Thierry Carrez (ttx)
Changed in cinder:
milestone: none → kilo-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in cinder:
milestone: kilo-1 → 2015.1.0
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers