GPFS Driver should check version level on startup

Bug #1204266 reported by Bill Owen on 2013-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Low
Bill Owen

Bug Description

The gpfs driver makes heavy use of mmclone command. This command was added fairly recently. The GPFS driver should verify that the GPFS cluster is operating at a level that supports mmclone at startup during prerequisite checking in check_for_setup_error.

Bill Owen (billowen) on 2013-07-23
Changed in cinder:
assignee: nobody → Bill Owen (billowen)
Changed in cinder:
importance: Undecided → Low
status: New → In Progress

Reviewed: https://review.openstack.org/40262
Committed: http://github.com/openstack/cinder/commit/4696390be43dcac2598c99d4f0ea3d6cc2f8f75d
Submitter: Jenkins
Branch: master

commit 4696390be43dcac2598c99d4f0ea3d6cc2f8f75d
Author: Bill Owen <email address hidden>
Date: Mon Aug 5 11:32:27 2013 -0700

    GPFS Verify min release level for mmclone command

    The gpfs driver makes heavy use of mmclone command. This command
    was added fairly recently. Verify that the GPFS cluster is operating
    at a level that supports mmclone at startup during prerequisite
    checking in check_for_setup_error.

    Need to verify:
    1. That gpfs cluster is at required level
    2. That filesystem(s) are also operating at required level.

    Change-Id: Ie71d0b814d77b544e1a456d110882c1a02a5b2e5
    Fixes: bug #1204266

Changed in cinder:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-09-05
Changed in cinder:
milestone: none → havana-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in cinder:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers