crash in en_US locale for non-sudoer user

Bug #1501565 reported by Mamoru TASAKA on 2015-10-01
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Catfish
Fix Released
Undecided
Unassigned
catfish (Fedora)
Fix Released
Undecided
catfish (Ubuntu)
Undecided
Unassigned

Bug Description

With catfish 1.3.2, in LANG=en_US.utf8, when user is not in sudoer list, catfish won't launch like

CatfishWindow.py:258:finish_initializing:AttributeError: 'NoneType' object has no attribute 'hide'

Traceback (most recent call last):
  File "/usr/share/catfish/bin/catfish.py", line 44, in <module>
    catfish.main()
  File "/usr/share/catfish/catfish/__init__.py", line 73, in main
    window = CatfishWindow.CatfishWindow()
  File "/usr/share/catfish/catfish_lib/Window.py", line 170, in __new__
    new_object.finish_initializing(builder)
  File "/usr/share/catfish/catfish/CatfishWindow.py", line 258, in finish_initializing
    menuitem.hide()
AttributeError: 'NoneType' object has no attribute 'hide'

Because catfish/CatfishWindow.py says:
   221 menuitem = builder.get_named_object("menus.application.update")

catfish_lib/Window.py says:
     51 "menus": {
     52 # Application (AppMenu)
     53 "application": {
      60 "update": "application_menu_update"

But the corresponding object is not defined in data/ui/CatfishWindow.ui

When I try to open catfish, I see nothing.

So,I tried opening it from the terminal and got this -

mukundan @ imladris ~$ catfish
/usr/share/catfish/catfish/__init__.py:23: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk # pylint: disable=E0611
/usr/bin/locate

(catfish.py:3508): Gtk-WARNING **: gtkwidget.c:8463: widget not within a GtkWindow
Traceback (most recent call last):
  File "/usr/share/catfish/bin/catfish.py", line 44, in <module>
    catfish.main()
  File "/usr/share/catfish/catfish/__init__.py", line 73, in main
    window = CatfishWindow.CatfishWindow()
  File "/usr/share/catfish/catfish_lib/Window.py", line 170, in __new__
    new_object.finish_initializing(builder)
  File "/usr/share/catfish/catfish/CatfishWindow.py", line 258, in finish_initializing
    menuitem.hide()
AttributeError: 'NoneType' object has no attribute 'hide'

$ rpm -qa catfish
catfish-1.3.2-1.fc23.noarch

I cannot reproduce this.
* First of all, would you attach the result of
  $ rpm -qa | sort
?

* Also, would you attach the result of
  $ strace -s 1000 catfish
?

Can you reproduce this even if you create new user and login to the new user?

Created attachment 1078075
strace output

I got the crash when I opened catfish for the first time ever .. So, it was a new user.

(In reply to Mukundan Ragavan from comment #4)
> I got the crash when I opened catfish for the first time ever .. So, it was
> a new user.

Well, that does not mean it is a new user. Would you try creating a new user now and test this is still reproducible on the new user?

Also, would you attach the result of $ rpm -qa | sort ?

Created attachment 1078089
list of installed packages

Yes. I can reproduce this on a new user *AND* on another system.

list od packages attached.

$ cat all-pkgs.out | wc -l
6870

Oh, maybe if you add yourself to sudoers, this error disappears?

*** Bug 1267480 has been marked as a duplicate of this bug. ***

catfish-1.3.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-66b4e8da17

Yup! This works!

Thanks for the quick fix.

catfish-1.3.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update catfish'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-66b4e8da17

catfish-1.3.2-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Thank you for testing. Now the fixed package is pushed.

rezso (rezso) wrote :

Thank you, it works.

Kev Bowring (flocculant) wrote :

confirmed Xubuntu test user

Changed in catfish-search:
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1501565

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in catfish (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre) wrote :
Changed in catfish-search:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.3.3-0ubuntu2

---------------
catfish (1.3.3-0ubuntu2) wily; urgency=medium

  * Add patches from upstream to fix startup and runtime crashes.
  * debian/patches:
    - xubuntu-lp1501565.patch (LP: #1501565)
    - xubuntu-lp1507765.patch (LP: #1507765)

 -- Sean Davis <email address hidden> Mon, 19 Oct 2015 22:02:26 -0400

Changed in catfish (Ubuntu):
status: Confirmed → Fix Released
Sean Davis (bluesabre) on 2016-01-31
Changed in catfish-search:
milestone: none → 1.3.4
status: Fix Committed → Fix Released
Changed in catfish (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.