Contains embedded copy of pexpect

Bug #1257500 reported by Andrew Starr-Bochicchio on 2013-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Catfish
Undecided
Sean Davis
catfish (Ubuntu)
Undecided
Unassigned

Bug Description

catfish ships an embedded copy of the python module pexpect. It would be much better to just depend on the python-pexpect package available in the archive.

Sean Davis (bluesabre) wrote :

This was because the upstream pexpect did not support python3. It looks like it was finally rolled in last month (python-pexpect), so I'll update the package soon (when debian/ubuntu get the updated package).

Changed in catfish (Ubuntu):
status: New → Confirmed
Sean Davis (bluesabre) wrote :

A fix for this has been committed, and will be included in the next release.

Changed in catfish-search:
status: New → Fix Committed
assignee: nobody → Sean Davis (smd-seandavis)
Sean Davis (bluesabre) on 2014-02-05
Changed in catfish-search:
milestone: none → 1.0.0
Sean Davis (bluesabre) wrote :

Fixed in Catfish 1.0.0

Changed in catfish-search:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.0.0-1

---------------
catfish (1.0.0-1) unstable; urgency=medium

  * Team upload.

  [ Jackson Doak ]
  * New upstream release. Closes: #589777, #598598 LP: #1257500, #1258713
  * Replace Depends: locate with Recommends: mlocate | locate. Closes: #731363
  * Bump standards-version to 3.9.5

  [ Vincent Cheng ]
  * Drop debian/catfish.1 and use upstream manpage instead.

 -- Vincent Cheng <email address hidden> Tue, 04 Feb 2014 21:03:50 -0800

Changed in catfish (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers