unity-system-compositor crash, no interaction on windowed mode

Bug #1511095 reported by kevin gunn on 2015-10-28
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical Pocket Desktop
High
kevin gunn
Mir
Fix Released
High
Alexandros Frantzis
0.17
Fix Released
High
Unassigned
mir (Ubuntu)
High
Unassigned

Bug Description

I am seeing this occur with Nexus7 (i haven't tested with nexus4 enough to say)
but I regularly see N7 reboot with me having interacted with it

I will have usually connected the BT mouse and have maybe u-s-s open as well as dash (i think i've even seen it do so after just being rebooted with me not touching it before the next reboot).
the screen will be on or off from being idel, no interaction per se and the device will suddenly display the "spinner" screen which is actually ubuntu dot-dot-dots

I have seen it enough to confirm there are no crash files generated/associated with it

lastly, i have seen this mostly while i have added silo21 (unity8 improvements) on top of the latest pd image.

attached is a syslog

Related branches

kevin gunn (kgunn72) wrote :
kevin gunn (kgunn72) wrote :

unity8 log post reboot

kevin gunn (kgunn72) wrote :

unity8 log leading up to reboot

kevin gunn (kgunn72) wrote :

dmesg post reboot

kevin gunn (kgunn72) wrote :

dmesg leading up to reboot

Changed in canonical-pocket-desktop:
assignee: nobody → kevin gunn (kgunn72)
kevin gunn (kgunn72) wrote :

also i can't help but think it sort of feels like alan's description of this bug 1507518

kevin gunn (kgunn72) wrote :

as for frequency, I would say it's a little random, but seems to happen a few times per boot - i'm not always eyes on the device, but it feels like ~30 to 1 hr this happens

kevin gunn (kgunn72) wrote :

I'm pretty convinced this bug is actually this bug 1511092

Gerry Boland (gerboland) wrote :

Device reboot a bad thing. The output of "adb shell /system/bin/logcat" around the time of the reboot may be valuable (might indicate GPU reset, bringing down everything with it)

kevin gunn (kgunn72) wrote :
Download full text (31.2 KiB)

OK, i'm lucky...i literally just saw it happen with adb up...and here's the spew

kg@kg-MacBookPro:~$ adb shell /system/bin/logcat
--------- beginning of /dev/alog/main
D/audio_hw_primary( 1712): adev_open: enter
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_INITIALIZE
E/ ( 1712): [ACDB RTC]->rtc init done!->result [0]
D/Diag_Lib( 1712): actp_diag_init: call diag init function with AD844209
E/ ( 1712): [ACDB ACPH]->actp diag init done!
D/ACDB-LOADER( 1712): No existing ION info in ACDB driver
D/ACDB-LOADER( 1712): ACDB -> ION_IOC_ALLOC
D/ACDB-LOADER( 1712): ACDB -> ION_IOC_SHARE
D/ACDB-LOADER( 1712): ACDB -> MMAP ADDR
D/ACDB-LOADER( 1712): ACDB -> register MEM to ACDB driver: 0xad64a000
D/ACDB-LOADER( 1712): ACDB -> send_asm_topology
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_GET_AUDPROC_STREAM_TOPOLOGY_ID
D/ACDB-LOADER( 1712): send mbhc data
D/ACDB-LOADER( 1712): send tabla anc data
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_GET_ANC_SETTING
D/ACDB-LOADER( 1712): done with conversion, anc config size is 148
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_GET_ANC_SETTING
D/ACDB-LOADER( 1712): done with conversion, anc config size is 148
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_GET_ANC_SETTING
D/ACDB-LOADER( 1712): done with conversion, anc config size is 148
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_GET_ANC_SETTING
D/ACDB-LOADER( 1712): done with conversion, anc config size is 148
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_GET_ANC_SETTING
D/ACDB-LOADER( 1712): done with conversion, anc config size is 74
D/ACDB-LOADER( 1712): ACDB -> ACDB_CMD_GET_ANC_SETTING
D/ACDB-LOADER( 1712): done with conversion, anc config size is 74
D/ACDB-LOADER( 1712): ACDB -> init done!
D/ ( 1712): csd_client_init
E/ ( 1712): csd_client_service_init: Invalid rx device 0, setting to handset
E/ ( 1712): csd_client_service_init: Invalid tx device 0, setting to handset
E/QMI_FW ( 1712): QMUXD: Service_id=20 not found over conn_id=0
E/QMI_FW ( 1712): QMUXD: Service_id=20 not found over conn_id=0
E/QMI_FW ( 1712): QMUXD: Service_id=20 not found over conn_id=0
E/QMI_FW ( 1712): QMUXD: Service_id=20 not found over conn_id=0
E/QMI_FW ( 1712): QMUXD: Service_id=20 not found over conn_id=0
I/audio_hw_primary( 1712): out_set_parameters: enter: usecase(1: low-latency-playback) kvpairs: routing=2;
I/audio_hw_primary( 1712): out_set_parameters: exit: code(1)
I/audio_hw_primary( 1712): select_devices: enter - uc_id 1
I/audio_hw_primary( 1712): select_devices: VOICE_CALL is active
D/audio_hw_primary( 1712): select_devices: out_snd_device(2: speaker) in_snd_device(0: )
D/ACDB-LOADER( 1712): ACDB -> send_afe_cal
I/audio_hw_primary( 1712): select_devices: exit
I/audio_hw_primary( 1712): select_devices: enter - uc_id 4
I/audio_hw_primary( 1712): select_devices: VOICE_CALL is active
D/audio_hw_primary( 1712): select_devices: out_snd_device(0: ) in_snd_device(15: handset-mic)
E/ACDB-LOADER( 1712): Error: ACDB AudProc vol returned = -8
I/audio_hw_primary( 1712): select_devices: exit
D/libEGL ( 2637): loaded /system/lib/egl/libEGL_adreno.so
D/libEGL ( 2637): loaded /system/lib/egl/libGLESv1_CM_adreno.so
D/libEGL ( 2637): loaded /system/lib/egl/libGLESv2_adreno.so
I/Adreno-EGL( 2637)...

kevin gunn (kgunn72) wrote :

also had all the dbg symbols loaded and caught the u-s-c crash file created at the exact same time

summary: - random reboots with windowed mode (no monitor attached)
+ unity-system-compositor crash, no interaction on windowed mode
Changed in canonical-pocket-desktop:
importance: Undecided → High
Changed in mir (Ubuntu):
importance: Undecided → High
Changed in qtmir (Ubuntu):
importance: Undecided → High
Changed in unity-system-compositor (Ubuntu):
importance: Undecided → High
Changed in unity8 (Ubuntu):
importance: Undecided → High

The stack trace shows a crash in mi::DisplayInputRegion::bounding_rectangle() because we don't have any displays in the region. A fix for the immediate crash is at:

https://code.launchpad.net/~afrantzis/mir/maybe-fix-1511095-for-0.17/

From the supplied info I can't tell if not having any detected active displays is a valid situation or it's indeed a problem and the root cause of what we are seeing. Whatever the case we shouldn't crash like this, so this fix is a definite improvement, even if it turns out not to be a final fix.

Changed in mir:
assignee: nobody → Alexandros Frantzis (afrantzis)
status: New → In Progress
importance: Undecided → High
milestone: none → 0.18.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.18.0

Changed in mir:
status: In Progress → Fix Committed
kevin gunn (kgunn72) on 2015-11-06
Changed in canonical-pocket-desktop:
status: New → Fix Committed
Changed in mir (Ubuntu):
status: New → Fix Committed
no longer affects: qtmir (Ubuntu)
no longer affects: unity-system-compositor (Ubuntu)
no longer affects: unity8 (Ubuntu)
Launchpad Janitor (janitor) wrote :
Download full text (152.7 KiB)

This bug was fixed in the package mir - 0.17.1+16.04.20151105.1-0ubuntu1

---------------
mir (0.17.1+16.04.20151105.1-0ubuntu1) xenial; urgency=medium

  [ Alberto Aguirre ]
  * New upstream release 0.17.1 (https://launchpad.net/mir/+milestone/0.17.1)
    - No ABI changes. Bug fix release only.
    - Bugs fixed:
      . compositing never stops when external monitor is connected
        (LP: #1499039)
      . half screen on external monitor (LP: #1511538)
      . Nested servers don't apply their display configuration at startup
        (LP: #1492269)
      . libmircookie1 package does not list libnettle as dependency
        (LP: #1513225)
      . unity-system-compositor crash, no interaction on windowed mode
        (LP: #1511095)
      . mir_connection_get_egl_pixel_format() crashes (LP: #1510218)
      . [regression] mir-client-platform-mesa-dev pkg-config file dropped
        (LP: #1509005)

  [ CI Train Bot ]
  * New rebuild forced.

mir (0.17.0+15.10.20151008.2-0ubuntu1) wily; urgency=medium

  [ Alexandros Frantzis ]
  * New upstream release 0.17.0 (https://launchpad.net/mir/+milestone/0.17.0)
    - ABI summary: Only servers and graphics drivers need rebuilding;
      . Mirclient ABI unchanged at 9
      . Mirserver ABI bumped to 35
      . Mircommon ABI unchanged at 5
      . Mirplatform ABI bumped to 11
      . Mirprotobuf ABI bumped to 3
      . Mirplatformgraphics ABI bumped to 6
      . Mirclientplatform ABI unchanged at 3
    - Enhancements:
      . Introduce libmircookie, a simple mechanism for a group of cooperating
        processes to hand out and verify difficult-to-forge timestamps to
        untrusted 3rd parties.
      . More refactorings to support renderers other than GL.
      . Add MirBlob to the client API - a tool for serializing and
        deserializing data.
      . Introduce a libinput based input platform, not yet used by default.
      . Provide a mechanism for the shell to send events on surface
        construction.
      . Provide mir::shell::DisplayConfigurationController allowing shells
        to correctly change the display configuration, notifying clients
        as appropriate.
      . New DSO versioning guide.
      . Send events pertaining to the output a surface is currently on (dpi,
        form factor, scale) to clients.
    - Bug fixes:
      . [enhancement] XMir specific documentation should live in its own
        subsection (LP: #1200114)
      . Nested servers need cursor support (LP: #1289072)
      . Mir cursor is missing/invisible until the client sets it multiple
        times (LP: #1308133)
      . [regression] Fullscreen software surfaces (like Xmir -sw) can crash
        the Mir server (LP: #1493721)
      . [usc] Mir gives up and shuts down due to input with multimonitor qtmir
        (std::exception::what: Failure sending input event) (LP: #1496069)
      . Mouse cursor disappears upon entering the surface area of a nested
        client (LP: #1496849)
      . [android] input is not dispatched when attaching an external monitor
        (LP: #1498045)
      . [android] input coordinates are scaled incorrectly when an external
        display is connected (LP: #1498540)
      . [andro...

Changed in mir (Ubuntu):
status: Fix Committed → Fix Released
Kevin DuBois (kdub) on 2015-12-22
Changed in canonical-pocket-desktop:
status: Fix Committed → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers