Fails to pair with Bose QC35 headphones

Bug #1620636 reported by Jim Hodapp on 2016-09-06
98
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Jim Hodapp
bluez (Ubuntu)
High
Unassigned

Bug Description

I am unable to pair the Bose QC35 BT headphones with Ubuntu, either Ubuntu desktop running 16.04 LTS with bluez 5.37 (also tried bluez 5.41 from installed from yakkety archive), nor using Ubuntu Touch rc-proposed build for Turbo #174. I'm trying to pair through the normal bluetooth control panel brought up through the bluetooth indicator.

I've attached some logs that show it failing to pair. If I can provide anymore useful information about the headphones, please let me know.

Syslog with bluetoothd debugging enabled:
http://pastebin.ubuntu.com/23141394/

btmon output:
http://pastebin.ubuntu.com/23141446/

bluetoothctl output:
http://pastebin.ubuntu.com/23141510/

With Linux kernel 4.8.0 and bluez 4.52:
---------------------------------------

bluetoothctl: http://pastebin.ubuntu.com/23256457/
btmon: http://pastebin.ubuntu.com/23256471/

According to information here http://unix.stackexchange.com/questions/292189/pairing-bose-qc-35-over-bluetooth-on-fedora this might be due to not yet supported feature from BlueZ however this needs a further checking.

Might be that the kernels since 3.19 have this included: http://www.bluez.org/bluetooth-4-2-features-going-to-the-3-19-kernel-release/

Jim Hodapp (jhodapp) on 2016-09-30
description: updated
description: updated
Changed in bluez (Ubuntu):
assignee: nobody → Konrad Zapałowicz (kzapalowicz)
Jim Hodapp (jhodapp) on 2016-09-30
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
importance: Undecided → High
Changed in bluez (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Triaged
Changed in bluez (Ubuntu):
status: New → In Progress
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Robin Sheat (eythian) wrote :

Following the instructions here: http://askubuntu.com/questions/833322/pair-bose-quietcomfort-35-with-ubuntu-16-04-over-bluetooth I managed to make it pair and appear as an audio device.

While playback technically worked, it wasn't useable as it came across as though there wasn't enough bandwidth - the audio was choppy and got delayed. It seemed that pulse gave up sending to it after a point, and nothing would play back then.

Jim Hodapp (jhodapp) wrote :

@Robin: Yeah I've been able to get mine working as well. Were you trying with Ubuntu desktop or on Ubuntu Touch? The choppiness seems to be bluez doing other device scans. So on Touch, if you make sure that system settings is in the background, it should remain nearly chop-free. On the desktop, it stopped scanning if I closed system settings and then got a lot better quality.

Robin Sheat (eythian) wrote :

This is ubuntu desktop. I found that if I did:

sudo hciconfig hci0 lp HOLD,SNIFF

while everything was disconnected, then the audio started working properly.

Now I'm back here because after a reboot it wouldn't connect at all, so I guess I need to fix the pairing or something.

Jim Hodapp (jhodapp) wrote :

@Robin: yeah after a reboot or after simply turning the headphones on and off again, pairing doesn't work. I need to use the Bose Connect app on my phone to delete the remembered pairing, delete it from Ubuntu, and add a new pairing from the app and pair from Ubuntu. Only then does it work.

Alexis Laporte (alexis-laporte) wrote :

I have a Sony MDR 1000X, which is similar to the Bose.

I have the same problem and tried the solutions people here mentionned (I had the same choppy streaming when forcing ControllerMode = bredr).

The only difference is that my headset «pairs» but there's no sound after it.

I can send any output log that might be needed.

Thanks.

@Alexis,

I would like to ask you to register the Sony bug as a new one as this will allow us to track it more efficiently.

As for the logs, try sending us syslog with debugging enabled. Instructions on how to capture it are here https://wiki.ubuntu.com/DebuggingBluetooth

Also, could you share which Ubuntu version are you using?

Thanks!

tags: added: papercuts2017
Wesley C wamer (weswam) wrote :

I am also seeing the identical issues as described above

@Wesley

You mean with Sony or Bose?

Wesley C wamer (weswam) wrote :

@Konrad

Sorry for not being more specific I'm having the issues for the Bose QC35 headphones.

@Wesley

Understood. Can you use it w/ the Bose app on the phone?

Jim Hodapp (jhodapp) wrote :

@Wesley: I would also add, did you know that you can place this headphone in BT pairing mode by first switching it on and then holding that same switch as far away from the off position as possible for a second or two? You don't need the Bose Connect app to put it in pairing mode then.

Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → Jim Hodapp (jhodapp)
Wesley C wamer (weswam) wrote :

@Konrad @Jim The headphones pair flawlessly with every device I have in my house including my laptop on the windows partition. If I boot my laptop into the Ubuntu partition and try to pair it just fails to pair. I'm very confident this is an issue exclusive to my Ubuntu machines my Mac and Windows devices have no problems with these headphones.

Wolf Rogner (war-rsb) wrote :

In my case, the Bose QC35 pairs as a head phone only and this only in case, the head phone is not paired with any other device (in my case, it was first paired with a mobile phone).

However, using a BT mouse makes sound output extremly jittery.

Even though the head set has a microphone, it is not recognized as a combination device.

Using Ubuntu 16.10, latest kernels and BT stacks available from repository.

Wesley C wamer (weswam) wrote :

@Wolf Unfortunately for me even after fully clearing the device list on my Bose QC35s it still will not pair. It immediately fails when I attempt to pair.

@All

Let me explain a bit how the headset works so that you have the general
understanding and perhaps an explanation to why there are some problems
with how it works with Ubuntu.

This headset supports both the BR/EDR mode also known as Bluetooth Classic
and the Bluetooth Low Energy sometimes referred to as Smart. The important
bit however is the fact that on the Low Energy side it does not support
pairing. The pairing is expected to happen on the BR/EDR.

As far as I remember the bluez prioritizes the LE mode over BR/EDR and
initiates pairing on this channel that for the reasons stated above fails.

BlueZ 5.42 contains improvements for transport selection (BR/EDR vs LE). This
is not yet a full support offering seamless experience however things might
look better using it.

For you to know we currently package:

- xenial with bluez 5.37
- yakkety with bluez 5.41
- zesty with bluez 5.41

With the ongoing work to have zesty being packaged with the latest upstream
bluez which is atm 5.43. Also we plan to update xenial with bluez 5.43
however this is nothing certain yet as we need to make sure that the update
will play nice with the LTS release and not break anything.

Hope this helps

Hi
I' using ubuntu 16.04 in a Lenovo thinkpad and I can pair de Bose QC35 adding ControllerMode = bredr but with no sound if I choose the headphones in gnome-control-center (audio) If I comment the ControllerMode, the headphones doesnt show in the gnome-control-center

Alessio Tona (ale763) wrote :

I got it to work, but you need to set it up manually every time you reboot. First I close bluetooth and bluez by effectively stopping them (not restarting), then starting them again using systemctl stop/start bluetooth and sudo /etc/init.d/bluetooth start/stop. Then I start bluez manager and connect my device using setup via audio sink. Then you have to manually change sound to the headphones. I am a newbie with scripts, maybe someone more experienced than me can make a script that does all these actions at boot.

I can confirm that this issue is fixed in 17.10 daily image. Bose QuietComfort 35 headphones now pair without issues.

Wolf Rogner (war-rsb) wrote :

The head phone pairs, the microphone does not.

Further, the sound still is very low and jittery.

Useless to listen to music over this device under these conditions.

Jim Hodapp (jhodapp) wrote :

Yes I've experienced the same kind of jitter. The volume level is pretty decent for me, but not the streaming performance. I basically need to be doing nothing else on my laptop for it to stream without jittering.

Isak Asp (mr.asp) wrote :

Bose QC 35 pairs nice with 17.10, but experience a lot of lag and jitter.

Jim Hodapp (jhodapp) wrote :

Isak: yeah same here, that usually has to do with bluez still querying for other devices in the background and sucking up all of the channel bandwidth. It really needs someone to investigate if we can get bluez to not consume so much bandwidth, or make the query period more context sensitive such that it only happens when the BT settings UI is shown or explicitly told to query for new devices on the command line.

tags: added: bose
Letatcest (ksoeteman) wrote :

Hi, I use a 17.10 and this headset. After figuring out how to get high fidelity sound, I also wanted to use the microphone from the headset, but...

When you switch on the headsets microphone, the sound goes back from A2DP Sink (HiFi playback) to HSP/HFP (Headset Head Unit) quality, which means: low quality (and constantly a nagging voice telling you 'call from')

I followed instructions here:
https://askubuntu.com/questions/833322/pair-bose-quietcomfort-35-with-ubuntu-over-bluetooth

But no solution there.

And also: I just want the headset to connect as Bluetooth LE if possible, but that's apparently not working very well either.

Peter Uithoven (p7ter) wrote :

@ksoeteman

I'm afraid you can't use HiFi playback (A2DP) and the microphone at the same time on any playtform, since it's a general Bluetooth limitation:

Profile limitation – Bluetooth headsets are currently limited to using one profile at a time. Those who read the Bluetooth Profiles section above carefully will note that this presents a problem as the A2DP profile supports stereo audio, but not microphone functionality, and the HSP and HFP profiles support mics but are limited to low-quality mono transmission. This renders modern Bluetooth headsets unusable for gaming that also requires voice chat, for example, as the audio will come through in low-quality mono rather than stereo. Likewise, while using Skype or any other software that requires continuous headset functionality, any music that is playing simultaneously will stream through headset profile in low-quality mono and sound terrible as a result.

From: http://theheadphonelist.com/wireless-fidelity-making-sense-bluetooth-headphone-technology/

Letatcest (ksoeteman) wrote :

@p7ter thanks, I wasn't aware. No need to look further then ;) In that case I have no bug to report (and will retract my bug report as it connects smoothly to my 16.04 desktop and 17.10 laptop without any changes to bt files).

Ihor Menshykov (ihor-ibm) wrote :

I'm upgraded to Ubuntu 18.04 prerelease and I still can't pair. I used to fix the issue like this https://askubuntu.com/questions/833322/pair-bose-quietcomfort-35-with-ubuntu-over-bluetooth on 16.04 once, it worked for a while, but later stopped working and I couldn't pair my headphones, donno why, maybe due to some updates, maybe "just because". Decided to update and try if it maybe worked in a more recent version, but it didn't work in 17.10 and still doesn't in current 18.04 dev branch. Can't pair.

Hey,

I just have tried to pair the QC35 using bluez 5.42 and 5.46 and it did pair. Could you capture HCI trace for me while you are pairing?

Type:

$ sudo btmon --write ~/bose-qc35.snoop

Then start searching for the headset and try to pair. Once pairing fails kill the btmon and attach the .snoop file to this bug report.

Thanks.

Hey,

I'm also having troubles trying to use my QC35 II, after dunno how many different attempts to pair it that I'm not even able to describe, I finally was able to pair it, but I was not so lucky to actually connect it. Here I attach the chunk of btmon output I get on every attempt to connect

tags: added: xenial
Changed in bluez (Ubuntu):
assignee: Konrad Zapałowicz (kzapalowicz) → nobody
Changed in bluez (Ubuntu):
status: In Progress → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers