Brightness is too strong

Bug #1618391 reported by alexisme on 2016-08-30
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Pat McGowan
repowerd (Ubuntu)
Undecided
Alexandros Frantzis

Bug Description

Hello,

When using my phone (Bq 4.5) in the dark, the brightness is to strong and it hurts the eyes and it disturbs others if the want to sleep etc...

With an android phone you are able to decrease the brightness so much that the phone is not disturbing anymore.

It would be nice if it would be possible to make it possible to decrease the brightness a bit more for ubuntu phones

Pat McGowan (pat-mcgowan) wrote :

do you have autobrightness on, or are you manually reducing the brightness? it seems to go very low for me

Changed in canonical-devices-system-image:
status: New → Incomplete
alexisme (alexanderc-spa) wrote :

The autobrightness is on, but it goes to the minimal brigtness (i.e. it doesn't matter if autobrightness is on or not)
I'm talking about being into the complete dark, where the phone seems to be a torch for me!
What I remarked is that the android phones can set a lower brightness in order to avoid this problem. If the eyes are in complete darkness, a strong light as the ubuntu phone quickly hurt!

I was just about to report the exact same problem.

Even when manually setting the brightness to its minimum it is still way too bright when using the phone in complete darkness.

I am using OTA-12 on Meizu PRO5.

Pat McGowan (pat-mcgowan) wrote :

The devices are all using a default value (in this case 10). We could check with the vendors to see if they have overriden the defaults for other OSes.

In experimenting with this I noticed a typo in the source when getting this parameter, so the min will always be 10 on every system in spite of the config.
in src/adapters/brightness_params.cpp
    auto min_str = device_config.get("screenBrightnessSettingMininum", "10");
should be ...Minimum

Changed in canonical-devices-system-image:
status: Incomplete → Confirmed
Changed in repowerd (Ubuntu):
assignee: nobody → Alexandros Frantzis (afrantzis)
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → Medium
milestone: none → backlog
Alexandros Frantzis (afrantzis) wrote :

> In experimenting with this I noticed a typo in the source when getting this parameter, so the min
> will always be 10 on every system in spite of the config.

Thanks Pat, this is indeed a typo in repowerd.

That being said, two things to note in relation to the "brightness is too strong":

1. The screenBrightnessSettingMininum config has no effect on autobrightness; it only affects the minimum value manually settable by the user. Autobrightness is governed by the curve specified in "config_autoBrightnessLcdBacklightValues" in the device specific config file (/usr/share/powerd/device_configs/config-default.xml)

2. By pure chance, this bug has no effect on E4.5 and allows an even darker setting on MX4 (not sure about PRO5) for the manual case, since it defaults to 10 for min brightness, whereas the actual config values for the aforementioned devices are 10 and 15 respectively.

Suggested steps to improve the situation:

* Fix typo in repowerd (assigned to me)
* Change device specific config files to have lower minimum values for both (manual) brightness setting and the autobrightness curve.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in repowerd (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Alexandros Frantzis (afrantzis) wrote :

> Suggested steps to improve the situation:
>
> * Fix typo in repowerd (assigned to me)

The fix has been released in repowerd 2016.10

> * Change device specific config files to have lower minimum values for both (manual) brightness setting and the autobrightness curve.

This is not done yet. Not sure which the best team to handle this.

Changed in canonical-devices-system-image:
status: Fix Committed → Confirmed
Changed in repowerd (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package repowerd - 2016.10+16.10.20161007-0ubuntu1

---------------
repowerd (2016.10+16.10.20161007-0ubuntu1) yakkety; urgency=medium

  * New 2016.10 release
    - Fix typo in brightness config value (LP: #1618391)
    - Update repowerd-cli help text
    - Handle SIGTERM gracefully in repowerd-cli
    - Wait for the repowerd DBus API to be accessible before marking
      the upstart job as started (LP: #1623853)
  * 2016.10 release

 -- Alexandros Frantzis <email address hidden> Fri, 07 Oct 2016 11:50:44 +0000

Changed in repowerd (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers