Complains about bad url on libertine scope urls

Bug #1591342 reported by Albert Astals Cid on 2016-06-10
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Stephen M. Webb
libertine-scope (Ubuntu)
Undecided
Unassigned
url-dispatcher (Ubuntu)
High
Larry Price

Bug Description

** (process:4255): WARNING **: Unable to dispatch url 'appid://xenial/org.kde.kate/0.0':GDBus.Error:com.canonical.URLDispatcher.BadURL: URL 'appid://xenial/org.kde.kate/0.0' is not handleable by the URL Dispatcher

Related branches

Ted Gould (ted) wrote :

Pretty sure this is a URL Dispatcher bug. It isn't using the new UAL API's so it can't detect Libertine apps well.

Changed in url-dispatcher (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in libertine-scope (Ubuntu):
status: New → Invalid
Pat McGowan (pat-mcgowan) wrote :

unfortunate that this did not land in the update

Changed in canonical-devices-system-image:
assignee: nobody → Stephen M. Webb (bregma)
importance: Undecided → High
milestone: none → backlog
status: New → In Progress

FWIW, this bug results in users not being able to launch certain apps on OTA-13. At least Ubuntu Hangups, Liri Browser and YourGUS are affected by this problem.
Can you give any information about when the fix will land?

Stephen M. Webb (bregma) on 2016-09-19
Changed in url-dispatcher (Ubuntu):
assignee: nobody → Larry Price (larryprice)
status: Triaged → In Progress

On Mon, 2016-09-19 at 15:23 +0000, Tim Süberkrüb wrote:
> FWIW, this bug results in users not being able to launch certain apps
> on OTA-13. At least Ubuntu Hangups, Liri Browser and YourGUS are
> affected by this problem.
> Can you give any information about when the fix will land?
To be clear, URL Dispatcher hasn't changed except for rebuilds since
November 2015. It's not anything related to OTA13 or any of the last
several OTAs. If those apps worked in OTA12 but not 13, it wasn't URL
Dispatcher's fault.
Not saying this should get fixed and land, but acting like it broke
apps is disingenuous.

> To be clear, URL Dispatcher hasn't changed except for rebuilds since
> November 2015. It's not anything related to OTA13 or any of the last
> several OTAs. If those apps worked in OTA12 but not 13, it wasn't URL
> Dispatcher's fault.
> Not saying this should get fixed and land, but acting like it broke
> apps is disingenuous.
I apologize for the misinformation (if that's the case).
But you pointed me to this bug on IRC (https://irclogs.ubuntu.com/2016/08/22/%23ubuntu-app-devel.html) :-)
I'm a bit confused now TBH.

Apologize for this misunderstanding, apparently this is - even though it looked like it (at least to me) in the first place - not the cause for the problem I mentioned. Thanks for clarifying.

For the record: Installing Silo 1886 fixed the problem. So was this the right bug after all?

Pat McGowan (pat-mcgowan) wrote :

@tim yes ts the right bug, the point was its not a regression in url-dispatcher which hasnt changed in a year, so not sure it could have ever worked

Changed in canonical-devices-system-image:
milestone: backlog → 14
Larry Price (larryprice) wrote :

I've seen more and more apps start to lean towards the org.gnome.appname syntax in recent updates, which is probably what happened.

It definitely worked before, but I understand now what you mean.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package url-dispatcher - 0.1+17.04.20161107-0ubuntu1

---------------
url-dispatcher (0.1+17.04.20161107-0ubuntu1) zesty; urgency=medium

  [ Florian Boucault ]
  * Crossbuilding Fixes

  [ Larry Price ]
  * App ID should allow package names with dots. (LP: #1591342) (LP: #1606498)

  [ Ted Gould ]
  * Check versions of appid:// urls to reduce the number of invalid appids
    we send to UAL (LP: #1352656)
  * Scope testing for the scope:// URL and overlays that should be over
    the dash
  * Protect the dash from getting NULL urls (LP: #1476257)
  * Make sure URL Overlays are shutdown on exit
  * Remove the wildcard that is confusing the update script (LP: #1461496)
  * Not using a message that isn't set properly (LP: #1608009)
  * Fixing tests to adjust for UAL changes
  * Add a small GUI helper tool for testing
  * Show error dialog over apps that use Bad URLs (LP: #1370008)

 -- Ted Gould <email address hidden> Mon, 07 Nov 2016 16:33:15 +0000

Changed in url-dispatcher (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: 14 → x1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers