Comment 21 for bug 1590561

Interesting, and thanks for proposing a fix.

I guess some further information will still be needed to understand whether
to open the apparmor profile to access those, or if that is wrong from a
confinement perspective.

Can you find which Qt function and/or Oxide calls are made that trigger the
access to this? is the app / lib specifically scanning the hardware to know
about devices ? or is it due to the EGL driver (either userland or kernel) ?

On Wed, Feb 8, 2017 at 3:39 PM, Santosh <email address hidden> wrote:

> Environment: zesty/unity8/radeongpu
>
> I can see the EGL crash in my radeon gpu from command line
> $ webbrowser-app --desktop_file_hint=/usr/share/applications/webbrowser-
> app.desktop
>
> The Crash doesn't happen if I unload the webbrowser apparmor profile.
>
> Looking further on apparmor denial I see few number of message with
> apparmor=DENIED.
> I tried overriding that in webbrowser-app profile to find out actual
> missing privilege.
> and adding these in webbrowser-app profile fixes the issue:
>
> /sys/devices/pci[0-9]*/**/config r,
>
> This also solves webbrowser spinning problem when launched from scopes
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1590561
>
> Title:
> webbrowser-app crashes on startup on fresh zesty Unity8: No suitable
> EGL configs found
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1590561/+
> subscriptions
>