[mako] Alarm doesn't ring when screen locked

Bug #1588526 reported by slash on 2016-06-02
58
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
Ubuntu Clock App
Undecided
Unassigned
repowerd
Undecided
Alexandros Frantzis
indicator-datetime (Ubuntu)
Undecided
Charles Kerr

Bug Description

Hello,

I noticed couple of time, difficult to reproduce that the alarm does not ring at the correct time but ring as soon the screen is on.

Mako Rc-proposed bq-aquaris R324.

Regards

Edit : to make ring the phone i just need to wake up the phone and the alarm start to ring.

Related branches

slash (slash-tux) on 2016-06-06
description: updated
mxd (mxdlinux) wrote :

Hello , I also have the same problem , the alarm reacts only when the screen is on, but after turning on the screen once , the other alarm react properly

Michal Predotka (mpredotka) wrote :

mxd, what device do you use?

slash (slash-tux) wrote :

So on the advice of a fellow,
i played with the vibration setting, under clock settings, and now the alarm rings normally.

I hope it's help to target the bug

slash (slash-tux) wrote :

On the advice of a fellow, i play with the vibration setting (off) under clock settings and recreates the alarms.

Now it seems working fine.

mxd (mxdlinux) wrote :

I use the nexus 4

mxd (mxdlinux) wrote :

there days or it sounds a time, other days not at all, and others where it rings with + - 5 minutes delay

Pat McGowan (pat-mcgowan) wrote :

not able to reproduce, perhaps clock or indicator devs have an idea

Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
status: New → Incomplete
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Michal Predotka (mpredotka) wrote :

I wonder if it has something to do with bug #1516696 and bug #1568002

slash (slash-tux) wrote :

Following my previous post.

The alarm seems to ring normally when it's set it up for the first time. It's only the next day that it doesn't ring anymore until the screen is activated.

Rgds

mxd (mxdlinux) wrote :

hello, I tried, but nothing changes, the bug apparently existed for release and continues to exist, I suppose it will be resolved one day as the other bugs, yet I continue to use ubuntu and pricipalement android for some functions and applications

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Rasool (rasoolentertainment) wrote :

Hello
I am using Ubuntu official clock.
When I set an alarm, sometimes it works and sometimes does not wake me up. I must first make sure the power button, the screen will turn on and then the alarm was activated immediately!
What can I do that without having to manually turn on the screen, was the executive alarms?

Nexus 4
OTA-13
The OTA-12 and even earlier versions also got a problem

Changed in canonical-devices-system-image:
milestone: none → 14
Mark Murphy (mokmeister) wrote :

This affects me on BQ Aqarius M10 since OTA13. I have previously successfully used the alarm pre - OTA13. This happened the morning before last. Last night I changed the alarm sound to a different sound and while I woke before the alarm was due to go off when it did go off it had the default alarm sound (I was reading a book at the time so the screen was active).

Pat McGowan (pat-mcgowan) wrote :

Theory is that the phone suspends before the alarm sound can be played. In that case pushing the power button or waking on the 5 min poll timer will then sound the alarm. However we do request that repowerd keeps the system awake when we issue the alarm or notification. We wait for the system dbus to be available, perhaps that is sometimes taking too long, or the request is not serviced properly.

tags: added: wakeup

@Rasool
@Mark

Could you please attach the /var/log/syslog file from your device to this bug the next time this (alarm not going off) happens to you? It could help us figure out what is going wrong.

@Mark

Could you please clarify if "this happened the morning before last" is referring to your alarm not going off at all until you pressed the power button? Unless I am misunderstanding, your comment seems to describe two independent issues seen in two different occasions: 1. alarm not going off at all 2. change in alarm sound not being applied

slash (slash-tux) wrote :

Gents,

FYI, i've switched my Nexus 4 from rc-proposed/bq aquaris to rc-proposed last week and so far the alarm seems to work every morning.
My phone is in airplane mod every night until the alarm ring.

RAMupgrade (ramupgrade) wrote :

ISSUE:
Alarm fails to wake phone (and user) from sleep and only triggers when power button is pressed.

OS VERSION:
OTA-13 on LGE Nexus 4
Build: Ubuntu 15.04 - armhf (20160913-023544)

DETAILS:
This problem occurs regularly but I cannot reproduce it consistently.
*Seems* better when phone is plugged in and charging but still testing this.
Clock vibration is on. Will test with vibration off.

Bug has persisted for several years now. As a vital core app (especially from a user perspective), this must be resolved.

Reference bug reports:
#1187994 (2013)
#1299916 (2014)
#1459946 (2015)

Changed in ubuntu-clock-app:
status: New → Confirmed
Michal Predotka (mpredotka) wrote :

The problem seems to be specific to Nexus 4 only. Or is it anyone with bq or Meizu phone who got this bug?

slash (slash-tux) wrote :

The problem seems to be specific to rc-proposed/bq-aquaris.

Yesterday night i've reinstall the bq-aquaris to use Here location service, and this morning the bug appear.
Phone in flight mode, no charging, as soon i switch on the screen the alarm rings.

slash (slash-tux) wrote :

Hello,
I've capture the syslog of
6.15 the alarm that didn't ring, and i think it can be seen at 6.19.50 my action to wakeup the phone.
21.37 a success full alarm ring tonight as a test.

Rdgs

slash (slash-tux) wrote :

Ok another one, to repeat the bug :
- Nexus 4 latest Rc-proposed-bq-aqaris
- flight mode ON (doesn't know if it play a role)
- set alarm to allow the phone to go to a "deep sleep"

The alarm was set at 45, at 50 I plug my usb cable to connect phone and reach the shell. As soon the phone was connected the screen went on and the alarm ring.

RAMupgrade (ramupgrade) wrote :

UPDATE (Nexus 4, OTA 13 as daily driver)

After some testing, I can confirm:

   Clock vibration setting: makes no difference, problem still occurs.
   Plugged in and charging: makes no difference, problem still occurs.
   Restarting phone: resolves problem temporarily.

Alarm sounded this morning as expected, after restart (not reset). Problem appears to develop over time. Suggests unresolved conflict or leak somewhere.

Observation:
I notice that SMS notifications do not suffer the same issue. The sleeping phone will always beep and show a light for incoming SMS even when it ignores the alarm. Same goes for incoming phone calls. Only the alarm clock fails to wake the phone.

slash (slash-tux) wrote :

In my case, the reminders from the calendar fails to wake up the phone.

Pat McGowan (pat-mcgowan) wrote :

These seems specific to the Nexus 4, moving to backlog as it is no longer actively supported

summary: - Alarm doesn't ring when screen locked
+ [mako] Alarm doesn't ring when screen locked
Changed in canonical-devices-system-image:
milestone: 14 → backlog

Is Nexus4 a no longer supported device? :O This is the only phone what a new user can buy. I don't think it's a good decision.

slash (slash-tux) wrote :

Since when the N4 is not anymore supported, last month in OTA 13 the was a bug specifically solved for Mako. https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1318360

Moreover, there is high likelihood the future fix for this bug https://bugs.launchpad.net/ubuntu/+source/ofono/+bug/1516696 would help to find this bug.

Regards

Charles Kerr (charlesk) wrote :

After looking through the code, Pat's thoughts in comment 14 seem right to me.

For indicator-datetime's part, it can pass the system bus into the object constructor instead of making an asynchronous call to fetch it. This narrows the dangerous interval in datetime between wakeup and calling requestSysState -- though, NB, I'm not able to reproduce this bug in testing and so I'm not able to determine how much this change ameliorates it.

Outside of indicator-datetime, this might be a question for repowerd wrt ensuring that, after system wakeup, apps have a chance to respond to the wakeup before the system goes back to sleep.

Jelmer Prins (justcarakas) wrote :

I never saw a message that the Nexus 4 is no longer a supported device!

It would be nice to be able to actually buy something that I like, was waiting on the MX 6 but that seems to have been canceled. A lot of people use the Nexus 4, so why would you stop supporting it?

Marcin Wójcik (masheleni) wrote :

Not 100% sure if it's related to this bug or not, but the end result is the same.
I have had occurrences where I set a new alarm and it does not go off at all.

So I have an alarm set to wake me up on weekdays, which hasn't given me issues.
But not too long ago, I added a new 'once off' alarm to wake me up early on a Sunday morning, and made sure it was enabled.

Needless to say, I overslept, as the alarm didn't ring at all.
When I went into the alarm settings, I saw something odd.
The list of alarms showed both my weekday alarm and the once off alarm.
The once off alarm was disabled, and the weekday alarm I had always set up had the title of my once off alarm.

When I went into the once off alarm settings, I enabled it and then everything was back to how it should be.

I now reboot my phone every time I set a new alarm in the hopes that it functions properly.
It's a bit of a hassle.

GTriderXC (gtriderxc) wrote :

I see mentioned here only Nexus 4. I never experienced such a behaviour on bq E4.5. The only thing that happened was a second alarm clock that didn't ring. However it happened only once and I can not reproduce it.

Changed in canonical-devices-system-image:
milestone: backlog → 14
RAMupgrade (ramupgrade) wrote :

The suggestion of no longer supporting the Nexus 4 (comment #24) is worrying, as there are no current OEM devices for sale and few enough supported models. This deprecation isn't mentioned anywhere else (that I could find) and flies in the face of these current pages:
https://developer.ubuntu.com/en/phone/devices/
https://developer.ubuntu.com/en/phone/devices/devices/

This doesn't *appear* to be the official line from Canonical and probably shouldn't be stated as fact or used as the basis for any decisions until confirmed in a more official capacity.

I've just updated the clock app on my Nexus 4 to version 3.8.487. The update's fix list doesn't mention a fix for the alarm issue discussed above, so I'll continue testing because I care about this (as do others). I don't plan to change device any time soon either! ;)

Additionally, comment #13 above describes the bug affecting the BQ Aquarius M10, not the Nexus 4.

Michal Predotka (mpredotka) wrote :

Comment #13 describes a problem with a different alarm sound played then expected. I believe that could be the same situation as in bug #1596924 (sound change need to be confirmed)

Yes, I can confirm the alarm does sound but only when you pick the phone up and turn on the screen.

However, this is after (10 minutes in my case) it should have sounded

________________________________
From: <email address hidden> <email address hidden> on behalf of Michal Predotka <email address hidden>
Sent: 14 October 2016 23:05
To: <email address hidden>
Subject: [Bug 1588526] Re: [mako] Alarm doesn't ring when screen locked

Comment #13 describes a problem with a different alarm sound played then
expected. I believe that could be the same situation as in bug #1596924
(sound change need to be confirmed)

--
You received this bug notification because you are subscribed to a
duplicate bug report (1631863).
https://bugs.launchpad.net/bugs/1588526

Title:
  [mako] Alarm doesn't ring when screen locked

Status in Canonical System Image:
  Incomplete
Status in Ubuntu Clock App:
  Confirmed
Status in indicator-datetime package in Ubuntu:
  Confirmed

Bug description:
  Hello,

  I noticed couple of time, difficult to reproduce that the alarm does
  not ring at the correct time but ring as soon the screen is on.

  Mako Rc-proposed bq-aquaris R324.

  Regards

  Edit : to make ring the phone i just need to wake up the phone and the
  alarm start to ring.

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1588526/+subscriptions

RAMupgrade (ramupgrade) wrote :

Problem persists (alarm not waking phone) after updating to latest clock app. Typically the problem occurs 1 or 2 days after a reset and always comes back. My device has a bare minimum of apps installed and I don't use any scopes, aside from the main home screen. Bluetooth and GPS permanently off. Wi-fi rarely on. Device set to request passcode upon waking.

I use both single-instance and repeating alarms. Often the alarm will wake the phone 1 hour after the alarm is scheduled.

So far, I cannot find an obvious and repeatable trigger, from a user perspective.

Nexus 4 running Ubuntu 15.04 (OTA-13), image 20160913.

Michal Predotka (mpredotka) wrote :

FWIW updating the Clock app will not affect this bug. The Clock app just saves an alarm using Alarm API and the rest is done by the system.

RAMupgrade (ramupgrade) wrote :

Thanks for the info. Much appreciated!

Pat McGowan (pat-mcgowan) wrote :

Did this land?

Changed in canonical-devices-system-image:
status: Incomplete → In Progress
importance: Undecided → High
Andrea Simonetti (simox) wrote :

 Hi,
 i have the same problem. But i often notice that sometime when i unlock the phone it takes a few seconds for my nexus4 to refresh the time. It use to show me the time i block it before..
could this be related to this bug?

thanks for your care!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 15.10+17.04.20161104-0ubuntu1

---------------
indicator-datetime (15.10+17.04.20161104-0ubuntu1) zesty; urgency=medium

  [ Charles Kerr ]
  * Remember the system bus instead of fetching it asynchronously (LP:
    #1588526)

 -- <email address hidden> (<email address hidden>) Fri, 04 Nov 2016 16:45:17 +0000

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Bill Filler (bfiller) on 2016-11-09
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
slash (slash-tux) wrote :

Gents,

I'm currently in Rc-proposed, so my phone should have received by now the fix, however the phone still experiencing this bug.

Regards

JANARDHAN H L (janardhanhl) wrote :

Expexperiancing this often. on nexus -4 OTA-13

Changed in repowerd:
assignee: nobody → Alexandros Frantzis (afrantzis)
status: New → In Progress

I have prepared a PPA containing a new repowerd with a potential fix for the issue here:

https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/2276

IMPORTANT CAVEAT: The changes are experimental. Only try the PPA packages on a development device, not one you care about keeping stable. You may need to reflash a clean image if things go very wrong.

To try the updated packages follow the instructions from the link below:

https://wiki.ubuntu.com/Process/Merges/TestPlans/repowerd

Let me know if/how the fix works for you.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Ren (ubuntech) wrote :

@Pat, in which release has this bug-id been fixed ? I have just tested OTA-14 and the issue is still there.
At the same time tell me where can I find information when a bug id is supposed to be fixed how to test it on my own phone ?

Pat McGowan (pat-mcgowan) wrote :

Will leave this open since alf provided a ppa with a possibly more complete fix per comment #42

Changed in canonical-devices-system-image:
milestone: 14 → backlog
status: Fix Released → In Progress
Changed in ubuntu-clock-app:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers