Several users (Russia, Germany, Spain) report no store access

Bug #1519359 reported by John McAleely on 2015-11-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura

Bug Description

Reported by several customers in Russia. They observe this bug appears to impact them: bug #1506015

A common feature when reproducing this bug is to be on networks with a very different time to UTC, and to have failed to update the time zone correctly by hand during setup (bug #1351534)

Anecdotally, this is reported as 'worse since ota-8'. Is it possible some component has gotten stricter in how it reflects time to the store?

This is due to bug #1509118
A change in OTA7 introduced the use of a time based signature per the fix for bug #1483866

John McAleely (john.mcaleely) wrote :

Seems this may be the underlying bug #1509118

description: updated
John McAleely (john.mcaleely) wrote :

@victor-gonzalez0, we can see the underlying problem but in order to consider possible quick workarounds/fixes, we'd like to understand the exact repro sequence.

In IRC you mentioned it could be reproed by you. What steps do you follow?

Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

@Victor, also if you can reproduce can you please attach the following log files:
- /var/log/syslog
- content of /home/phablet/.cache/upstart/
- content of /var/log/upstart/ (needs root to read these files)

Thanks.

Hi John!

First of all, I think that we should really change the summary because one of our russian users and another german user confirm us that they reproduce the bug after updating to OTA-8.

Steps:

1. Hard-reset to OTA-7(r26)
2. Connect to Wi-Fi and try to register U1 account. Is not working until changing the time zone, it gives you Network error/Login error or even tells you to connect to the internet when you are already on Wi-Fi.(pics attached)
3. OTA Update from OTA-7 went fine and Ubuntu store worked well.

We are not sure if customers did not change time zone in OTA-7 before updating to OTA-8 but, currently s the only way we know to reproduce the bug like the users did.

I'll try to get more useful info

Jean-Baptiste Lallement (jibel) wrote :

I tried to reproduce with the steps in comment 4 and I can login to U1 and successfully install an app. I tried on first boot, with wifi configured during the wizard on OTA7. I'm in France, same timezone than Germany.

@Victor, when was wifi configured, during wizard on initial boot or later from the indicator or system-settings?
Do the devices have SIM cards and how many? do the SIMs have service and data is enabled?
Is it still happening after a reboot and wifi already configured?
Do other network based applications work (eg webbrowser or weather)?
Are these users behind a firewall or captive portal?

- From the test performed: I connected Wi-Fi after wizard configuration for the steps in the comment above.

- From our russian customer:

--> After OTA-8 was not possible to enter Ubuntu store over Wi-Fi, he had SIM card inserted, and once he disables Wi-Fi and mobile data service is connected, Ubuntu store is available (see pics attached over_wifi.jpg and over_data.jpg)

--> He confirmed that over Wi-Fi, the browser was working properly while Ubuntu store wasn't available.

--> mmm he did not mention any firewall or similar.

For this question:

Is it still happening after a reboot and wifi already configured?

- I did another hard-reset to OTA-7
- Wi-Fi was not set in wizard
- Once in home screen I enable Wi-Fi, register de U1 account and try to download an app, not possible (authentication error). Furthermore, once U1 is added and you try to download apps, U1 account is automatically removed, watch the video u1.mp4 (sorry DUT in spanish).
- Now, I register once again U1 account and reboot. I try again to download apps and I come across with the same problem as before.
- Once Time&date is changed manually or you set your city in automatically mode (with U1 account added in first place) Ubuntu store works.

Please note that Ubuntu store will work only if it is done in that order:

1st. U1 account is registered
2nd. Manually change Date & time or set your city in automatically.

Hope you'll find this useful, anything else you need just tell me =)

@Jean! please let me know in which concrete moment do I have to pull the logs and I'll attach them tomorrw =)

Jean-Baptiste Lallement (jibel) wrote :

Victor, run your test as you do in the video then grab the logs.

Well, here is what I was able to pull by now: syslog and .cache/upstart.

From scope-registry.log

2015-10-16 18:46:29,652 - WARNING - Network error getting purchases.
2015-10-16 18:46:30,889 - WARNING - Signing reuested but no credentials found. Using unsigned URL.
2015-10-16 18:46:31,820 - WARNING - Network error: "Host requires authentication (204)"
 "Authorization Required"

From syslog, time synchronization failed:
Oct 16 18:41:39 ubuntu-phablet ntpdate[1571]: name server cannot be used: Temporary failure in name resolution (-3)
Oct 16 18:45:19 ubuntu-phablet ntpdate[6904]: no server suitable for synchronization found

Although from syslog the devices successfully connected to a local access point but ntp sync failed

Oct 16 18:45:10 ubuntu-phablet NetworkManager[1602]: <info> Activation (wlan0) successful, device activated.
Oct 16 18:45:10 ubuntu-phablet nm-dispatcher: Dispatching action 'up' for wlan0
Oct 16 18:45:19 ubuntu-phablet ntpdate[6904]: no server suitable for synchronization found

Alejandro J. Cura (alecu) wrote :

I agree that this sounds very similar to bug #1483866

Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Alejandro J. Cura (alecu)
milestone: none → ww02-2016
summary: - Users configuring phones in Russia report no store access
+ Several users (Russia, Germany, Spain) report no store access

@Victor, following our discussion on IRC, could you connect your phone to 'bq_invitado', log into your phone (adb or ssh) and run the following command from the phone:
$ ntpdate -d ntp.ubuntu.com

The goal is to check if the phone can sync its clock from this time server pool and from this network or not.

dobey (dobey) wrote :

There seem to be multiple issues being discussed in this bug report, and they seem to be consistently getting confused with one another.

Bug #1483866 is unrelated to any of the issues in here. The server still shows results even if the signature is invalid, so having no valid signature here would result in the store scope still showing results.

@jibe!

Sorry for the delay(holidays). In the file attached you'll find two screenshots with the ntpdate command results and a folder with the upstart logs we talked about on IRC.

Hope it to be useful

Pat McGowan (pat-mcgowan) wrote :

OTA 8.5 contains two fixes that may address the issues here:
- fix to the authentication when time is wrong, will address downloading apps from the store (bug #1483866)
- fix to qt network bearer plugin which *might* be related to properly detecting a connection (bug #1480877)

@victor,

Thanks for the logs. I think you're hitting the time issue. Your device is set to Nov. 19th but the real time is Dec. 10th. and the offset is far too high (almost 20 days)

Changed in canonical-devices-system-image:
status: Confirmed → Incomplete
milestone: ww02-2016 → ww08-2016
dobey (dobey) wrote :

Is this still an issue now?

I tried to reproduce by performing a factory data reset to krillin in OTA-9 and do steps in #6. The bug was not reproduced.
Furthermore, I reinstalled OTA-8.5 and update to OTA-9 to repeat the steps, but it seems to work fine now =)

Thank you Victor. I'm closing this report according to your last comment. Don't hesitate to reopen if you can reproduce.

Changed in canonical-devices-system-image:
status: Incomplete → Fix Released
Changed in canonical-devices-system-image:
milestone: ww08-2016 → ww02-2016
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers