PayUI unable to log in Ubuntu One

Bug #1510640 reported by Víctor R. Ruiz on 2015-10-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Alejandro J. Cura
Online Accounts setup for Ubuntu Touch
Critical
Alberto Mardegan
ubuntu-system-settings-online-accounts (Ubuntu)
Critical
Alberto Mardegan

Bug Description

Test case.
- Find an app available for purchase in the store, by searching for "price:2.99" (capitalization is important, and other values may be used as well).
- Tap on the "Purchase" button in the Preview.

Expected result.
- Verify the "Ubuntu One" log-in/register page is opened.

Actual result.
- Page is opened briefly and then closes, preventing log in into Ubuntu One.

Rodney Dawes, Alberto Mardegan and me have been investigating the problem. We think the issue is that payui online-accounts hook is not updating this file: .local/share/accounts/applications/com.canonical.payui_payui.application That file have settings that remain with the old pay-ui click package version. online-accounts-service refuses to validate the new click package with the wrong versioning. Removing the file does the trick.

current build number: 148
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en

https://jenkins.qa.ubuntu.com/job/generic-click-builder-14.09-armhf/39/artifact/output/com.canonical.payui_15.01.133_armhf.click

Related branches

Rodney Dawes (dobey) wrote :

This is not a bug in pay-ui. It is a problem with either click itself, or whatever provides the online-accounts hook, resulting in the hook either failing or not being run at all.

affects: pay-ui → click
Rodney Dawes (dobey) on 2015-10-27
affects: click → click (Ubuntu)
affects: ubuntu-system-settings-online-accounts → ubuntu-system-settings-online-accounts (Ubuntu)
Rodney Dawes (dobey) on 2015-10-27
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
importance: Undecided → Critical
no longer affects: click (Ubuntu)
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) on 2015-10-28
Changed in ubuntu-system-settings-online-accounts:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Alberto Mardegan (mardy)
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → In Progress
Changed in canonical-devices-system-image:
importance: Undecided → Critical
assignee: nobody → Alejandro J. Cura (alecu)
milestone: none → ww46-2015
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.7+16.04.20151028.1-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.7+16.04.20151028.1-0ubuntu1) xenial; urgency=medium

  [ Alberto Mardegan ]
  * Regenerate hooks whenever file time changes (LP: #1510640)

  [ CI Train Bot ]
  * Resync trunk. added: po/hi.po

 -- David Barth <email address hidden> Wed, 28 Oct 2015 14:00:46 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Alberto Mardegan (mardy) on 2015-10-29
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers