People's own phone number isn't where they expect to find it

Bug #1364452 reported by Matthew Paul Thomas on 2014-09-02
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
address-book-app (Ubuntu)
High
Renato Araujo Oliveira Filho
ubuntu-system-settings (Ubuntu)
High
Unassigned

Bug Description

Twenty people were given an Ubuntu phone and asked to find their own phone number. (10 were iPhone users, 8 Android, 1 Windows Phone, and 1 feature phone user.)

The first place they looked:
- 9 in the Contacts app
- 5 in System Settings "Phone" screen
- 3 in System Settings "About" screen
- 2 in the Dialer app contacts screen
- 1 in System Settings "Cellular" screen.

So, our current placement of the phone number in the "About" screen (bug 1221908) is suboptimal.

Instead it should be in the Contacts app, and possibly in the "Phone" screen.
Where the phone is dual SIM, both phone numbers should be shown.

Only once that is done, it should be removed from the "About" screen.

<https://goo.gl/XCquqY>: "Address Book should always contain one special contact representing you as the user of the phone ... To indicate its purpose and resilience, the “Me” contact should be denoted by the word “Me” as a caption at the trailing end (with a translation hint stating that it should be extremely short); and the contact’s visual design should be subtly different from other contacts. Apart from those two differences, the contact should be displayed and ordered the same as any other contacts in the list..."

Related branches

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
description: updated
summary: - Your own phone number isn't where people expect to find it
+ People's own phone number isn't where they expect to find it
tags: added: matchdesign usability
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-app (Ubuntu):
status: New → Confirmed
Changed in address-book-app (Ubuntu):
importance: Undecided → High
Changed in address-book-app (Ubuntu):
status: Confirmed → In Progress
Matthew Paul Thomas (mpt) wrote :

Address Book specification updated. <http://goo.gl/7dMID9>

Changed in address-book-app (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
status: In Progress → Triaged
Matthew Paul Thomas (mpt) wrote :

"About This Device" specification updated. <https://wiki.ubuntu.com/AboutThisDevice?action=diff&rev2=35&rev1=34>

Changed in ubuntu-system-settings (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
status: Confirmed → Triaged
Changed in ubuntu-ux:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Olga Kemmet (olga-kemmet)
Craig Boyes (craigboyesmobile) wrote :

Number not even showing correctly in "About" for me.

Changed in address-book-app:
importance: Undecided → Medium
no longer affects: address-book-app
description: updated

My phone number appears on address-book-app settings.

Changed in address-book-app (Ubuntu):
status: Triaged → Fix Released
Olga Kemmet (olga-kemmet) wrote :

tested on BQ r274

Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Changed in address-book-app (Ubuntu):
status: Fix Released → Triaged
Matthew Paul Thomas (mpt) wrote :

Tested in Ubuntu 15.04 r82; the contact isn't present as specified. Reopening.

description: updated
Changed in ubuntu-ux:
status: Fix Released → Fix Committed

Not working in 15.04 (r3) on MEIZU MX4:
My number is neither displayed in the about screen, nor in the address book. (Unless I put it there manually...)

Sebastien Bacher (seb128) wrote :

The issue mentioned in the previous comment should be reported as a new bug, the feature relies on the SIM card to expose the phone number which doesn't always seems to be the case

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.10.20150827-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.10.20150827-0ubuntu1) wily; urgency=medium

  [ Ken VanDine ]
  * Don't show the phone number in the about page, that is now provided
    by address-book-app (LP: #1364452)

  [ Robert Ancell ]
  * Use new QML package names for qml-module-qt-labs-folderlistmodel,
    qml-module-qtsysteminfo.

  [ Sebastien Bacher ]
  * [security-privacy] rename the "Lock phone" item to "Locking and
    unlocking" and do not include the screen delay as a value, it
    misleads users to think that the section is only about that where it
    also includes security options (LP: #1361127)
  * [security-privacy] use the correct access to location string (LP:
    #1388184)

  [ jonas-drange ]
  * Use wait_select_single instead of select_single to make the test
    less flaky
  * [plugin] add has-dynamic-name to allow for dynamic renaming of a
    plugin. (LP: #1475629)

 -- CI Train Bot <email address hidden> Thu, 27 Aug 2015 07:47:59 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Pat McGowan (pat-mcgowan) wrote :

@renato can you follow up on the Me contact and whether we still want it

Changed in address-book-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Matthew Paul Thomas (mpt) wrote :

I took over design of the Contacts app only a couple of weeks ago, and I have not had time to review the spec yet. But the “Me” contact section, at least, is still current.

Changed in ubuntu-ux:
assignee: Olga Kemmet (olga-kemmet) → Matthew Paul Thomas (mpt)
Pat McGowan (pat-mcgowan) wrote :

The current display location is totally undiscoverable
The dialer app settings goes to the Phone screen, adding it there seems a good idea per the description
Moving it from contact settings to a Me contact is the design spec

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
status: Fix Released → Confirmed
Changed in canonical-devices-system-image:
milestone: none → backlog
no longer affects: ubuntu-ux
Changed in ubuntu-system-settings (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody

My own phone number doesn't show up anywhere. Not in the about section and not in contacts. And it never did, not on my Meizu MX4 and not on my Nexus 5. SIM is from German provider O2 (=Telefonica).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers