device doesn't detect current time zone

Bug #1351534 reported by Selene ToyKeeper on 2014-08-02
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
kevin gunn
unity8 (Ubuntu)
High
Lukáš Tinkl

Bug Description

On first phone boot, or after flashing a new image, the user's time zone isn't auto-detected. Instead, the system always defaults to UTC.

It should probably default instead to checking the cell provider for time zone information, or GPS (if enabled), or if there is a network connection, get an approximate location from that (look up the current access point, in case it has been mapped).

I'm not entirely sure which system component or launchpad project this belongs in, so some re-targeting help would be appreciated.

Related branches

Pat McGowan (pat-mcgowan) wrote :

This requires a NITZ service implementation which has been discussed to implement at a later time

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

that also leads to bug #1289481 ("Default time zone is unlabelled")

Changed in ubuntu-system-settings (Ubuntu):
importance: Wishlist → High
summary: - doesn't detect current time zone
+ device doesn't detect current time zone
tags: added: ota-1 rtm14
Matthew Paul Thomas (mpt) wrote :

(The first-run setup is now part of unity8.)

affects: ubuntu-system-settings (Ubuntu) → unity8 (Ubuntu)
Changed in unity8 (Ubuntu):
assignee: nobody → Lukáš Tinkl (lukas-kde)
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → High
milestone: none → backlog
status: New → In Progress
Selene ToyKeeper (toykeeper) wrote :

There was a branch linked in early December, but then holidays happened. Is this still active?

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Yuan-Chen Cheng (ycheng-twn) wrote :

may I know if it's use the information from the sim card to decide time zone ?

Michael Zanetti (mzanetti) wrote :

It does. It uses the SIM card information to detect the language, and based on the language it pre-selects the most likely time zone and shows time zones where this language is spoken first.

Selene ToyKeeper (toykeeper) wrote :

It's not quite the solution I had in mind, but it does seem like an improvement.

Other phone platforms automatically pick a relevant time zone any time the cell radio is turned on, so they get the right time with no configuration (and update that time automatically during trips, after each landing).

At the moment, my Ubuntu phones now automatically choose "English (New Zealand)" or "English (Australia)" as the language, since that's where my SIM cards are from, but they don't get anywhere near the correct time until I manually configure "America/Denver" as my time zone. The improvement I see is that I no longer have to change this manually in the settings tool, since it's now one of the OOBE steps. It also sorts Denver to the top of the list for "den".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers