Support storing and viewing photos on an SD card

Bug #1392368 reported by Pat McGowan on 2014-11-13
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Canonical Devices Products
camera-app
Fix Released
High
Florian Boucault
gallery-app
Fix Released
High
Florian Boucault
apparmor-easyprof-ubuntu (Ubuntu)
High
Jamie Strandboge
apparmor-easyprof-ubuntu (Ubuntu RTM)
High
Jamie Strandboge
camera-app (Ubuntu)
High
Unassigned
camera-app (Ubuntu RTM)
High
Unassigned
ciborium (Ubuntu RTM)
Undecided
Unassigned
gallery-app (Ubuntu)
High
Unassigned
gallery-app (Ubuntu RTM)
High
Unassigned

Bug Description

If an SD card is present we will use it as extended storage for the device.
The camera and gallery apps need to be able to access this storage.

Related branches

Changed in camera-app:
status: New → In Progress
Changed in gallery-app:
assignee: nobody → Florian Boucault (fboucault)
status: New → In Progress
importance: Undecided → High
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Bill Filler (bfiller) on 2014-12-03
tags: added: ww51
Changed in camera-app (Ubuntu):
status: New → In Progress
Changed in camera-app (Ubuntu RTM):
status: New → In Progress
Changed in gallery-app (Ubuntu):
status: New → In Progress
Changed in gallery-app (Ubuntu RTM):
status: New → In Progress
Changed in camera-app (Ubuntu):
importance: Undecided → High
Changed in camera-app (Ubuntu RTM):
importance: Undecided → High
Changed in gallery-app (Ubuntu):
importance: Undecided → High
Changed in gallery-app (Ubuntu RTM):
importance: Undecided → High
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package camera-app - 3.0.0+15.04.20141211-0ubuntu1

---------------
camera-app (3.0.0+15.04.20141211-0ubuntu1) vivid; urgency=low

  [ CI Train Bot ]
  * Resync trunk

  [ Florian Boucault ]
  * Add an option to save photos and videos to external SD card. Adapted
    bottom edge UI to accomodate for more than 3 settings. (LP:
    #1392368)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Thu, 11 Dec 2014 16:24:50 +0000

Changed in camera-app (Ubuntu):
status: In Progress → Fix Released
Changed in camera-app:
status: In Progress → Fix Released
Bill Filler (bfiller) on 2014-12-19
tags: added: ww03
removed: ww51
Bill Filler (bfiller) on 2015-01-06
Changed in gallery-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: ww51-2014 → ww05-2015
Florian Boucault (fboucault) wrote :
Changed in camera-app:
status: Fix Released → In Progress
Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Jamie Strandboge (jdstrand)
Changed in apparmor-easyprof-ubuntu (Ubuntu RTM):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → High
status: New → Triaged
Jamie Strandboge (jdstrand) wrote :

apparmor-easyprof-ubuntu needs another change due to this denial:
Jan 8 17:53:58 ubuntu-phablet kernel: [99908.971037]type=1400 audit(1420746838.140:316): apparmor="DENIED" operation="open" profile="com.ubuntu.camera_camera_3.0.0.latest" name="/media/phablet/" pid=26014 comm="camera-app" requested_mask="r" denied_mask="r" fsuid=32011 ouid=0

The media is in /media/<user>/<label>/Pictures|Music|Video. There is supposed to be a way for an app like the camera to find out the 'label', but that doesn't exist right now so the camera has to list the directory contents of /media/user to get it. As such, apparmor-easyprof-ubuntu needs to (temporarily) add this rule:
  /media/*/ r,

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: Triaged → In Progress
Changed in apparmor-easyprof-ubuntu (Ubuntu RTM):
status: Triaged → In Progress
Jamie Strandboge (jdstrand) wrote :

apparmor-easyprof-ubuntu 1.2.40 is in rtm silo 10 and passes tests. Needs QA signoff. Once that happens, custom tarball needs to be regenerated after copying to 14.09.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor-easyprof-ubuntu - 1.3.3

---------------
apparmor-easyprof-ubuntu (1.3.3) vivid; urgency=medium

  * ubuntu/{music,pictures,video}_files*: temporarily allow read access to
    global SD card user directory (LP: #1392368). This can be removed once
    there is a proper API for apps to find the SD card label.
 -- Jamie Strandboge <email address hidden> Thu, 08 Jan 2015 14:24:42 -0600

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: In Progress → Fix Released
Changed in ciborium (Ubuntu RTM):
status: New → In Progress
Changed in apparmor-easyprof-ubuntu (Ubuntu RTM):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor-easyprof-ubuntu - 1.2.40

---------------
apparmor-easyprof-ubuntu (1.2.40) 14.09; urgency=medium

  * ubuntu/{music,pictures,video}_files*: temporarily allow read access to
    global SD card user directory (LP: #1392368). This can be removed once
    there is a proper API for apps to find the SD card label.
 -- Jamie Strandboge <email address hidden> Thu, 08 Jan 2015 14:41:20 -0600

Changed in apparmor-easyprof-ubuntu (Ubuntu RTM):
status: Fix Committed → Fix Released
Bill Filler (bfiller) on 2015-01-17
tags: added: ww05
removed: ww03
Pat McGowan (pat-mcgowan) wrote :

make critical for tracking

Changed in canonical-devices-system-image:
importance: High → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package camera-app - 3.0.0+15.04.20150108~rtm-0ubuntu1

---------------
camera-app (3.0.0+15.04.20150108~rtm-0ubuntu1) 14.09; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Florian Boucault ]
  * Fixed merge of SD card support (lp:~fboucault/camera-app/sdcard)
  * Depend on final release of 14.10 framework (ubuntu-sdk-14.10)
    instead of dev version (ubuntu-sdk-14.10-dev2)
 -- Ubuntu daily release <email address hidden> Thu, 08 Jan 2015 17:54:58 +0000

Changed in camera-app (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Changed in gallery-app (Ubuntu RTM):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2015-01-27
Changed in camera-app:
status: In Progress → Fix Released
Changed in gallery-app:
status: In Progress → Fix Released
Changed in ciborium (Ubuntu RTM):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers