Cannot email to Kindle after release 5.29

Bug #1949604 reported by Roger Striffler
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

Until recently, I have been able to successfully have Calibre email documents (.mobi) directly to my Kindle device. The last version that worked was 5.29. Versions beyond that result in an email from Amazon saying that the "Your email to Kindle(s) did not include any attachments".

I am on MacOS 11.6 (Big Sur).

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1949604

Do the books you are sending have non-english characters in their
title/author? And can you try sending one with a purely english
title/author, and see if that works.

 status incomplete

Changed in calibre:
status: New → Incomplete
Revision history for this message
Roger Striffler (rastriffler) wrote :

Hey, Kovid - thanks for the quick reply.

As far as I know, there should be no non-english characters in the book. and I saw none in the metadata. I can send you the book to test if you want.

I reverted back to version 5.29 and the book was sent sucessfully.

If needed, I could re-install 5.30 and try sending a different book and see if I get the same problem.

Revision history for this message
Kovid Goyal (kovid) wrote :

5.30 added support for non-ascii (aka english) filenames in email
attachments, so I guessed that was the cause. I haven't received any
other reports of deliveries to kindle.com email addresses failing so
trying with another book would be useful.

Revision history for this message
Roger Striffler (rastriffler) wrote (last edit ):

OK, I tried with three other books, one of which I just sent successfully (with 5.29) a few weeks ago; none of them sent successfully (all 3 resulted in an email from Amazon saying that the email did not contain an attachment).

The format of the titles are "Book Name - Author Name.mobi"

Let me know if there isanything else I can do to help.

Revision history for this message
Kovid Goyal (kovid) wrote :

Hmm sending random books works for me with calibre 5.31.1. What email
server are you using to send to amazon?

Revision history for this message
Roger Striffler (rastriffler) wrote :

Actually....I don't know. In the preferences I set up several email addresses to which books can be sent, including the one to my Kindle, but I did not specify a server, so I guess it's using the default mail client on my computer?

In that case, it should be using my Yahoo! account.

Revision history for this message
Kovid Goyal (kovid) wrote :

No, if you havent setup a mail relay it will just send the mail directly
from your computer. This is pretty fragile as amazon is quite likely to
block mail from random computers. I suggest setting up a mail relay, you
can do so for free with a hotmail account. See
https://manual.calibre-ebook.com/faq.html#i-cannot-send-emails-using-calibre

Revision history for this message
Maciej Kielar (m-kiler) wrote (last edit ):

Hello,

I've just registered, to report that this bud also affects the PocketBook service (PBSync).
Indeed, when I send a book that has non-english (polish) characters in the file name, I get no attachment. It works fine for pure-ascii characters. So it seems indeed related to the non-ascii characters support you mentioned. I'm not using any custom server for sending.
Is there anything I can do to help you fix that?
Regards,
Maciej

Revision history for this message
Kovid Goyal (kovid) wrote :

You should report it to PBSync, there isn't really anything for calibre
to fix, before this change it would ascii-ize filenames to work around
broken email services that don't handle the unicode filename in email
attachment standards (which are fifteen years old at this point).

If PBSync has a fixed email address scheme, I can have calibre special
case emails to it, same for amazon's @kindle.com (though I still havent
got any other reports of failures with amazon's service).

Revision history for this message
Maciej Kielar (m-kiler) wrote (last edit ):

Well I'm afraid I must disagree about this being a pbsync issue. Sending email from my private email account (gmail) works fine for the same file. So that would mean there is something wrong with how calibre composes the email?
About the pbsync email scheme, it works same as for kindle, the users sends email to ...@pbsync.com and the attached files are downloaded to the reader.

Revision history for this message
Kovid Goyal (kovid) wrote :

calibre does not compose the mails, that's done by the python standard
library. I would be very surprised if that's buggy.

And those emails with non-ascii file names work in dozens of
other email services. As for pbsync, if they dont want to fix their code, I
will simply special case emails to @pbsync.com

Revision history for this message
Kovid Goyal (kovid) wrote :
Revision history for this message
Maciej Kielar (m-kiler) wrote :

Ok, thanks! A workaround is still better than nothing :-)

Revision history for this message
Kovid Goyal (kovid) wrote :

Workarounds are the best you can do for bugs in external services.

Revision history for this message
Kovid Goyal (kovid) wrote :

And i asciiized the filenames when sending to @kindle.com addresses as well, since it does no harm. Hopefully that fixes this issue.

Changed in calibre:
status: Incomplete → Fix Released
Revision history for this message
devnull (ingmar-schuster) wrote :

I'm also getting this problem, sending ebooks through gmail to my Kindle adress. It hasn't worked for some time now.

```
Subject: E-book: XXXXXX
Date: Wed, 27 Apr 2022 08:29:35 +0200
Message-Id: <email address hidden>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="===============8085311258512539667=="

You will not see this in a MIME-aware mail reader.

--===============8085311258512539667==
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit

Attached, you will find the e-book

xxxxxxxx
        by xxxxxxx

in the MOBI format.

--===============8085311258512539667==
Content-Type: application/x-mobipocket-ebook
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="ASCII characters only.mobi"
MIME-Version: 1.0

U2[…]```

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers