[Viewer] Using Alt + Tab to switch programs in Windows when using the viewer in full screen, the text is adjusted as it was not in full screen

Bug #1918591 reported by Jonatan Nyberg
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

Using Alt+Tab to switch programs in Windows when using the viewer in full screen, the text is adjusted as it was not in full screen but the window is shown in full screen.

Steps to reproduce:
1. Open viewer
2. Switch to full screen
3. Use Alt+Tab to switch to another program
4. Use Alt+Tab to switch back to the viewer

summary: - [Enhancement - Viewer] Using Alt + Tab to switch programs in Windows
- when using the viewer in full screen, the text is adjusted as it was not
- in full screen
+ [Viewer] Using Alt + Tab to switch programs in Windows when using the
+ viewer in full screen, the text is adjusted as it was not in full screen
Revision history for this message
Jonatan Nyberg (bugreporter41) wrote :
Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1918591

I spent some time looking into this, and on my windows system it is
difficult to reproduce, seems to happen once every 5-6 times and that
too only when switching to certain applications. As far as I can tell,
its a bug in Qt WebEgine on windows. Nothing I can do about that. When
it did happen on my system I could recover by simply scrolling the book
a page.

 status invalid

Changed in calibre:
status: New → Invalid
Revision history for this message
Jim de Graff (rjdegraff) wrote : Re: [Bug 1918591] Re: calibre bug 1918591

It happens every time I switch between virtual desktops. As you say, it
recovers my position by scrolling so it's not a big deal. If its in Qt
then it's an SEP (someone else's problem).

Jim

On 2021-04-08 06:17, Kovid Goyal wrote:
> I spent some time looking into this, and on my windows system it is
> difficult to reproduce, seems to happen once every 5-6 times and that
> too only when switching to certain applications. As far as I can tell,
> its a bug in Qt WebEgine on windows. Nothing I can do about that. When
> it did happen on my system I could recover by simply scrolling the book
> a page.
>
> status invalid
>
> ** Changed in: calibre
> Status: New => Invalid
>

Revision history for this message
Kovid Goyal (kovid) wrote :

Well I had a brainwave and realized that the issue is basically fixed by forcing a re-render. So I can detect the switch back in fullscreen mode event and force a re-render, working around the Qt bug.

Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments