Bad file descriptor error in downloaded epub when opened from web browser

Bug #1849612 reported by Hyjuki Lomp on 2019-10-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

>calibre, version 4.2.0
>ERROR: Unhandled exception: <b>IOError</b>:[Errno 9] Bad file descriptor

The error is triggered when changing sections (the transition between html files in the epub; the transitions also take several seconds to load, which is extremely slow compared to expectations, but this seems to be an unrelated and known issue with the new reader).

I have been able to reproduce it only when the file is opened from the Downloads list of Firefox 70.0 (64-bit). The error is not triggered when the file is opened from Calibre or from the Windows Explorer. I have attached the epub downloaded from wikisource in case it's relevant.

>Traceback (most recent call last):
> File "site-packages\calibre\gui2\viewer\web_view.py", line 321, in javaScriptConsoleMessage
>IOError: [Errno 9] Bad file descriptor

>calibre 4.2 embedded-python: True is64bit: False
>Windows-10-10.0.18362-SP0 Windows ('32bit', 'WindowsPE')
>32bit process running on 64bit windows
>('Windows', '10', '10.0.18362')
>Python 2.7.14
>Windows: ('10', '10.0.18362', 'SP0', u'Multiprocessor Free')

Hyjuki Lomp (hujikolp) wrote :
  • epub Edit (492.9 KiB, application/octet-stream)

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Transitions between html files absolutely do not take multiple seconds.

Changed in calibre:
status: New → Fix Released
Hyjuki Lomp (hujikolp) wrote :

Thanks, the error message part is fixed when opening the epub from Firefox.

Loading time between html files still takes multiple seconds regardless of where it is opened from. I'll report another bug if I find out more.

Hyjuki Lomp (hujikolp) wrote :

The loading time between html files was specific to this file and related to url links, I reported it here in case it's an issue https://bugs.launchpad.net/calibre/+bug/1851814

The viewer also hanged for a minute between two sections of a different wikisource ebook but I couldn't reproduce that and it seems unrelated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments