New ebook viewer hangs on some large EPUB

Bug #1846886 reported by Johny on 2019-10-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

I have a large EPUB file (10 MB) that when I open it with the new ebook viewer introduced in version 4 of Calibre, it hangs. Sometimes the loading spinning wheel keeps forever, sometimes it loads but when I move page it hangs. The same file I was able to open it without problems in previous version of ebook-viewer.
However, I have another large EPUB file of 19 MB and it opens it well.

I'm running version 4.0 in Ubuntu 19.04.

This is likely a duplicate of 1846751 confirm it by pressing the esc key
when it hangs, if the progress screen goes away and it works, it is
indeed a duplicate. If not, attach the EPUB file and I will take a look.

Johny (juanbertinetti) wrote :

No, if I press ESC nothing happens and it's still hanged. I attach the file.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
gianlukar (gianlukar) wrote :

I'm having the same issue, the viewer hangs with one epub but works fine with another one.
can u help me?
calibre 4.2 on windows 10 v.1903

You need to open a separate bug report and attach the EPUB causing
issues

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments