Freezes loading books

Bug #1513330 reported by Deina on 2015-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Version 2.42 freezes when loading books. Tried both
 * Add book from single directory (first option)
 * Add books from directories & subs, one book per dir (2nd option)

Tried Install --> Repair, but had no effect.

Uninstalled 2.42 & dropped back to 2.41 & books loaded properly

Calibre version 2.42 (64 bit)
Windows 10

Are you using the "Rules to filter/transform tags" from
Preferences->Adding books? If so, post the rules you are using.

 status incomplete

Changed in calibre:
status: New → Incomplete

Rules are attached as PNG.

Deina

On 11/4/2015 9:57 PM, Kovid Goyal wrote:
> Are you using the "Rules to filter/transform tags" from
> Preferences->Adding books? If so, post the rules you are using.
>
> status incomplete
>
> ** Changed in: calibre
> Status: New => Incomplete
>

Your problem is caused by a replacement rule that creates an infinite
cycle, for example, when rule 1 replace A with B and rule 2 replace B
with A.

In the next release, calibre will detect these cycles and automatically
abort further processing of a tag involved in a cycle.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
Kovid Goyal (kovid) wrote :

Oh and just for completeness, it is because tag conditions in the rule
matching are case-insensitive so if you have a rule that says: replace a
with A it will also try to replace A with A, infinitely.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers