Comment 3 for bug 1407860

Thanks for the suggestion and the prompt response.
I figured there had to some way to correct that error but it wasn’t
obvious to this amateur! :-)

I didn’t know where the manifest was or how to sneak the file back into
the package. I think I saw the “remove” option but I didn’t want it to
remove the links. It would have been nice to have had an “update manifest
and import file” option when it told me the file was in the manifest.

At that point it was easier to use a backup and the saved searches
and replaces list to redo the last half dozen edits.

On Jan 9, 2015, at 3:44 AM, Kovid Goyal <email address hidden> wrote:

> If you want to import a file into the book and and entry for the file
> already exists in the manifest, you have two possible approaches:
>
> 1) Open the opf file and manually remove the entry in the meanifest
> 2) Run the check book tool, it will show you an error that says some
> thing like "Item in manifest is missing" along with an action to
> auto-remove the manifest entry. Click that action and the manifest entry
> will be removed for you.
>
> After doing either of those you will be able to import the file again.
>
> Someday, if I have some spare time, I may look into detecting this error
> specifically and adding an easy workaround in the import file process
> itself.
>
> status invalid
>
> ** Changed in: calibre
> Status: New => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1407860
>
> Title:
> cannot replace missing PDF
>
> Status in calibre: e-book management:
> Fix Released
>
> Bug description:
> Version: Calibre 2.12
> OS: OS X 10.9.5
> hardware: MacBook Pro
>
>
> Editing a book in ePub format. Two images were lost (don't know how but they were not removed
> with an edit command). One of them was the cover, cover.jpg.
>
> A check discovered the missing files. It recommended that I replace the files or remove the links.
> I tried clicking on the errors and they showed the links. The links were correct, I wanted to
> reload the files but the links didn't bring up a way to find the file.
>
> I tried "import file into book" menu item and selected the correct cover.jpg using the browser.
> It would not import the file with the error "cover.jpg already in manifest".
>
> I never tried the other missing image.
>
> I solved the problem by going back to an earlier version and repeating
> the edits.
>
> I found a way to replace an existing file but NOT a way to replace a
> missing file.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1407860/+subscriptions