Copy Author Sort to Author isn't working

Bug #1362338 reported by SUzupis on 2014-08-27
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

On an individual book, I try to copy author sort to author. First it takes a lot to even get the drop-down to show up (compared with the old version of Calibre), and then when I select the bottom option nothing happens.

I am running Calibre 2.0 on my mac.

This is caused by a change/bug in Qt 5 on OS X. You have to release the mouse button
first, and then click on the menu entry. So the steps are:

1) Hold down the mouse button to popup the menu
2) Release the mouse button when the menu pops up
3) Now click on the menu entry you want

I have reported the bug to Qt hopefully they will fix it so the behavior
goes back to what it was.

 status invalid

Changed in calibre:
status: New → Invalid

Yes that¹s it!
Thanks a lot fpr all your work!
manpaff

Am 28.08.14 06:24 schrieb "Kovid Goyal" unter <email address hidden>:

>This is caused by a change/bug in Qt 5 on OS X. You have to release the
>mouse button
>first, and then click on the menu entry. So the steps are:
>
>1) Hold down the mouse button to popup the menu
>2) Release the mouse button when the menu pops up
>3) Now click on the menu entry you want
>
>I have reported the bug to Qt hopefully they will fix it so the behavior
>goes back to what it was.
>
> status invalid
>
>** Changed in: calibre
> Status: New => Invalid
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (1362146).
>https://bugs.launchpad.net/bugs/1362338
>
>Title:
> Copy Author Sort to Author isn't working
>
>Status in calibre: e-book management:
> Invalid
>
>Bug description:
> On an individual book, I try to copy author sort to author. First it
> takes a lot to even get the drop-down to show up (compared with the
> old version of Calibre), and then when I select the bottom option
> nothing happens.
>
> I am running Calibre 2.0 on my mac.
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/calibre/+bug/1362338/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers