Broken Edit Metadata in Bulk commits 1.25.0

Bug #1282898 reported by Alan Smith on 2014-02-21
68
This bug affects 10 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned
calibre (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Unassigned

Bug Description

[SRU justification]
This patch is required in order to regain normal behavior of the "Edit Metadata" functionality

[Impact]
Without this patch, an error message appears when editing metadata in bulk which renders the interface unusable without a workaround.

[Fix]
Apply correction to the bug made upstream and in recent versions.

[Test Case]
After editing fields in Edit Metadata in Bulk dialog, commit the changes. With 1.25 binary on Trusty without the fix,The following error appears :

ERROR: Search/replace invalid: Search pattern is invalid: You must specify a search expression in the "Search for" field.

With the proposed fix, the message no longer appears.

[Regression]
None expected, this fix is present in all newer releases.

[Original description of the problem]
After editing fields in Edit Metadata in Bulk dialog, cannot commit the changes, with 1.25 binary on OS X 10.9.1. Got same error with various fields on Basic tab and Custom tab. Error message:

calibre, version 1.25.0
ERROR: Search/replace invalid: Search pattern is invalid: You must specify a search expression in the "Search for" field.

Debug log attached.

ETA. I wasn't on the search/replace tab at all. But later looking at the s/r tab, in the test section "Your test:" test result box is red and contains this:

You must specify a search expression in the "Search for" field

ETA2. Edit Metadata Individually, and editing in booklist, both work fine.

Alan Smith (dralans) wrote :
Alan Smith (dralans) on 2014-02-21
description: updated
Alan Smith (dralans) on 2014-02-21
description: updated
description: updated
Alan Smith (dralans) on 2014-02-21
description: updated

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
Kovid Goyal (kovid) wrote :

Since this is an annoying bug, I will upload a fixed build of 1.25 in a couple of hours, re-download and re-install and you should be fine.

Note that you can workaround the error by just entering some dummy text into the search for field.

Kovid Goyal (kovid) wrote :

The fixed build of 1.25 has been uploaded.

Lenny Silver (lsilver) wrote :

I downloaded the fixed build and the bug is now gone.
Many thanks, and kudos for the fastest bug fix I've ever seen

Alan Smith (dralans) wrote :

Thank you for the quick fix and rebuild. :)

Martin Pitt (pitti) on 2014-09-08
Changed in calibre (Ubuntu):
status: New → Fix Released
Katzinski (katzinski) wrote :

This bug seems to be back. I observed the same behavior as described by the thread starter.
OS Linux Xubuntu 14.04 LTS
package 1.25.0+dfsg-1build1
Tried to fix it by reinstalling from Ubuntu Software Center today, misbehavior still there.
Please let me know if I just missed to do something that would have made Calibre work. Thanks in advance.

Hi,
same for me.
I'm using Calibre 1.25 on Linux Mint and I get the same bug on the same package as above...
Seems that the Ubuntu repo is not up-to-date...
I installed 1.26 directly from the calibre site and everything is now ok.

Louis Bouchard (louis) on 2015-08-24
Changed in calibre (Ubuntu Trusty):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Louis Bouchard (louis-bouchard)
Louis Bouchard (louis) wrote :

Here is the upstream commit that fixes the issue : https://github.com/kovidgoyal/calibre/commit/70d96e7a07cd8ee57603fae136c811f4642d6f0d

I will work on the SRU for Trusty hopefully soon.

Louis Bouchard (louis) on 2015-08-25
Changed in calibre (Ubuntu Trusty):
status: Confirmed → In Progress
Louis Bouchard (louis) on 2015-08-25
description: updated
Louis Bouchard (louis) wrote :

debdiff of the fix

Martin Pitt (pitti) wrote :

Sponsored to SRU review queue, thanks Louis!

Hello Alan, or anyone else affected,

Accepted calibre into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/calibre/1.25.0+dfsg-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in calibre (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Louis Bouchard (louis) wrote :

Works for me on Trusty

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package calibre - 1.25.0+dfsg-1ubuntu1

---------------
calibre (1.25.0+dfsg-1ubuntu1) trusty; urgency=medium

  * d/p/Fix-1282898-Broken-Edit-Metadata-in-Bulk-commits-1.2.patch
    Fix broken Edit Metadata in Bulk commits 1.25.0
    (LP: #1282898)

 -- Louis Bouchard <email address hidden> Mon, 25 Aug 2015 10:27:07 +0200

Changed in calibre (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for calibre has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Louis Bouchard (louis) on 2015-09-09
Changed in calibre (Ubuntu Trusty):
assignee: Louis Bouchard (louis-bouchard) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments