Calibre not recognizing Kobo device

Bug #1251536 reported by Graysen on 2013-11-15
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
David Forrester

Bug Description

I have the Kobo Wifi and I was able to successfully connect my device earlier however after updating the software on my Kobo device, Calibre will no longer recognize my Kobo. Windows Explorer is recognizing my device and says it's connected. I followed all other tips on the Calibre help site.

Calibre version: 1.11
Windows 7

calibre 1.11 isfrozen: True is64bit: False
Windows-7-6.1.7601-SP1 Windows ('32bit', 'WindowsPE')
32bit process running on 64bit windows
('Windows', '7', '6.1.7601')
Python 2.7.5
Windows: ('7', '6.1.7601', 'SP1', 'Multiprocessor Free')
USB devices on system:
[u'usb\\root_hub20&vid8086&pid3b34&rev0005',
 u'usb\\root_hub20&vid8086&pid3b3c&rev0005',
 u'usb\\vid_090c&pid_37b3&rev_0816',
 u'usb\\vid_090c&pid_37b3&rev_0816&mi_00',
 u'usb\\vid_2237&pid_4162&rev_0110',
 u'usb\\vid_8087&pid_0020&rev_0000',
 u'usb\\vid_8087&pid_0020&rev_0000']
Drives detected:
 (0) E:\ ~ \\?\STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_KOBO&PROD_EREADER-1.9.11&REV_0110#00:24:23:32:2D:77&0#{53F56307-B6BF-11D0-94F2-00A0C91EFB8B}#{53F5630D-B6BF-11D0-94F2-00A0C91EFB8B}

No disabled plugins
Looking for devices of type: MTP_DEVICE
List of WPD PNP ids:
[u'\\\\?\\wpdbusenumroot#umb#2&37c186b&1&storage#volume#_??_usbstor#disk&ven_kobo&prod_ereader-1.9.11&rev_0110#00:24:23:32:2d:77&0##{6ac27878-a6fa-4155-ba85-f98f491d4f33}']
No suitable MTP devices found

Looking for devices...

Devices possibly connected: None

Changing the component for this bug.

 assignee davidfor
 tag kobo-driver
 status triaged

Changed in calibre:
assignee: nobody → David Forrester (davidfor)
status: New → Triaged
David Forrester (davidfor) wrote :

That is very strange. Looking at the log, the following lines seem to show a Kobo ereader connected.

u'usb\\vid_2237&pid_4162&rev_0110'

and

  (0) E:\ ~ \\?\STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_KOBO&PROD_EREADER-1.9.11&REV_0110#00:24:23:32:2D:77&0#{53F56307-B6BF-11D0-94F2-00A0C91EFB8B}#{53F5630D-B6BF-11D0-94F2-00A0C91EFB8B}

But a PID of 0x4162 is not one that I have for any Kobo device. The WiFi should be 0x4161 and the original Kobo 0x4165. That hasn't changed in the code for over a year. Kobo have changed the PID in firmware before, but I am surprised that this has happened. I though the last firmware for the WiFi was released well over a year ago. I would have expected any changes to have been reported well before this.

I can added the PID, but can you check it? To do this:

- Connect the ereader
- Open device manager.
- Find and expand the entry for "Disk Drives".
- Under this, there should be an entry for the ereader. If there is an SD card in the ereader, there will be two. It doesn't matter which you use.
- Right click on the ereader entry and select "Properties".
- On the properties dialog, go to the "Details" tab.
- In the "Property" drop down, find and select the entry for "Parent".
- Device id will be displayed. It should start something like the first line I copied from your log.

Please post the details exactly as they are shown so I can check them.

Also, from your log, it appears the firmware version is 1.9.11. Is that correct?

Graysen (graysen-mchugh) wrote :

Hi, thank you very much.

Here's the details you wanted:

USB\VID_2237&PID_4162\00:24:23:32:2D:77

1.9.11 is correct.

David Forrester (davidfor) wrote :

Thank you for that. It was what I expected.

I thought of someone else who had a Kobo WiFi. He was able to confirm the previous firmware version and device ids. Then he got the update to 1.9.11 and the new device ids. We have also had confirmation from Kobo that "Yes, we started rolling out Kobo Wifi firmware few weeks back." I have no idea why they changed the ids.

The attached patch adds the new device id to the driver.

Fixed in branch master. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Triaged → Fix Released

Sorry if You've already received this but I've been having some issues here with Apple Mail today. I always bcc myself to make sure messages are sent but today Mail
seems to just arbitrarily send some and not others and I never received a copy opt this one. So I tried a little different approach. Sorry, again, if it's a repeated message!

Phil

On 2013-11-16, at 7:38 PM, David Forrester <email address hidden> wrote:

> *** This bug is a duplicate of bug 1251536 ***

Is the KOBO Utilities Plug-In update to version 1.4.2 supposed to fix this problem?
If so it doesn't! I've installed it and restarted calibre and it still doesn't work!

Take Care, eh?
   Phil

I need someone real bad...Are you real bad?

David Forrester (davidfor) wrote :

No, the Kobo Utilities plugin is separate. The fix for this problem is in the Kobo driver and will be in the next calibre release. That should be on Friday. Unfortunately, there is no quicker way to get this to you unless you want to run calibre from source.

Great! Everything works again. Thanks - You guys are great!!!

Take Care, eh?
   Phil

"How on earth did I get here, and where the hell are my pants?" John Nunley

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers