Comment 1 for bug 1057331

That error indicates the KF8 part of that file is corrupted. calibre
(and the Kindles) will use the KF8 aprtin preference to the MOBI part,
which is why both will not work. You will need to get this file from
annother source.

 status invalid