Panel mode can't be positioned to the right

Bug #1089052 reported by Arturo Torres Sánchez on 2012-12-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Plug-ins
Wishlist
Fabounet
cairo-dock-plug-ins (Ubuntu)
Low
Matthieu Baerts
Saucy
Low
Matthieu Baerts
Trusty
Low
Matthieu Baerts

Bug Description

I'm using Cairo-Dock 3.1.2
When I set my dock to panel mode, I can make a left and a right panel using a separator. But I don't want a left panel, so I moved the separator to the left. Now my panel is shown at the left, and I can't have a right panel without having a left panel too.

* Impact:
in docks, icons can be aligned (to the middle, right or left of the screen's border)
in "panel" mode, separators expand to fill the screen width (which separates icons in distinct groups), but when there is no separator, all icons are grouped togather, and in this case, they didn't respect the alignment parameter.

this can be quite annoying in some cases
for instance, this prevents the user from being able to move the icons away from the top-left corner of the screen, which is where window's controls are on Ubuntu.

The fix was to correctly take into account the alignment in this
particular case.

* Test Case:
create a dock with an icon inside, set this dock with the "panel" view, and then try to change the alignment to the right: it won't work

* Regression Potential: it only concerns the position of icons in docks with "panel" view and no separator in the dock, which is by itself not a common use case.
we checked that it didn't influence the placement of icons when there is at least 1 separator, and that icons can be placed on the left, middle and right when there is no separator.

Hi,
indeed, it's currently not possible. If there is only 1 group of icons in
the panel, it will be on the left.
Now, as a workaround until this gets fixed, you could just let 1 icon as
the first group (possibly making it transparent) and put all your icons in
the second group.
But I see that you also have a gnome-panel on the top of the screen ? Not
sure if it's a viable option.

2012/12/11 Arturo Torres Sánchez <email address hidden>

> ** Attachment added: "Left and right panels. I don't want the left panel."
>
> https://bugs.launchpad.net/cairo-dock-core/+bug/1089052/+attachment/3457526/+files/20%20-%20Laborspaco%201.png
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Devs, which is subscribed to Cairo-Dock Core.
> https://bugs.launchpad.net/bugs/1089052
>
> Title:
> Panel mode can't be positioned to the right
>
> Status in Cairo-Dock : Core:
> New
>
> Bug description:
> I'm using Cairo-Dock 3.1.2
> When I set my dock to panel mode, I can make a left and a right panel
> using a separator. But I don't want a left panel, so I moved the separator
> to the left. Now my panel is shown at the left, and I can't have a right
> panel without having a left panel too.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/1089052/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team
> More help : https://help.launchpad.net/ListHelp
>

That's not gnome-panel, that's actually the workaround you mentioned.
How can I make the first icon transparent?

Changed in cairo-dock-core:
importance: Undecided → Wishlist
status: New → Triaged
affects: cairo-dock-core → cairo-dock-plug-ins
Matthieu Baerts (matttbe) wrote :

@Arturo: sorry, I forgot to answer to your last question: you can simply create a png file with gimp which is fully transparent.

@fabounet: is this bug now fixed thank to the rev 2987?

https://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-plug-ins/plug-ins/revision/2987
Dock-rendering: panel view: fixed the input shape when there is a single group of icons (no separator)

Fabounet (fabounet03) wrote :

yep, it should :)

2013/10/27 Matthieu Baerts <email address hidden>

> @Arturo: sorry, I forgot to answer to your last question: you can simply
> create a png file with gimp which is fully transparent.
>
> @fabounet: is this bug now fixed thank to the rev 2987?
>
>
> https://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-plug-ins/plug-ins/revision/2987
> Dock-rendering: panel view: fixed the input shape when there is a single
> group of icons (no separator)
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Devs, which is subscribed to Cairo-Dock Plug-ins.
> https://bugs.launchpad.net/bugs/1089052
>
> Title:
> Panel mode can't be positioned to the right
>
> Status in Cairo-Dock: Plug-ins:
> Triaged
>
> Bug description:
> I'm using Cairo-Dock 3.1.2
> When I set my dock to panel mode, I can make a left and a right panel
> using a separator. But I don't want a left panel, so I moved the separator
> to the left. Now my panel is shown at the left, and I can't have a right
> panel without having a left panel too.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/1089052/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team
> More help : https://help.launchpad.net/ListHelp
>

Matthieu Baerts (matttbe) wrote :

This bug should be fixed in the 3.3.2 (which will be released soon) ;)

Changed in cairo-dock-plug-ins:
assignee: nobody → Fabounet (fabounet03)
milestone: none → 3.3.2
status: Triaged → Fix Committed
Changed in cairo-dock-plug-ins (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Matthieu Baerts (matttbe)
milestone: none → ubuntu-14.01
Changed in cairo-dock-plug-ins:
status: Fix Committed → Fix Released
Changed in cairo-dock-plug-ins (Ubuntu Trusty):
status: Triaged → Fix Released
Changed in cairo-dock-plug-ins (Ubuntu Saucy):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Matthieu Baerts (matttbe)

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

description: updated

Hello Arturo, or anyone else affected,

Accepted cairo-dock-plug-ins into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cairo-dock-plug-ins/3.3.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cairo-dock-plug-ins (Ubuntu Saucy):
status: Triaged → Fix Committed
tags: added: verification-needed

I'm currently not on my Ubuntu system. If someone else wants to confirm, it's OK; or if I manage to get it again I will test it.

Matthieu Baerts (matttbe) wrote :

Hello Chris,

I confirm that this bug is now fixed when using this version 3.3.2-0ubuntu0.1, thank you!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock-plug-ins - 3.3.2-0ubuntu0.1

---------------
cairo-dock-plug-ins (3.3.2-0ubuntu0.1) saucy-proposed; urgency=low

  * New upstream release. (bug-fix version)
  * Detailed Upstream ChangeLog (3.3.1 -> 3.3.2)
    - Animated-icons: add the option to disable the 'opening animations'
      in Animated-icons' settings
    - DBus: third-party: init: register the applets after having set the
      text domain for gettext (to translate some titles)
    - Dock-rendering: panel view: fixed the input shape when there is a
      single group of icons (no separator) LP: #1089052
    - GMenu:
      - Apps: fixed tiny memory leak when stopping GMenu
      - Apps: New app: avoid multiple dialogues and select the first item
        in the list
      - Entry: with GTK 3.10: both the entry and the menu receive the signal
        that a key is pressed. This causes a bug: each character is doubled
      - Menus: added a workaround for libgnomemenu if XDG_CURRENT_DESKTOP
        is not defined (e.g. when using XFCE)
    - Icon Effect: config: move 'opening animation' option to 'when
      clicking on a launcher' section
    - MusicPlayer: fixed a bug when changing the player and fixed a few
      small memory leaks
    - System Monitor:
      - SWAP percent was computed twice
      - Fixed a possible crash if we want to display more than 4 values in
        a graph view
    - Shortcuts: bookmarks file:
      - If the file doesn't exist, first create the directory before
        creating an empty file LP: #1244997
      - Check for the existence of the old and new bookmark files to decide
        which one to use (useful for Mint 14 for instance)
    - Weather: on double-click on the main icon, show the hourly forecast
    - Translations: imported translations from Launchpad. LP: #1243608
  * debian/control:
    - bumped Cairo-Dock (core) versions
    - bumped Standards-Version to 3.9.4 (no change needed)
 -- Matthieu Baerts (matttbe) <email address hidden> Mon, 25 Nov 2013 01:38:36 +0100

Changed in cairo-dock-plug-ins (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cairo-dock-plug-ins has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers