Click at the position where icon label was, the icon and dock still receive the event

Bug #537115 reported by Jiff Shen on 2010-03-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cairo-Dock Core
Undecided
Matthieu Baerts
cairo-dock (Ubuntu)
Low
Unassigned

Bug Description

define a new dock as panel (like gnome panel) at top of screen, and enable plugins such as alsaMixer, clock, powermanager

configure the panel (dock) as "prevent apps overlap dock", open a application window (gVim for example) and make it maximized.

Move mouse onto clock applet, a clock label shows on top of the gVim window title bar; move mouse down to the gVim "close" button, click, then calendar window shows up.

Root Cause:
         When mouse moves onto a icon, the label appears, and the dock height grows. But when mouse left icon, label disapeared, but dock didn't shrink, and think it still has focus.

Resolution:
         Send "leave" event to dock when mouse left icon

Related branches

Jiff Shen (m3l3m01t) wrote :
Jiff Shen (m3l3m01t) wrote :
Jiff Shen (m3l3m01t) wrote :

This patch is for cairo-dock-2.1.4-0alpha1-20100304

summary: - Click at the position where icon label was, and the icon and dock still
+ Click at the position where icon label was, the icon and dock still
receive the event
tags: added: patch
affects: ubuntu → cairo-dock (Ubuntu)
Fabounet (fabounet03) wrote :

I can't reproduce the bug.
if I position my dock on the top of the screen, and leave it, it shrinks down correctly.
do you have it with the dock at the bottom or on the sides ?

You should wait for the plugin label shows up, then move mouse to the label;
the label should disappear; then click at this position, the plugin will
receive the click event. If another window is under this position, it cannot
receive click event.

PS: the dock is configurated to use "default" style, and icon won't re-size
upon pointing on it.

Please see the patch, there may have issue in calculating icon height, but
at least it works better.

On Sat, Mar 13, 2010 at 4:31 AM, Fabounet <email address hidden> wrote:

> I can't reproduce the bug.
> if I position my dock on the top of the screen, and leave it, it shrinks
> down correctly.
> do you have it with the dock at the bottom or on the sides ?
>
> --
> Click at the position where icon label was, the icon and dock still receive
> the event
> https://bugs.launchpad.net/bugs/537115
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Cairo-Dock : Core: New
> Status in “cairo-dock” package in Ubuntu: New
>
> Bug description:
> define a new dock as panel (like gnome panel) at top of screen, and enable
> plugins such as alsaMixer, clock, powermanager
>
> configure the panel (dock) as "prevent apps overlap dock", open a
> application window (gVim for example) and make it maximized.
>
> Move mouse onto clock applet, a clock label shows on top of the gVim window
> title bar; move mouse down to the gVim "close" button, click, then calendar
> window shows up.
>
> Root Cause:
> When mouse moves onto a icon, the label appears, and the dock
> height grows. But when mouse left icon, label disapeared, but dock didn't
> shrink, and think it still has focus.
>
> Resolution:
> Send "leave" event to dock when mouse left icon
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/537115/+subscribe
>

Fabounet (fabounet03) wrote :

"the label should disappear"
actually the label doesn't disappear for me (normal, since the icon is still pointed).
did you try with another view ? it's myabe specific to the one you are using.

Jiff Shen (m3l3m01t) wrote :

I tried against 2.1.4-0alpha1-20100312-0ubuntu1, the
label disappear immediately after leave icon, but appears again a little
while. ( not for dock at bottom of screen).
The panel is 24 pixel height, please try this issue on PANEL, not DOCK.

You can try to open a application, move the window until the close button is
at label position, then try these steps again. In this case, I have to
move mouse far away from the icon, wait until panel really shrinks, move
back, then I can close or drag the window. So clicking on label should not
activate plugin, instead it should send click event to that window. The
first snapshot in comment #2 shows this case.

On Mon, Mar 15, 2010 at 7:45 PM, Fabounet <email address hidden> wrote:

> "the label should disappear"
> actually the label doesn't disappear for me (normal, since the icon is
> still pointed).
> did you try with another view ? it's myabe specific to the one you are
> using.
>
> --
> Click at the position where icon label was, the icon and dock still receive
> the event
> https://bugs.launchpad.net/bugs/537115
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Cairo-Dock : Core: New
> Status in “cairo-dock” package in Ubuntu: New
>
> Bug description:
> define a new dock as panel (like gnome panel) at top of screen, and enable
> plugins such as alsaMixer, clock, powermanager
>
> configure the panel (dock) as "prevent apps overlap dock", open a
> application window (gVim for example) and make it maximized.
>
> Move mouse onto clock applet, a clock label shows on top of the gVim window
> title bar; move mouse down to the gVim "close" button, click, then calendar
> window shows up.
>
> Root Cause:
> When mouse moves onto a icon, the label appears, and the dock
> height grows. But when mouse left icon, label disapeared, but dock didn't
> shrink, and think it still has focus.
>
> Resolution:
> Send "leave" event to dock when mouse left icon
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/537115/+subscribe
>

Fabounet (fabounet03) wrote :

oh I see !
I thought this was a gnome-panel, but this is the dock with a x1 zoom and small icons, right ? ^_^
ok so the labels are actually part of the dock, so even when you are out of the icon from few pixels, you are still inside the dock. Ths is because when you have sub-docks, they must touch the main dock (otherwise you would leave the dock before entering the sub-dock). And since the label shouldn't overlap the sub-dock, automatically we have :
______________
. dock
---------------------
. label
---------------------
sub-dock or nothing

Jiff Shen (m3l3m01t) wrote :

exactly!

This patch is to resolve this issue, if mouse leave icon, but still in
inside dock, and sub-dock didn't pop up, it shrinks. This patch works for
sub-dock case.
With this patch, I can completely replace gnome-panel with cairo-dock.

This patch hasn't been tested against dock that is vertical.

On Tue, Mar 16, 2010 at 4:50 PM, Fabounet <email address hidden> wrote:

> oh I see !
> I thought this was a gnome-panel, but this is the dock with a x1 zoom and
> small icons, right ? ^_^
> ok so the labels are actually part of the dock, so even when you are out of
> the icon from few pixels, you are still inside the dock. Ths is because when
> you have sub-docks, they must touch the main dock (otherwise you would leave
> the dock before entering the sub-dock). And since the label shouldn't
> overlap the sub-dock, automatically we have :
> ______________
> . dock
> ---------------------
> . label
> ---------------------
> sub-dock or nothing
>
> --
> Click at the position where icon label was, the icon and dock still receive
> the event
> https://bugs.launchpad.net/bugs/537115
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Cairo-Dock : Core: New
> Status in “cairo-dock” package in Ubuntu: New
>
> Bug description:
> define a new dock as panel (like gnome panel) at top of screen, and enable
> plugins such as alsaMixer, clock, powermanager
>
> configure the panel (dock) as "prevent apps overlap dock", open a
> application window (gVim for example) and make it maximized.
>
> Move mouse onto clock applet, a clock label shows on top of the gVim window
> title bar; move mouse down to the gVim "close" button, click, then calendar
> window shows up.
>
> Root Cause:
> When mouse moves onto a icon, the label appears, and the dock
> height grows. But when mouse left icon, label disapeared, but dock didn't
> shrink, and think it still has focus.
>
> Resolution:
> Send "leave" event to dock when mouse left icon
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/cairo-dock-core/+bug/537115/+subscribe
>

Julien Lavergne (gilir) on 2010-04-18
Changed in cairo-dock (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Chow Loong Jin (hyperair) wrote :

Could someone test this with a vertical panel then? And possibly forward this upstream as well.

Matthieu Baerts (matttbe) wrote :

@ Chow Loong Jin, I think it's maybe better to integrate this patch directly on the lp:cairo-dock-core.

@ fabounet, can you have a look at this patch (and close this bug report) ? I think we forgot to integrate it :)

BTW, Jiff Shen, thank you for the patch!

unfortunately this patch can't be integrated as is, it's more a hack that
will not go well with sub-docks.
instead, I'm thinking of a panel view which would have this feature.

2010/5/4 Matthieu Baerts <email address hidden>

> @ Chow Loong Jin, I think it's maybe better to integrate this patch
> directly on the lp:cairo-dock-core.
>
> @ fabounet, can you have a look at this patch (and close this bug
> report) ? I think we forgot to integrate it :)
>
> BTW, Jiff Shen, thank you for the patch!
>
> --
> Click at the position where icon label was, the icon and dock still receive
> the event
> https://bugs.launchpad.net/bugs/537115
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to Cairo-Dock Core.
>
> Status in Cairo-Dock : Core: New
> Status in “cairo-dock” package in Ubuntu: Triaged
>
> Bug description:
> define a new dock as panel (like gnome panel) at top of screen, and enable
> plugins such as alsaMixer, clock, powermanager
>
> configure the panel (dock) as "prevent apps overlap dock", open a
> application window (gVim for example) and make it maximized.
>
> Move mouse onto clock applet, a clock label shows on top of the gVim window
> title bar; move mouse down to the gVim "close" button, click, then calendar
> window shows up.
>
> Root Cause:
> When mouse moves onto a icon, the label appears, and the dock
> height grows. But when mouse left icon, label disapeared, but dock didn't
> shrink, and think it still has focus.
>
> Resolution:
> Send "leave" event to dock when mouse left icon
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team<https://launchpad.net/%7Ecairo-dock-team>
> More help : https://help.launchpad.net/ListHelp
>

Nigel Babu (nigelbabu) wrote :

Please forward the patch upstream for their comments on fixing the issues with the patch.

tags: added: patch-needswork
removed: patch
Fabounet (fabounet03) wrote :

the new "panel" view is designed to solve this problem.

Changed in cairo-dock-core:
status: New → Fix Committed
Changed in cairo-dock (Ubuntu):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :
Download full text (4.7 KiB)

This bug was fixed in the package cairo-dock - 3.0.0.1-0ubuntu1

---------------
cairo-dock (3.0.0.1-0ubuntu1) precise; urgency=low

  * New upstream release. (LP: #983288)
  * Upstream ChangeLog:
   - Updated translations
   - Themes: Renamed the default theme and move it to the new 'themes' directory
   - Included here our default-panel theme from our server in order to use this
      theme without an Internet connexion
      (this theme is highly recommended for the Cairo-Dock' session)
   - Moved 'battery' to cairo-dock-plug-ins
   - Theme manager: fixed the preview made when the current theme is saved
   - Fixed a bug with icons that are always visible
      (their alpha was not reseted correctly)
   - Fixed a bug that prevented the dock from hiding when leaving
      and re-entering quickly
   - Containers: set opacity to 0 on creation, so that we don't get grey
      rectangles on loading (before we receive the first X Expose event)
      + increase the size of default windows to avoid invisible icons LP: #960282
   - When destroying a flying container, don't forget to detach the icon
   - Removed prints
   - Pango: only used the logical rectangle in order to avoid any deplacements
   - Draw: Icons always visible: limit the background margin to 1px, avoid
      icons to stick togather
   - Menu: disabled the Quit menu entry for all Cairo-Dock sessions
      (not only 'cairo-dock')
   - cairo-dock-session: only modify Compiz settings if '--replace' paramater
      is given
   - don't launch 'cairo-dock' if Cairo-Dock is already use only by current user
   - Session: Used shorter names
      (was too long for DM and we were not able to read the full name)
   - Used IsRunnableHelper to check if compiz can be launched or we have to
      use metacity (on Ubuntu)
   - The latest version of unity-2d-panel is now supported
      (it's no longer needed to modify config file with root rights or to kill
      a processus to have unity-2d-panel and Cairo-Dock)
   - cairo-dock.conf: fixed a typo (a wrong icon name)
   - initial-setup: no longer modify gconf keys of gnome settings (LP: #981092)
   - cairo-dock.c: initialised gettext before getopt in order to translate
      the output of 'cairo-dock -h'
   - Used the new name of the default theme
   - fixed the retrieval of the desktop background (was broken since the switch
      to GTK3)
   - Use the right web address of the themes' directory on our server.
   - Help.conf: removed lines which only contain 'TODO' and bump Help's version
   - fixed the drawing of multi-lines dialogs (sometime the text was invisible)
   - X manager: when receiving a NetDesktopGeometry signal from X
      notify everybody every time, and also update the number of viewports
   - Welcome message: replaced 'Cairo-Dock2' by 'Cairo-Dock'
  * This 3.0 series (and previous series) also fixes these bugs:
   - "glx-dock does not work with kde 4.8.1" (LP: #961048)
   - "the dock position is wrong when multiple monitor's resolution is different"
      (LP: #905912)
   - "GLX-Dock Hardware acc. UNDO!" (LP: #875975)
   - "Can't disable zoom" (LP: #702800)
   - "all button tips visible if icons 'maximum zoom' set to 1.0" (LP: #618...

Read more...

Changed in cairo-dock (Ubuntu):
status: Invalid → Fix Released
Changed in cairo-dock-core:
assignee: nobody → Matthieu Baerts (matttbe)
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers