[i18n] bzr commands affected working tree crashed with unicode error in non-english locale

Bug #966934 reported by Alexander Belchenko on 2012-03-28
102
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Bazaar
High
Martin Packman
2.5
High
Martin Packman
bzr (Ubuntu)
High
Jelmer Vernooij
Precise
High
Jelmer Vernooij

Bug Description

bzr 2.5.0-2 standalone with localization enabled, ru locale. Trying to pull latest changes from lp:qbzr got the following traceback:

Wed 2012-03-28 11:34:20 +0300
0.547 bazaar version: 2.5.0
0.547 bzr arguments: [u'pull']
0.562 looking for plugins in C:\work\Bazaar\plugins
0.750 looking for plugins in C:/Program Files/Bazaar/plugins
0.765 Plugin name colo already loaded
0.781 Plugin name explorer already loaded
0.797 Plugin name qbzr already loaded
1.093 encoding stdout as sys.stdout encoding 'cp866'
1.468 opening working tree 'C:/work/Bazaar/plugins/qbzr'
3.328 falling back to default implementation
3.328 failed to load system host keys: [Errno 2] No such file or directory: 'C:\\Documents and Settings\\modul98/.ssh/known_hosts'
[ 3972] 2012-03-28 11:34:24.500 INFO: Connected (version 2.0, client Twisted)
4.547 Trying SSH agent key 69DE0146E3CD769AE60602F7192D0EB5
[ 3972] 2012-03-28 11:34:25.765 INFO: Authentication (publickey) successful!
[ 3972] 2012-03-28 11:34:25.953 INFO: Secsh channel 1 opened.
11.312 Using fetch logic to copy between RemoteRepository(bzr+ssh://bazaar.launchpad.net/~qbzr-dev/qbzr/trunk2a/.bzr/)(RemoteRepositoryFormat(_network_name='Bazaar repository format 2a (needs bzr 1.16 or later)\n')) and CHKInventoryRepository('file:///C:/work/Bazaar/plugins/qbzr/.bzr/branches/.bzr/repository/')(RepositoryFormat2a())
11.312 fetching: <SearchResult search:(set(['<email address hidden>']), ['<email address hidden>', '<email address hidden>', '<email address hidden>', '<email address hidden>', '<email address hidden>', ...], 13)>
14.640 tiplog: recorded pull on <email address hidden>
[ 3972] 2012-03-28 11:34:36.765 INFO: M NEWS.txt
[ 3972] 2012-03-28 11:34:36.765 INFO: M lib/conflicts.py
[ 3972] 2012-03-28 11:34:36.780 INFO: M lib/subprocess.py
[ 3972] 2012-03-28 11:34:36.780 INFO: M lib/widgets/shelve.py
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-ar.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-cs.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-da.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-de.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-en.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-en_GB.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-es.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-et.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-fr.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-gl.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-he.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-hu.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-it.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-ja.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-nl.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-pl.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-pt_BR.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-ru.po
[ 3972] 2012-03-28 11:34:36.780 INFO: M po/qbzr-sk.po
[ 3972] 2012-03-28 11:34:36.796 INFO: M po/qbzr-sl.po
[ 3972] 2012-03-28 11:34:36.796 INFO: M po/qbzr-sr.po
[ 3972] 2012-03-28 11:34:36.796 INFO: M po/qbzr-sv.po
[ 3972] 2012-03-28 11:34:36.796 INFO: M po/qbzr-th.po
[ 3972] 2012-03-28 11:34:36.796 INFO: M po/qbzr-tr.po
[ 3972] 2012-03-28 11:34:36.796 INFO: M po/qbzr-uk.po
[ 3972] 2012-03-28 11:34:36.796 INFO: M po/qbzr.pot
16.297 Transferred: 314kB (29.1kB/s r:311kB w:3kB)
16.297 Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 920, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1131, in run_bzr
  File "bzrlib\commands.pyo", line 673, in run_argv_aliases
  File "bzrlib\commands.pyo", line 695, in run
  File "bzrlib\cleanup.pyo", line 136, in run_simple
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "bzrlib\builtins.pyo", line 1221, in run
  File "bzrlib\decorators.pyo", line 218, in write_locked
  File "bzrlib\workingtree.pyo", line 1008, in pull
  File "bzrlib\merge.pyo", line 2021, in merge_inner
  File "bzrlib\merge.pyo", line 686, in do_merge
  File "bzrlib\cleanup.pyo", line 136, in run_simple
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "bzrlib\merge.pyo", line 654, in _do_merge_to
  File "bzrlib\merge.pyo", line 802, in do_merge
  File "bzrlib\cleanup.pyo", line 132, in run
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "bzrlib\merge.pyo", line 808, in _do_merge
  File "bzrlib\transform.pyo", line 1734, in apply
  File "bzrlib\progress.pyo", line 116, in update
  File "bzrlib\ui\text.pyo", line 374, in _progress_updated
  File "bzrlib\ui\text.pyo", line 554, in show_progress
  File "bzrlib\ui\text.pyo", line 536, in _repaint
  File "bzrlib\ui\text.pyo", line 440, in _show_line
UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-30: ordinal not in range(128)

Although pull into treeless branch works without problems:

C:\work\Bazaar\plugins\qbzr>bzr pull -d colo:0.22
Используется сохранённое местоположение родителя: bzr+ssh://bazaar.launchpad.net/%2Bbranch/qbzr/0.22/
Connected (version 2.0, client Twisted)
Authentication (publickey) successful!
Secsh channel 1 opened.
Now on revision 1470.

Related branches

Alexander Belchenko (bialix) wrote :
Download full text (3.7 KiB)

The same problem with `bzr update` in the same tree, because my tree is out-of-date due the pull error:

Wed 2012-03-28 11:42:34 +0300
0.328 bazaar version: 2.5.0
0.328 bzr arguments: [u'update']
0.328 looking for plugins in C:\work\Bazaar\plugins
0.437 looking for plugins in C:/Program Files/Bazaar/plugins
0.437 Plugin name colo already loaded
0.437 Plugin name explorer already loaded
0.437 Plugin name qbzr already loaded
0.562 encoding stdout as sys.stdout encoding 'cp866'
0.672 opening working tree 'C:/work/Bazaar/plugins/qbzr'
[ 3336] 2012-03-28 11:42:36.828 INFO: M NEWS.txt
[ 3336] 2012-03-28 11:42:36.828 INFO: M lib/conflicts.py
[ 3336] 2012-03-28 11:42:36.842 INFO: M lib/subprocess.py
[ 3336] 2012-03-28 11:42:36.842 INFO: M lib/widgets/shelve.py
[ 3336] 2012-03-28 11:42:36.842 INFO: M po/qbzr-ar.po
[ 3336] 2012-03-28 11:42:36.858 INFO: M po/qbzr-cs.po
[ 3336] 2012-03-28 11:42:36.858 INFO: M po/qbzr-da.po
[ 3336] 2012-03-28 11:42:36.858 INFO: M po/qbzr-de.po
[ 3336] 2012-03-28 11:42:36.875 INFO: M po/qbzr-en.po
[ 3336] 2012-03-28 11:42:36.875 INFO: M po/qbzr-en_GB.po
[ 3336] 2012-03-28 11:42:36.875 INFO: M po/qbzr-es.po
[ 3336] 2012-03-28 11:42:36.890 INFO: M po/qbzr-et.po
[ 3336] 2012-03-28 11:42:36.890 INFO: M po/qbzr-fr.po
[ 3336] 2012-03-28 11:42:36.905 INFO: M po/qbzr-gl.po
[ 3336] 2012-03-28 11:42:36.905 INFO: M po/qbzr-he.po
[ 3336] 2012-03-28 11:42:36.905 INFO: M po/qbzr-hu.po
[ 3336] 2012-03-28 11:42:36.921 INFO: M po/qbzr-it.po
[ 3336] 2012-03-28 11:42:36.921 INFO: M po/qbzr-ja.po
[ 3336] 2012-03-28 11:42:36.921 INFO: M po/qbzr-nl.po
[ 3336] 2012-03-28 11:42:36.937 INFO: M po/qbzr-pl.po
[ 3336] 2012-03-28 11:42:36.937 INFO: M po/qbzr-pt_BR.po
[ 3336] 2012-03-28 11:42:36.937 INFO: M po/qbzr-ru.po
[ 3336] 2012-03-28 11:42:36.953 INFO: M po/qbzr-sk.po
[ 3336] 2012-03-28 11:42:36.953 INFO: M po/qbzr-sl.po
[ 3336] 2012-03-28 11:42:36.953 INFO: M po/qbzr-sr.po
[ 3336] 2012-03-28 11:42:36.967 INFO: M po/qbzr-sv.po
[ 3336] 2012-03-28 11:42:36.967 INFO: M po/qbzr-th.po
[ 3336] 2012-03-28 11:42:36.967 INFO: M po/qbzr-tr.po
[ 3336] 2012-03-28 11:42:36.983 INFO: M po/qbzr-uk.po
[ 3336] 2012-03-28 11:42:36.983 INFO: M po/qbzr.pot
2.328 Transferred: 0kB (0.0kB/s r:0kB w:0kB)
2.328 Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 920, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1131, in run_bzr
  File "bzrlib\commands.pyo", line 673, in run_argv_aliases
  File "bzrlib\commands.pyo", line 695, in run
  File "bzrlib\cleanup.pyo", line 136, in run_simple
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "bzrlib\builtins.pyo", line 1762, in run
  File "bzrlib\workingtree.pyo", line 1435, in update
  File "bzrlib\mutabletree.pyo", line 52, in tree_write_locked
  File "bzrlib\workingtree.pyo", line 1505, in _update_tree
  File "bzrlib\merge.pyo", line 2021, in merge_inner
  File "bzrlib\merge.pyo", line 686, in do_merge
  File "bzrlib\cleanup.pyo", line 136, in run_simple
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "bzrlib\merge.pyo", line 654, in _do_merge_to
  File "bzrlib\merge.pyo", line 802, i...

Read more...

Alexander Belchenko (bialix) wrote :

And there is no way to workaround this, because setting env variable LANGUAGE to either C or en does not help - the same error.

Changed in bzr:
importance: High → Critical
Alexander Belchenko (bialix) wrote :

Sorry, forget the last comment, that's my fault, I've typed LANGAUGE rather than LANGUAGE.

So, actually the only woirkaround is to force English locale.

Changed in bzr:
importance: Critical → High
summary: - [i18n] bzr pull crashed with unicode error
+ [i18n] bzr pull/update crashed with unicode error

Huh, TextProgressView straight up doesn't support non-ascii text. Setting BZR_PROGRESS_BAR=none is also a reasonable workaround for this particular issue, for now people want to just disable localisation completely as there are still a selection of bugs like this,

Alexander Belchenko (bialix) wrote :

OK, revert affected too:

C:\work\Bazaar\plugins\qbzr\po>bzr revert
 M po/qbzr-ru.po
bzr: ERROR: exceptions.UnicodeEncodeError: 'ascii' codec can't encode characters in position 16-24: ordinal not in range(128)

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 920, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1131, in run_bzr
  File "bzrlib\commands.pyo", line 673, in run_argv_aliases
  File "bzrlib\commands.pyo", line 695, in run
  File "bzrlib\cleanup.pyo", line 136, in run_simple
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "bzrlib\builtins.pyo", line 4780, in run
  File "bzrlib\builtins.pyo", line 4786, in _revert_tree_to_revision
  File "bzrlib\mutabletree.pyo", line 52, in tree_write_locked
  File "bzrlib\workingtree.pyo", line 1332, in revert
  File "bzrlib\transform.pyo", line 2863, in revert
  File "bzrlib\transform.pyo", line 1734, in apply
  File "bzrlib\progress.pyo", line 116, in update
  File "bzrlib\ui\text.pyo", line 374, in _progress_updated
  File "bzrlib\ui\text.pyo", line 554, in show_progress
  File "bzrlib\ui\text.pyo", line 536, in _repaint
  File "bzrlib\ui\text.pyo", line 440, in _show_line
UnicodeEncodeError: 'ascii' codec can't encode characters in position 16-24: ordinal not in range(128)

bzr 2.5.0 on python 2.6.6 (Windows-XP-5.1.2600-SP3)
arguments: ['C:\\Program Files\\Bazaar\\bzr.EXE', 'revert']
plugins: acad[0.8.0], bzrtools[2.5.0], colo[0.3.1dev], explorer[1.3.0dev],
    fastimport[0.14.0dev], find_branches[unknown], format1[unknown],
    git[0.6.7], launchpad[2.5.0], qbzr[0.22.2dev], rewrite[0.6.4dev],
    scmproj[0.6.2dev], svn[1.2.1], tiplog[0.0.5dev], undelete[0.2.0],
    x_bit[1.0.0]
encoding: 'cp1251', fsenc: 'mbcs', lang: None

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

It seems all commands that works with working tree are affected.

Alexander Belchenko (bialix) wrote :

OK, another workaround is to use QBzr dialogs instead of plain bzr commands. QBzr works correctly with unicode.

summary: - [i18n] bzr pull/update crashed with unicode error
+ [i18n] bzr commands affected working tree crashed with unicode error in
+ non-english locale
Alexander Belchenko (bialix) wrote :

I think this bug is Critical, although there are several workarounds. Should we edit the description of the bug report and provide information on workarounds?

Martin Packman (gz) on 2012-03-28
Changed in bzr:
assignee: nobody → Martin Packman (gz)
status: Confirmed → In Progress
Jelmer Vernooij (jelmer) on 2012-05-28
Changed in bzr (Ubuntu):
status: New → Fix Released
importance: Undecided → High
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Jelmer Vernooij (jelmer)

Hello Alexander, or anyone else affected,

Accepted bzr into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in bzr (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Packman (gz) on 2012-06-20
Changed in bzr:
milestone: none → 2.6b2
status: In Progress → Fix Released

Hi all,

This is the last bug in the proposed bzr SRU to precise that hasn't had the fix verified. Could someone experiencing this confirm that the version in precise-proposed resolves this issue on Ubuntu for them? Or someone provide instructions to reproduce this?

Thanks!

Martin Packman (gz) wrote :

This might be a little annoying to reproduce, as it requires both a non-english locale that translates a progress update string (and uses a non-ascii character), and to do a slow enough operation that the progress gets displayed.

So, something like:

    $ locale -a
     # verify that ru or ja locale is available
    $ bzr branch -r-40 lp:qbzr test_branch
     # get not quite all of a project so pull will get new changes and update tree
    $ LANG=ja_JP.utf8 bzr pull -d test_branch
     # should see at least one progress message not in english, and no traceback

Martin Packman (gz) wrote :

So, it turns out that due to a packaging bug Ubuntu doesn't actually install .mo files, whereas Debian does. Therefore I'll verify this bug on the grounds it's not reproducible with the precise-proposed package.

tags: added: verification-done
removed: verification-needed

On Tue, Jun 26, 2012 at 4:52 AM, Martin Packman
<email address hidden> wrote:
> So, it turns out that due to a packaging bug Ubuntu doesn't actually
> install .mo files, whereas Debian does. Therefore I'll verify this bug
> on the grounds it's not reproducible with the precise-proposed package.

Package's in main have their .mo file stripped at build time and moved
into language-packs for iso space issues. For instance,
'/usr/share/locale-langpack/ru/LC_MESSAGES/bzr.mo' is found in the
package 'language-pack-ru-base'

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.5.1-0ubuntu1

---------------
bzr (2.5.1-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
   + Fixes handling of colocated branches in `bzr rmbranch`. LP: #920653
   + rmbranch now refuses to remove active branch. LP: #922953
   + Connecting with HTTPS via HTTP correctly uses host name of destination
     rather than that of proxy. LP: #944696
   + No longer requires tty when GPG signing commits. LP: #847388
   + Fixes unicode erorrs when translated progress task messages
     contain non-ascii text. LP: #966934
   + Fixes display of help for configuration options that overlap
     with other topics. LP: #941672
  * Drop 06_spurious_test_failure: applied upstream.
 -- Jelmer Vernooij <email address hidden> Mon, 28 May 2012 13:36:02 +0200

Changed in bzr (Ubuntu Precise):
status: Fix Committed → Fix Released
Hans Ginzel (hans-matfyz) wrote :

This bug is not fixed.

bzr: ERROR: exceptions.UnicodeEncodeError: 'ascii' codec can't encode character u'\u011f' in position 79: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 673, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/fastimport/cmds.py", line 694, in run
    return exporter.run()
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/fastimport/exporter.py", line 238, in run
    self.emit_commit(revid, self.ref)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/fastimport/exporter.py", line 356, in emit_commit
    self.print_cmd(self._get_commit_command(ref, mark, revobj, file_cmds))
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/fastimport/exporter.py", line 285, in print_cmd
    self.outf.write("%r\n" % cmd)
  File "/usr/lib/python2.7/dist-packages/fastimport/commands.py", line 140, in __repr__
    return self.to_string(include_file_contents=True)
  File "/usr/lib/python2.7/dist-packages/fastimport/commands.py", line 188, in to_string
    for c in self.iter_files()])
UnicodeEncodeError: 'ascii' codec can't encode character u'\u011f' in position 79: ordinal not in range(128)
# locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY=en_GB.UTF-8
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER=en_GB.UTF-8
LC_NAME=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8
LC_TELEPHONE=en_GB.UTF-8
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
LC_ALL=

Package: bzr
Version: 2.6.0-3ubuntu1

Chemtox (chemtox) wrote :

Also seeing this in an up-to-date Saucy. Switching locale to en or C doesn't helps.

Ubuntu/scrot/src$ bzr --version
Bazaar (bzr) 2.6.0
  Python interpreter: /usr/bin/python 2.7.5
  Python standard library: /usr/lib/python2.7
  Platform: Linux-3.11.0-19-generic-x86_64-with-Ubuntu-13.10-saucy

Ubuntu/scrot/src$ bzr builddeb -- -S -us -uc
Building using working tree
Building package in normal mode
Looking for a way to retrieve the upstream tarball
Upstream tarball already exists in build directory, using that
bzr: ERROR: exceptions.UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 54: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 673, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/cmds.py", line 449, in run
    builder.export()
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/builder.py", line 77, in export
    self.distiller.distill(self.target_dir)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/source_distiller.py", line 79, in distill
    self._distill(target)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/source_distiller.py", line 107, in _distill
    export(self.tree, target)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/util.py", line 603, in export
    filtered=filtered, per_file_timestamps=True)
  File "/usr/lib/python2.7/dist-packages/bzrlib/export/__init__.py", line 175, in export
    per_file_timestamps, fileobj):
  File "/usr/lib/python2.7/dist-packages/bzrlib/export/__init__.py", line 128, in get_export_generator
    trace.mutter('export version %r', tree)
  File "/usr/lib/python2.7/dist-packages/bzrlib/trace.py", line 155, in mutter
    out = fmt % tuple(real_args)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 54: ordinal not in range(128)

Ubuntu/scrot/src$ locale
LANG=en_GB.utf-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.utf-8"
LC_NUMERIC="en_GB.utf-8"
LC_TIME="en_GB.utf-8"
LC_COLLATE="en_GB.utf-8"
LC_MONETARY="en_GB.utf-8"
LC_MESSAGES="en_GB.utf-8"
LC_PAPER="en_GB.utf-8"
LC_NAME="en_GB.utf-8"
LC_ADDRESS="en_GB.utf-8"
LC_TELEPHONE="en_GB.utf-8"
LC_MEASUREMENT="en_GB.utf-8"
LC_IDENTIFICATION="en_GB.utf-8"
LC_ALL=

André (afsverissimo) wrote :

Still in 16.04

$ bzr-buildpackage lp:~ubuntu-desktop/nautilus/ubuntu -r 495 -S -v
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
Building branch from revision <email address hidden>
bzr: ERROR: exceptions.UnicodeEncodeError: 'ascii' codec can't encode character u'\xf1' in position 82: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 673, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/cmds.py", line 376, in run
    (changelog, top_level) = find_changelog(tree, not contains_upstream_source)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/builddeb/util.py", line 211, in find_changelog
    raise UnparseableChangelog(str(e))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf1' in position 82: ordinal not in range(128)

bzr 2.7.0dev1 on python 2.7.11 (Linux-4.4.0-4-generic-x86_64-with-
    Ubuntu-16.04-xenial)
arguments: ['/usr/bin/bzr', 'builddeb', 'lp:~ubuntu-desktop/nautilus/ubuntu',
    '-r', '495', '-S', '-v']
plugins: bash_completion[2.7.0dev1], builddeb[2.8.6],
    changelog_merge[2.7.0dev1], grep[2.7.0dev1], launchpad[2.7.0dev1],
    netrc_credential_store[2.7.0dev1], news_merge[2.7.0dev1],
    po_merge[2.7.0dev1], weave_fmt[2.7.0dev1]
encoding: 'utf-8', fsenc: 'UTF-8', lang: 'en_GB.UTF-8'

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers