docs don't sufficiently explain difference between update and revert

Bug #809484 reported by xaav on 2011-07-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned
Breezy
Low
Unassigned

Bug Description

xaav said, incorrectly """Bzr up is redundant; bzr revert accomplishes the same task. There is no need to maintain these two commands; it creates inconsistency and confusion about which one to use."""

The docs should explain the difference more clearly (probably in the guide and in help.)

John A Meinel (jameinel) wrote :

I'm not sure about the 'bzr revno --tree' bug, but I think you are confused. revert is *not* the same as update, because revert *intentionally* doesn't change the working tree revision pointer. Specifically so that if you are at rev 10, and want to undo the previous commit, you can "bzr revert -r -9; bzr commit" to create revision 11 like things were at rev 9.

Changed in bzr:
status: New → Invalid
xaav (xaav) wrote :

Oh, thanks for that information. The doc needs to be clearer on that point.

Martin Pool (mbp) on 2011-07-12
summary: - Bzr up is redundant
+ docs don't sufficiently explain difference between update and revert
Changed in bzr:
status: Invalid → Confirmed
importance: Undecided → Medium
tags: added: doc easy
description: updated
Jelmer Vernooij (jelmer) on 2017-11-09
tags: added: check-for-breezy

Wow. This bug is old! I don't even use bzr anymore; I switched to git along
with everyone else.

2017-11-08 18:25 GMT-06:00 Jelmer Vernooij <email address hidden>:

> ** Tags added: check-for-breezy
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/809484
>
> Title:
> docs don't sufficiently explain difference between update and revert
>
> Status in Bazaar:
> Confirmed
>
> Bug description:
> xaav said, incorrectly """Bzr up is redundant; bzr revert accomplishes
> the same task. There is no need to maintain these two commands; it
> creates inconsistency and confusion about which one to use."""
>
> The docs should explain the difference more clearly (probably in the
> guide and in help.)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bzr/+bug/809484/+subscriptions
>

Jelmer Vernooij (jelmer) on 2018-03-30
tags: removed: check-for-breezy
Changed in brz:
status: New → Triaged
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers