Bazaar Version Control System

unable to find subvertpy (Windows Standalone Installer)

Reported by Neronyatkin on 2009-02-11
78
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar
High
John A Meinel

Bug Description

bzr: ERROR: exceptions.ImportError: bzr-svn: unable to find subvertpy. Please install from http://launchpad.net/subvertpy.

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 893, in run_bzr_catch_errors
  File "bzrlib\commands.pyo", line 839, in run_bzr
  File "bzrlib\commands.pyo", line 539, in run_argv_aliases
  File "C:/Program Files/Bazaar/plugins\qbzr\lib\commands.py", line 715, in run
  File "bzrlib\commands.pyo", line 839, in run_bzr
  File "bzrlib\commands.pyo", line 539, in run_argv_aliases
  File "bzrlib\builtins.pyo", line 3477, in run
  File "bzrlib\builtins.pyo", line 70, in tree_files
  File "bzrlib\builtins.pyo", line 119, in internal_tree_files
  File "bzrlib\workingtree.pyo", line 331, in open_containing
  File "bzrlib\bzrdir.pyo", line 844, in open_containing
  File "bzrlib\bzrdir.pyo", line 865, in open_containing_from_transport
  File "bzrlib\bzrdir.pyo", line 819, in open_from_transport
  File "bzrlib\lazy_import.pyo", line 125, in __call__
  File "bzrlib\transport\__init__.pyo", line 1680, in do_catching_redirections
  File "bzrlib\bzrdir.pyo", line 806, in find_format
  File "bzrlib\bzrdir.pyo", line 1645, in find_format
  File "C:/Program Files/Bazaar/plugins\svn\format.py", line 86, in probe_transport
  File "C:/Program Files/Bazaar/plugins\svn\format.py", line 56, in _check_versions
  File "C:/Program Files/Bazaar/plugins\svn\__init__.py", line 103, in lazy_check_versions
  File "C:/Program Files/Bazaar/plugins\svn\__init__.py", line 86, in init_subvertpy
ImportError: bzr-svn: unable to find subvertpy. Please install from http://launchpad.net/subvertpy.

bzr 1.12rc1 on python 2.5.2 (win32)
arguments: ['C:\\Program Files\\Bazaar\\bzr.exe', 'qsubprocess', '"revert" "DOCs/\xd0\xf3\xea\xee\xe2\xee\xe4\xf1\xf2\xe2\xee \xef\xee\xeb\xfc\xe7\xee\xe2\xe0\xf2\xe5\xeb\xff.doc"']
encoding: 'cp1251', fsenc: 'mbcs', lang: None
plugins:
  bzrtools C:\Program Files\Bazaar\plugins\bzrtools [1.12]
  launchpad C:\Program Files\Bazaar\plugins\launchpad [unknown]
  netrc_credential_store C:\Program Files\Bazaar\plugins\netrc_credential_store [unknown]
  qbzr C:\Program Files\Bazaar\plugins\qbzr [0.9.7]
  svn C:\Program Files\Bazaar\plugins\svn [0.5]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.

Jelmer Vernooij (jelmer) wrote :

this is fixed in the -2 installer John uploaded today

Changed in bzr-svn:
assignee: nobody → jameinel
status: New → Fix Released
Neronyatkin (neronyatkin) wrote :

bzr-setup-1.12rc1-2.exe
again:
bzr: ERROR: exceptions.ImportError: bzr-svn: unable to find subvertpy. Please install from http://launchpad.net/subvertpy.

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 893, in run_bzr_catch_errors
  File "bzrlib\commands.pyo", line 839, in run_bzr
  File "bzrlib\commands.pyo", line 539, in run_argv_aliases
  File "C:/Program Files/Bazaar/plugins\qbzr\lib\commands.py", line 715, in run
  File "bzrlib\commands.pyo", line 839, in run_bzr
  File "bzrlib\commands.pyo", line 539, in run_argv_aliases
  File "bzrlib\builtins.pyo", line 3477, in run
  File "bzrlib\builtins.pyo", line 70, in tree_files
  File "bzrlib\builtins.pyo", line 119, in internal_tree_files
  File "bzrlib\workingtree.pyo", line 331, in open_containing
  File "bzrlib\bzrdir.pyo", line 844, in open_containing
  File "bzrlib\bzrdir.pyo", line 865, in open_containing_from_transport
  File "bzrlib\bzrdir.pyo", line 819, in open_from_transport
  File "bzrlib\lazy_import.pyo", line 125, in __call__
  File "bzrlib\transport\__init__.pyo", line 1680, in do_catching_redirections
  File "bzrlib\bzrdir.pyo", line 806, in find_format
  File "bzrlib\bzrdir.pyo", line 1645, in find_format
  File "C:/Program Files/Bazaar/plugins\svn\format.py", line 86, in probe_transport
  File "C:/Program Files/Bazaar/plugins\svn\format.py", line 56, in _check_versions
  File "C:/Program Files/Bazaar/plugins\svn\__init__.py", line 103, in lazy_check_versions
  File "C:/Program Files/Bazaar/plugins\svn\__init__.py", line 86, in init_subvertpy
ImportError: bzr-svn: unable to find subvertpy. Please install from http://launchpad.net/subvertpy.

bzr 1.12rc1 on python 2.5.2 (win32)
arguments: ['C:\\Program Files\\Bazaar\\bzr.exe', 'qsubprocess', '"revert" "DOCs/\xd0\xf3\xea\xee\xe2\xee\xe4\xf1\xf2\xe2\xee \xef\xee\xeb\xfc\xe7\xee\xe2\xe0\xf2\xe5\xeb\xff.doc"']
encoding: 'cp1251', fsenc: 'mbcs', lang: None
plugins:
  bzrtools C:\Program Files\Bazaar\plugins\bzrtools [1.12]
  launchpad C:\Program Files\Bazaar\plugins\launchpad [unknown]
  netrc_credential_store C:\Program Files\Bazaar\plugins\netrc_credential_store [unknown]
  qbzr C:\Program Files\Bazaar\plugins\qbzr [0.9.7]
  svn C:\Program Files\Bazaar\plugins\svn [0.5]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.

Changed in bzr:
status: Fix Released → New
Changed in bzr:
assignee: jameinel → nobody
Changed in bzr-svn:
assignee: nobody → jelmer
Jelmer Vernooij (jelmer) wrote :

Please keep this assigned to John/bzr, as he's working on this. This is a bug in the bzr installer, bzr-svn doesn't have its own installer and I'm not involved in the Windows installer.

Changed in bzr-svn:
assignee: jelmer → jameinel
Changed in bzr:
status: New → Confirmed
Neronyatkin (neronyatkin) wrote :

OK

yarko (yarkot1) wrote :

still a problem; to "get around" this un-satisfied dependency (since it comes up only in certain cases, eg sometimes the svn plugin isn't called so no problem), I've attempted to disable the svn plugin until this is resolved. I think this will solve more "failures" than it will create (we'll see):

- go to your installation directory (e.g. d:/Bazaar/plugins) and rename the plugin directory "svn" to something like "svn-doesnt-work"

That did if for me, for now.

yarko (yarkot1) wrote :

actually better to move svn out of the plugins directory....

baxissimo (wbaxter) wrote :

> actually better to move svn out of the plugins directory....

Well this "workaround" disables svn integration, right? That's kinda like how amputation is a workaround for RSI.

But anyway, I just ran into this problem too, but for me the error seems to go away after rebooting.

But my sequence of steps was actually (from a working 1.11 install)
1. Install http://launchpadlibrarian.net/22753079/bzr-setup-1.12-1.exe
2. See the error about not finding the __collate function in MSVCRT.dll
3. Get annoyed
4. Reinstall http://launchpadlibrarian.net/21547847/bzr-setup-1.11-1.exe [without rebooting!]
5. Still see an odd error about subverpy (though slightly different)
6. Reboot
7. Try "bzr --version" and see a "Bazaar (bzr) 1.12" message appear without any error.

So I'm not sure what happened there with the attempt to install 1.11, but after a reboot I now have what seems to be a working 1.12 install.

Download full text (3.4 KiB)

The version I've tried:
 * bzr 1.12-1 Windown Standalone Installer, MD5: 7461cf50c630b559a2dd9f6c20a63a82

when run bzr --version:
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Bazaar (bzr) 1.12
  Python interpreter: D:\usr\local\Bazaar\python25.dll 2.5.2
  Python standard library: D:\usr\local\Bazaar\lib\library.zip
  bzrlib: D:\usr\local\Bazaar\lib\library.zip\bzrlib
  Bazaar configuration: D:\Documents and Settings\ntt6\Dados de aplicativos\bazaar\2.0
  Bazaar log file: D:\Documents and Settings\ntt6\Meus documentos\.bzr.log

Copyright 2005, 2006, 2007, 2008, 2009 Canonical Ltd.
http://bazaar-vcs.org/

bzr comes with ABSOLUTELY NO WARRANTY. bzr is free software, and
you may use, modify and redistribute it under the terms of the GNU
General Public License version 2 or later.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

So, I've tried to run the command:
 * bzr help commands

And Bazaar raised the error:
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
bzr: ERROR: exceptions.ImportError: Unable to load subvertpy extensions - did you build it?

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 896, in run_bzr_catch_errors
  File "bzrlib\commands.pyo", line 842, in run_bzr
  File "bzrlib\commands.pyo", line 542, in run_argv_aliases
  File "bzrlib\commands.pyo", line 856, in ignore_pipe
  File "bzrlib\builtins.pyo", line 3666, in run
  File "bzrlib\help.pyo", line 51, in help
  File "bzrlib\help_topics\__init__.pyo", line 826, in get_help_text
  File "bzrlib\help_topics\__init__.pyo", line 90, in get_detail
  File "bzrlib\help.pyo", line 78, in _help_commands_to_text
  File "bzrlib\help.pyo", line 77, in <genexpr>
  File "bzrlib\commands.pyo", line 173, in get_cmd_object
  File "bzrlib\commands.pyo", line 190, in _get_cmd_object
  File "bzrlib\registry.pyo", line 168, in get
  File "bzrlib\registry.pyo", line 61, in get_obj
  File "bzrlib\registry.pyo", line 66, in _do_import
  File "D:/usr/local/Bazaar/plugins\svn\mapping3\__init__.py", line 25, in <module>
  File "subvertpy\__init__.pyo", line 97, in <module>
ImportError: Unable to load subvertpy extensions - did you build it?

bzr 1.12 on python 2.5.2 (win32)
arguments: ['bzr', 'help', 'commands']
encoding: 'cp1252', fsenc: 'mbcs', lang: None
plugins:
  bzrtools D:\usr\local\Bazaar\plugins\bzrtools [1.12]
  launchpad D:\usr\local\Bazaar\plugins\launchpad [unknown]
  netrc_credential_store D:\usr\local\Bazaar\plugins\netrc_credential_store [unknown]
  qbzr D:\usr\local\Bazaar\plugins\qbzr [0.9.8]
  svn D:\usr\local\Bazaar\plugins\svn [0.5]
  xmloutput D:\usr\local\Bazaar\plugins\xmloutput [0.8.1]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs...

Read more...

I'm trying to install subvertpy. I'm belive I can build the module and copy to some place at %BAZAAR_HOME%\plugins.
This is what I've did:

1. Download the tar.gz
2. python setup.py install
-------------------------------------------------------------------------------------------------
Traceback (most recent call last):
  File "setup.py", line 229, in <module>
    (svn_includedirs, svn_libdirs, extra_libs) = svn_build_data()
  File "setup.py", line 173, in svn_build_data
    "Please set SVN_DEV to the location of the svn development "
Exception: Please set SVN_DEV to the location of the svn development packages.
These can be downloaded from:
http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=91
-------------------------------------------------------------------------------------------------
3. set SVN_DEV=%Bazaar_HOME%\plugins\svn
4.python setup.py install
-------------------------------------------------------------------------------------------------
Traceback (most recent call last):
  File "setup.py", line 229, in <module>
    (svn_includedirs, svn_libdirs, extra_libs) = svn_build_data()
  File "setup.py", line 179, in svn_build_data
    "Please set SVN_BDB to the location of the svn BDB packages "
Exception: Please set SVN_BDB to the location of the svn BDB packages - see README.txt in the SV_DEV dir
-------------------------------------------------------------------------------------------------

5. set SVN_BDB=D:\usr\local\Bazaar\plugins\svn
6. python setup.py install
-------------------------------------------------------------------------------------------------
Traceback (most recent call last):
  File "setup.py", line 229, in <module>
    (svn_includedirs, svn_libdirs, extra_libs) = svn_build_data()
  File "setup.py", line 184, in svn_build_data
    "Please set SVN_LIBINTL to the location of the svn libintl "
Exception: Please set SVN_LIBINTL to the location of the svn libintl packages - see README.txt in the SV_DEV dir
-------------------------------------------------------------------------------------------------

7. set SVN_LIBINTL=D:\usr\local\Bazaar\plugins\svn
8. python setup.py install
-------------------------------------------------------------------------------------------------
Traceback (most recent call last):
  File "setup.py", line 229, in <module>
    (svn_includedirs, svn_libdirs, extra_libs) = svn_build_data()
  File "setup.py", line 187, in svn_build_data
    svn_version = get_svn_version()
  File "setup.py", line 158, in get_svn_version
    "Please check that your SVN_DEV location is correct.\n"
Exception: Please check that your SVN_DEV location is correct.
Unable to find required svn_version.h file.
-------------------------------------------------------------------------------------------------

9. Post It here.
10 Download the svn plugin, version 0.5.2....

Download full text (4.2 KiB)

...

11. I builded bzr-svn 0.5.2
12. Then set the SVN_VARS to installed dir:
      set SVN_DEV=D:\usr\local\Python25\Lib\site-packages\bzrlib\plugins\svn\
      set SVN_LIBINTL=D:\usr\local\Python25\Lib\site-packages\bzrlib\plugins\svn\
      set SVN_BDB=D:\usr\local\Python25\Lib\site-packages\bzrlib\plugins\svn\
13. Try to install again:
-------------------------------------------------------------------------------------------------
Traceback (most recent call last):
  File "setup.py", line 229, in <module>
    (svn_includedirs, svn_libdirs, extra_libs) = svn_build_data()
  File "setup.py", line 187, in svn_build_data
    svn_version = get_svn_version()
  File "setup.py", line 158, in get_svn_version
    "Please check that your SVN_DEV location is correct.\n"
Exception: Please check that your SVN_DEV location is correct.
Unable to find required svn_version.h file.
-------------------------------------------------------------------------------------------------

14. Read the stacktrace O_o:
-------------------------------------------------------------------------------------------------
These can be downloaded from:
http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=91
-------------------------------------------------------------------------------------------------
15. Downloaded, installed and change the SVN_VARS...
16. Try to install again:
-------------------------------------------------------------------------------------------------
Traceback (most recent call last):
  File "setup.py", line 229, in <module>
    (svn_includedirs, svn_libdirs, extra_libs) = svn_build_data()
  File "setup.py", line 187, in svn_build_data
    svn_version = get_svn_version()
  File "setup.py", line 158, in get_svn_version
    "Please check that your SVN_DEV location is correct.\n"
Exception: Please check that your SVN_DEV location is correct.
Unable to find required svn_version.h file.
-------------------------------------------------------------------------------------------------

17. Look for something with svn, python, 2.5.4 and dev in its name :)
      http://subversion.tigris.org/files/documents/15/44108/svn-win32-1.5.4_dev.zip

17.1 Uncompress zip to: D:\instaladores\SCM\Bazaar\1.12\svn\svn-win32-1.5.4

18. Downloaded, installed and change the SVN_DEV=D:\instaladores\SCM\Bazaar\1.12\svn\svn-win32-1.5.4
19. Try to install subvertpy again: python setup.py install
-------------------------------------------------------------------------------------------------
running install
running build
running build_py
creating build
creating build\lib.win32-2.5
creating build\lib.win32-2.5\subvertpy
copying subvertpy\delta.py -> build\lib.win32-2.5\subvertpy
copying subvertpy\marshall.py -> build\lib.win32-2.5\subvertpy
copying subvertpy\properties.py -> build\lib.win32-2.5\subvertpy
copying subvertpy\ra.py -> build\lib.win32-2.5\subvertpy
copying subvertpy\ra_svn.py -> build\lib.win32-2.5\subvertpy
copying subvertpy\server.py -> build\lib.win32-2.5\subvertpy
copying subvertpy\__init__.py -> build\lib.win32-2.5\subvertpy
creating build\lib.win32-2.5\subvertpy\tests
copying subvertpy\tests\test_client.py -> build\lib.win32-2.5\subvertpy\tests
copying...

Read more...

baxissimo (wbaxter) wrote :

I wrote:
> But anyway, I just ran into this problem too, but for me the error seems to go away after rebooting.

I was wrong. I think maybe bzr --version was all that worked. When I tried to run some real commands the next day I got the popup about the collate function missing in msvcrt.dll again.

Dan Hughes (dan-multiedit) wrote :

What I have happen is that bzr 1.12 works fine under Windows Vista Business 32-bit but fails as the original message states when run under Windows XP Pro SP2. I've done a little research and have discovered the following:

The MSVCP60.dll file located in bazaar\lib directory is linking to the msvcrt.dll file and is using the __lc_collate_cp_func entry point. This is what is failing under XP since the msvcrt.dll file in the System32 directory is at version 7.0.2600.2180 and does not contain that entry. While under Vista the msvcrt.dll in the System32 director is at version 7.0.6001.18000 which is newer and contains the needed entry point. I don't know how to resolve this issue since I don't use MS C++ compilers as to avoid these kinds of issues.

Dan

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dan Hughes wrote:
> What I have happen is that bzr 1.12 works fine under Windows Vista
> Business 32-bit but fails as the original message states when run under
> Windows XP Pro SP2. I've done a little research and have discovered the
> following:
>
> The MSVCP60.dll file located in bazaar\lib directory is linking to the
> msvcrt.dll file and is using the __lc_collate_cp_func entry point. This
> is what is failing under XP since the msvcrt.dll file in the System32
> directory is at version 7.0.2600.2180 and does not contain that entry.
> While under Vista the msvcrt.dll in the System32 director is at version
> 7.0.6001.18000 which is newer and contains the needed entry point. I
> don't know how to resolve this issue since I don't use MS C++ compilers
> as to avoid these kinds of issues.
>
> Dan
>

I believe we should not be bundling MSVCP60.dll, what happens if you
just move that file out of the way?

John
=:->
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkmfFEgACgkQJdeBCYSNAAP+NACdF3SMTWxCL49WVS2pAZjL08t9
cO0AnRXtnapc1+6RbbXTRlmOHEPjcVzq
=J2SP
-----END PGP SIGNATURE-----

If you remove %BAZAAR_HOME%\lib\MSVCP60.dll

bzr help commands works just fine.

John A Meinel (jameinel) wrote :

=== modified file 'setup.py'
--- setup.py 2009-02-11 15:33:31 +0000
+++ setup.py 2009-02-23 05:15:56 +0000
@@ -616,7 +616,7 @@

     # MSWSOCK.dll is a system-specific library, which py2exe accidentally pulls
     # in on Vista.
- dll_excludes.append("MSWSOCK.dll")
+ dll_excludes.extend(["MSWSOCK.dll", "MSVCP60.dll"])
     options_list = {"py2exe": {"packages": packages + list(additional_packages),
                                "includes": includes,
                                "excludes": excludes,

Should be the diff which prevents that dll from getting packaged. I'm not 100% certain on this, but in the meantime, it sounds like it isn't problematic to delete the MSVCP60.dll. (I assume it is being found elsewhere on people's PATH.)

Mark Hammond (mhammond) wrote :

That patch looks correct to me. FWIW, powrprof.dll should be added to that list too - but will only be included when packaged on Vista, so you probably aren't seeing that DLL in your current builds. I thought I'd submitted a patch with powrprof.dll, but I may be mis-remembering...

Unsure if this is related or not.

Removing lib\MSVCP60.dll solved the problem with the warning for me, BUT when doing "bzr update" in a checkout of a SVN repository, nothing happened and the command never returned. After reverting to version 1.11, I could "bzr update" as usual.

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Henrik Steensland wrote:
> Unsure if this is related or not.
>
> Removing lib\MSVCP60.dll solved the problem with the warning for me, BUT
> when doing "bzr update" in a checkout of a SVN repository, nothing
> happened and the command never returned. After reverting to version
> 1.11, I could "bzr update" as usual.
>

As I think I mentioned in the release notes, bzr-svn has been upgraded
to 0.5.0, which uses a different mapping method. Though you can
explicitly request the old mapping.

I would guess that it has to regenerate all the information at this point.

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkmitVUACgkQJdeBCYSNAAM/ZwCeNqtIep233x1j1MslitgFabAT
AQYAn1EniH8h3PTYxsrk7+c73DCnawqp
=kIjZ
-----END PGP SIGNATURE-----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thank you for the information.
I saw nothing in the release notes for bzr 1.12
http://doc.bazaar-vcs.org/bzr.1.12/en/release-notes/NEWS.html#bzr-1-12-1234567890-2009-02-13

Are there separate release notes for bzr-svn?

http://bazaar-vcs.org/BzrForeignBranches/Subversion links to http://bazaar-vcs.org/BzrForeignBranches/Subversion/mapping, which is not yet written.

Are you saying that "bzr checkout" after an upgrade to bzr 1.12 should generate the missing mapping information and therefore take extra time? It didn't appear to do anything, at least not anything disk intensive as my computer was silent. How do I request the old mapping method?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (MingW32)

iD8DBQFJosRX33R6PCWxU9URAnj9AJ9XrvlLocVuAhu4/u7nyuMvp1cPEQCbBpfS
W2Rkar29kaZJFehkXLGrIiI=
=A9xf
-----END PGP SIGNATURE-----

Mark Hammond (mhammond) wrote :

To clarify, if you build on Vista the inclusion of powrprof.dll causes an almost identical error re msvcrt.dll as this initial bug report when run on a non-vista OS. IOW, excluding that dll should IMO be considered an important part of a resolution to this bug. Ironically, this issue re powrprof.dll led me to the same conclusion re msvcp60.dll - but just as I came back to this bug to say so I see everyone else came to the same conclusion ;)

John A Meinel (jameinel) wrote :

I just released a bzr-setup-1.12-2.exe which bundles bzr-svn 0.5.2 and should be filtering out the bad dll.

Changed in bzr:
importance: Undecided → High
milestone: none → 1.12
status: Confirmed → Fix Released
Neronyatkin (neronyatkin) wrote :

bzr push

MessageBox "___lc_collate_cp_func not find in DLL msvcrt.dll"

Using saved push location: svn://XX.XX.XX.XX/some/path/trunk
bzr: ERROR: exceptions.ImportError: Unable to load subvertpy extensions - did you build it?

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 896, in run_bzr_catch_errors
  File "bzrlib\commands.pyo", line 842, in run_bzr
  File "bzrlib\commands.pyo", line 542, in run_argv_aliases
  File "bzrlib\builtins.pyo", line 981, in run
  File "bzrlib\push.pyo", line 45, in _show_push_branch
  File "bzrlib\transport\__init__.pyo", line 1625, in get_transport
  File "bzrlib\transport\__init__.pyo", line 1648, in _try_transport_factories
  File "bzrlib\registry.pyo", line 61, in get_obj
  File "bzrlib\registry.pyo", line 66, in _do_import
  File "C:/Program Files/Bazaar/plugins\svn\transport.py", line 36, in <module>
  File "subvertpy\__init__.pyo", line 97, in <module>
ImportError: Unable to load subvertpy extensions - did you build it?

bzr 1.12 on python 2.5.2 (win32)
arguments: ['bzr', 'push']
encoding: 'cp1251', fsenc: 'mbcs', lang: None
plugins:
  bzrtools C:\Program Files\Bazaar\plugins\bzrtools [1.12]
  launchpad C:\Program Files\Bazaar\plugins\launchpad [unknown]
  netrc_credential_store C:\Program Files\Bazaar\plugins\netrc_credential_store
[unknown]
  qbzr C:\Program Files\Bazaar\plugins\qbzr [0.9.8]
  svn C:\Program Files\Bazaar\plugins\svn [0.5.2]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.

Changed in bzr:
status: Fix Released → Incomplete
kelley567jp (kelley567) wrote :

I worked well when I installed bzr-setup-1.12-2.exe.(Windows XP Home Edition SP3(Japanese))

Mark Hammond (mhammond) wrote :

STV: I don't think the new installer actually tries to remove any old copies that were previously installed; so if you just upgraded without uninstalling you may still have the problematic DLL. Please try either uninstalling then reinstalling or manually deleting msvcp60.dll from your Bazaar installation directory.

Neronyatkin (neronyatkin) wrote :

Mark Hammond: You're right. My mistake. Now working.

Changed in bzr:
status: Incomplete → Fix Released
Jamie Maher (jmaher-guser) wrote :

This bit me as well, upgrading directly from a previous version of Bzr without uninstalling first.. removing msvcp60.dll from the .\lib directory corrected the problem.

Maybe a note to uninstall, before installing for future versions?

Download full text (3.1 KiB)

maybe have the installer offer an option / suggestion to uninstall?

On Thu, Feb 26, 2009 at 12:55 PM, Jamie Maher <email address hidden> wrote:

> This bit me as well, upgrading directly from a previous version of Bzr
> without uninstalling first.. removing msvcp60.dll from the .\lib
> directory corrected the problem.
>
> Maybe a note to uninstall, before installing for future versions?
>
> --
> unable to find subvertpy (Windows Standalone Installer)
> https://bugs.launchpad.net/bugs/328181
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Bazaar Version Control System: Fix Released
>
> Bug description:
> bzr: ERROR: exceptions.ImportError: bzr-svn: unable to find subvertpy.
> Please install from http://launchpad.net/subvertpy.
>
> Traceback (most recent call last):
> File "bzrlib\commands.pyo", line 893, in run_bzr_catch_errors
> File "bzrlib\commands.pyo", line 839, in run_bzr
> File "bzrlib\commands.pyo", line 539, in run_argv_aliases
> File "C:/Program Files/Bazaar/plugins\qbzr\lib\commands.py", line 715, in
> run
> File "bzrlib\commands.pyo", line 839, in run_bzr
> File "bzrlib\commands.pyo", line 539, in run_argv_aliases
> File "bzrlib\builtins.pyo", line 3477, in run
> File "bzrlib\builtins.pyo", line 70, in tree_files
> File "bzrlib\builtins.pyo", line 119, in internal_tree_files
> File "bzrlib\workingtree.pyo", line 331, in open_containing
> File "bzrlib\bzrdir.pyo", line 844, in open_containing
> File "bzrlib\bzrdir.pyo", line 865, in open_containing_from_transport
> File "bzrlib\bzrdir.pyo", line 819, in open_from_transport
> File "bzrlib\lazy_import.pyo", line 125, in __call__
> File "bzrlib\transport\__init__.pyo", line 1680, in
> do_catching_redirections
> File "bzrlib\bzrdir.pyo", line 806, in find_format
> File "bzrlib\bzrdir.pyo", line 1645, in find_format
> File "C:/Program Files/Bazaar/plugins\svn\format.py", line 86, in
> probe_transport
> File "C:/Program Files/Bazaar/plugins\svn\format.py", line 56, in
> _check_versions
> File "C:/Program Files/Bazaar/plugins\svn\__init__.py", line 103, in
> lazy_check_versions
> File "C:/Program Files/Bazaar/plugins\svn\__init__.py", line 86, in
> init_subvertpy
> ImportError: bzr-svn: unable to find subvertpy. Please install from
> http://launchpad.net/subvertpy.
>
> bzr 1.12rc1 on python 2.5.2 (win32)
> arguments: ['C:\\Program Files\\Bazaar\\bzr.exe', 'qsubprocess', '"revert"
> "DOCs/\xd0\xf3\xea\xee\xe2\xee\xe4\xf1\xf2\xe2\xee
> \xef\xee\xeb\xfc\xe7\xee\xe2\xe0\xf2\xe5\xeb\xff.doc"']
> encoding: 'cp1251', fsenc: 'mbcs', lang: None
> plugins:
> bzrtools C:\Program Files\Bazaar\plugins\bzrtools [1.12]
> launchpad C:\Program Files\Bazaar\plugins\launchpad [unknown]
> netrc_credential_store C:\Program
> Files\Bazaar\plugins\netrc_credential_store [unknown]
> qbzr C:\Program Files\Bazaar\plugins\qbzr [0.9.7]
> svn C:\Program Files\Bazaar\plugins\svn [0.5]
> *** Bazaar has encountered an internal error.
> Please report a bug at https://bugs.launchpad.net/bzr/+filebug
> including this traceback, and a description of what you
> were doing when the ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers