Eclipse plugin can't find bzr-xmloutput

Bug #338960 reported by Reuben Firmin on 2009-03-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned
Bazaar Plugin for Eclipse
Undecided
Unassigned

Bug Description

See attachment for my config.

I'm getting the error message:
bzr-xmloutput >= 0.6.0 plugin not found

However, I just installed that today in my ~/.bazaar/plugins directory:

reubenf@fridge:~/.bazaar/plugins$ ls -al
total 16
drwxr-xr-x 4 reubenf reubenf 4096 2009-03-06 14:31 .
drwxr-xr-x 4 reubenf reubenf 4096 2009-03-05 13:44 ..
drwxr-xr-x 7 reubenf reubenf 4096 2009-03-06 14:31 bzr-xmloutput
drwxr-xr-x 3 reubenf reubenf 4096 2009-03-05 13:45 extmerge

Reuben Firmin (reubenf) wrote :
Reuben Firmin (reubenf) wrote :

Never mind, you can resolve. I had to rename to xmloutput. Bzr on the command line told me that.

Thanks

Guillermo Gonzalez (verterok) wrote :

Thanks for pointing out how you solved the issue.

Changed in bzr:
status: New → Invalid
Changed in bzr-eclipse:
status: New → Invalid
jwg366 (jwg366) wrote :

I had the same problem,but I had to install into Program Files/bazaar/plugins, not into %home%/.bazaar/plugins

hope this helps anyone.

Guillermo Gonzalez (verterok) wrote :

jwg366 ,
thanks for the followup.

popgo (unidba) wrote :

anyone sloved it.

wgodoy80 (wgodoy80) wrote :

The same error showed up if the folder .bazaar/pluigns was created by root (avoid using sudo). Avoiding root (or sudo) and renaming the bzr-xmloutput-* folder to xmloutput (with mv) solved it.

Xavier Marduel (xavjlm) wrote :

I'm getting the error : "xmloutput >= 0.9.2 plugin not found"

file .bzr.log contains:ed 2014-03-19 15:20:22 +0100
0.295 bazaar version: 2.6.0
0.295 bzr arguments: [u'xmlplugins']
0.300 looking for plugins in /Users/xavier/x_local/eclipse-4.2/plugins/org.vcs.bazaar.eclipse.client_1.4.0.201401310653/plugins
0.319 looking for plugins in /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/bzrlib/plugins
0.320 Plugin name rewrite already loaded
0.320 Plugin name xmloutput already loaded
0.465 encoding stdout as osutils.get_user_encoding() 'utf-8'
0.475 return code 0

As it can be seen, I'm using bazaar 2.6.0 on MacOSX
Eclipse 4.2.2 or 4.3 and latest bzr-eclipse
Pydev 2.8.2 is installed on eclipse

I've got the same problem on windows too!

Changed in bzr-eclipse:
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments