Comment 7 for bug 280888

Hi Russel,

On Sun, Oct 12, 2008 at 8:08 AM, Russel Winder
<email address hidden> wrote:
> I am still getting messages in the Console:
>
> Error while executing xmlstatus
> 'module' object has no attribute '_raise_if_nonexistent'
>
> which is a bit annoying. From the .bzr.log I am seeing:
>
> 1143.129 run_bzr_xml arguments: (['/home/users/russel/bin/bzr', 'xmlstatus', '/home/users/russel/Repositories/Bazaar/Masters/ADS'], '/home/users/russel/Repositories/Bazaar/Masters/ADS')
> 1143.129 bzr arguments: [u'xmlstatus', u'/home/users/russel/Repositories/Bazaar/Masters/ADS']
> 1143.139 encoding stdout as osutils.get_user_encoding() 'UTF-8'
> 1143.151 opening working tree '/home/users/russel/Repositories/Bazaar/Masters/ADS'
> 1143.173 Traceback (most recent call last):
> File "/home/users/russel/.bazaar/plugins/xmloutput/xml_errors.py", line 61, in xml_error_handling
> return func(*args, **kwargs)
> File "/home/users/russel/.bazaar/plugins/xmloutput/__init__.py", line 123, in run
> to_file=to_file, versioned=versioned)
> File "/home/users/russel/.bazaar/plugins/xmloutput/statusxml.py", line 143, in show_tree_status_xml
> diff._raise_if_nonexistent(specific_files, old, new)
> AttributeError: 'module' object has no attribute '_raise_if_nonexistent'
>

This error is related to an incompatible version of bzr and
bzr-xmloutput, it seems that in bzr.dev diff._raise_if_non_existent
was removed recently

I'll try to push a fix during the weekend.

Cheers,

>
> --
> Bzr eclipse doesn't work with latest Eclipse and latest Bzr
> https://bugs.launchpad.net/bugs/280888
> You received this bug notification because you are a member of bzr-
> eclipse developers, which is subscribed to Bazaar Plugin for Eclipse.
>
> Status in Bazaar Plugin for Eclipse: New
>
> Bug description:
> This may be something stupid I am doing but...
>
> I have just had to reinstall Eclipse 3.4 Ganymede on Ubuntu Hardy, I installed from the tarball I had and then immediately updated to get the Ganymede updates. I then installed all the plugins including the Bazaar one. My Bazaar installation is bzr.dev with xmloutput 0.6.1.
>
> Whenever I try to open a project that is a Bazaar branch I get:
>
> Error while executing xmlstatus
> <?xml version="1.0" encoding="UTF-8"?><error><class>AttributeError</class><dict></dict><message>'module' object has no attribute '_raise_if_nonexistent'</message></error>
> <?xml version="1.0" encoding="UTF-8"?><error><class>AttributeError</class><dict></dict><message>'module' object has no attribute '_raise_if_nonexistent'</message></error>
>
> and there is a great deal of activity that slows things down massively for every operation in Eclipse.
>
> Basically the project in unusable with the plugin installed.
>