Byobu breaks text copying

Bug #1020674 reported by Ryan Thompson on 2012-07-03
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
byobu
High
Dustin Kirkland 
byobu (Ubuntu)
High
Dustin Kirkland 

Bug Description

Recently, I've started having an issue that prevents me from copying text from a Byobu terminal. Whenever I highlight some text in the terminal, that text is immediately un-highlighted as soon as the clock in the status bar "ticks". This means that the text only stays highlighted for a second or less, so I have to click, drag, and press Control+Shift+C all in the span of one second or else I don't get to copy anything.

This only seems to happen on 12.04, with the latest Byobu from the PPA:

ryan@aeolus:~$ wajig policy byobu tmux
byobu:
  Installed: 5.20-0ubuntu1~ppa6
  Candidate: 5.20-0ubuntu1~ppa6
  Version table:
 *** 5.20-0ubuntu1~ppa6 0
        500 http://ppa.launchpad.net/byobu/ppa/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     5.17-0ubuntu1 0
        500 http://mirror.math.ucdavis.edu/ubuntu/ precise/main amd64 Packages
tmux:
  Installed: 1.6-1ubuntu1
  Candidate: 1.6-1ubuntu1
  Version table:
 *** 1.6-1ubuntu1 0
        500 http://mirror.math.ucdavis.edu/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Ryan Thompson (rct86) on 2012-07-10
description: updated
description: updated
Zorael (zorael) wrote :

Persists in Kubuntu 12.10, byobu 5.21-0ubuntu1 and tmux 1.6-2 both from quantal main.

https://bugs.launchpad.net/ubuntu/+source/byobu/+bug/1018538

Dustin Kirkland  (kirkland) wrote :

I think this is a dupe of Bug #1018538 and Bug #1073145, which I just committed a proposed fix...

Changed in byobu:
status: New → Fix Committed
Changed in byobu (Ubuntu):
status: New → Fix Committed
Changed in byobu:
importance: Undecided → High
Changed in byobu (Ubuntu):
importance: Undecided → High
Changed in byobu:
assignee: nobody → Dustin Kirkland (kirkland)
Changed in byobu (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.23-0ubuntu1

---------------
byobu (5.23-0ubuntu1) raring; urgency=low

  [ Dustin Kirkland ]
  * configure.ac, debian/control, debian/copyright, README,
    usr/lib/byobu/rcs_cost, usr/share/man/man1/byobu.1,
    usr/share/man/man1/byobu-config.1, usr/share/man/man1/byobu-ctrl-
    a.1, usr/share/man/man1/byobu-enable.1, usr/share/man/man1/byobu-
    janitor.1, usr/share/man/man1/byobu-launcher.1,
    usr/share/man/man1/byobu-launcher-install.1,
    usr/share/man/man1/byobu-launcher-uninstall.1,
    usr/share/man/man1/byobu-layout.1, usr/share/man/man1/byobu-quiet.1,
    usr/share/man/man1/byobu-reconnect-sockets.1,
    usr/share/man/man1/byobu-screen.1, usr/share/man/man1/byobu-select-
    backend.1, usr/share/man/man1/byobu-select-profile.1,
    usr/share/man/man1/byobu-select-session.1, usr/share/man/man1/byobu-
    shell.1, usr/share/man/man1/byobu-silent.1,
    usr/share/man/man1/byobu-status.1, usr/share/man/man1/byobu-status-
    detail.1, usr/share/man/man1/byobu-tmux.1:
    - point to the new byobu.co website rather than the launchpad landing
      page
  * usr/share/byobu/profiles/common: LP: #1089008
    - re-enable shift-pgup/shift-pgdn in the terminal buffer in screen,
      to match our default in tmux
  * === added directory usr/share/byobu/pixmaps/highcontrast,
    debian/install, usr/share/byobu/pixmaps/highcontrast/byobu.svg:
    - add a byobu high contrast icon, LP: #1082241
    - simplify, removing detail
  * usr/lib/byobu/distro, usr/lib/byobu/logo: LP: #1094716
    - try to improve logo printing and distro detection on Mac
  * debian/control, debian/rules, usr/bin/byobu-config, usr/bin/byobu-
    select-session: LP: #1043048
    - get our python code pep8 compliant
      + except use tabs instead of spaces, and allow lines longer than
        80 characters
    - this should get byobu's python code working better with python3
  * debian/postrm:
    - fix lintian error

  [ Dustin Kirkland and Philip Muškovac ]
  * usr/lib/byobu/battery: LP: #1090831
    - some batteries use "CHARGE" while others use "ENERGY"

  [ Antonio Lorusso ]
  * usr/bin/byobu-status: LP: #1018538, #1073145, #1020674
    - fix select/copy/paste in iTerm2 and KDE
 -- Dustin Kirkland <email address hidden> Mon, 05 Nov 2012 13:48:13 +0100

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
Changed in byobu:
status: Fix Committed → Fix Released
Hendy Irawan (ceefour) wrote :

Antonio Lorusso, Thanks for fixing this !

Hendy Irawan (ceefour) wrote :

Related to bug #1018538

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers