[FFE] bindwood is incompatible with Firefox 4

Bug #648587 reported by LordPhoenix on 2010-09-27
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Bindwood
High
James Henstridge
bindwood (Ubuntu)
High
James Henstridge
Natty
High
James Henstridge

Bug Description

I'm using Firefox 4 beta and bindwood is not yet compatible with it. You should make it available so that we could test it…

We need a feature freeze exception for this for Natty. Without this making it in, Ubuntu One bookmarks sync will not work.

Related branches

Brewersfan121 (brewersfan121) wrote :

I have it installed on Firefox 4.0b8pre, and Firefox has been crashing. It didn't start crashing until I installed Bindwood, so I'm wondering if Bindwood is crashing Firefox 4. The crash reports won't load properly, so we have no way of knowing. (This is the Mozilla build, not the Ubuntu build)

James Henstridge (jamesh) wrote :

We will be adding Firefox 4.0 support to Bindwood. It is a bit more work than just bumping the maxVersion value in the install.rdf file though, which is why it hasn't been done yet.

James Henstridge (jamesh) wrote :

May as well assign this to myself. Firefox 4.0 compatibility is one of the features planned for the next version.

Changed in bindwood:
assignee: nobody → James Henstridge (jamesh)
importance: Undecided → High
status: New → In Progress
Changed in bindwood:
milestone: none → 1.1.0
Changed in bindwood (Ubuntu):
assignee: nobody → James Henstridge (jamesh)
status: New → Triaged
importance: Undecided → High
summary: - bindwood is incompatible with Firefox 4
+ [FFE] bindwood is incompatible with Firefox 4
description: updated
Iulian Udrea (iulian) wrote :

Approved. Please get this in.

(Next time when you subscribe ubuntu-release please make sure that the status of the bug is set to "New", otherwise it won't appear on our radar.)

Changed in bindwood (Ubuntu Natty):
status: Triaged → Confirmed
Changed in bindwood (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
tags: added: u1-natty
tags: added: u1-natty-beta
Changed in bindwood:
status: In Progress → Fix Committed
Changed in bindwood:
status: Fix Committed → Fix Released
James Henstridge (jamesh) wrote :

A tarball of the 1.99.0 release is now available here:

https://launchpad.net/bindwood/trunk/1.99.0

I've updated the packaging used for the ubuntuone nightlies PPA packages here:

https://code.launchpad.net/~jamesh/bindwood/packaging-dailies-1.99.0

This integrates the changes from the upstream Ubuntu packaging, so should be a good base for a new Ubuntu package. The main changes are:

 1. update the copyright file to match the current source code layout.
 2. get rid of the 01_no_chmod.patch patch, since it is no longer needed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bindwood - 1.99.0-0ubuntu1

---------------
bindwood (1.99.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    - New synchronisation engine.
    - Adds Firefox 4 compatibility (LP: #648587).
  * Remove patches/01_no_chmod.patch since Bindwood no longer requires
    the couchdb_env.sh script to be executable.
 -- James Henstridge <email address hidden> Wed, 16 Mar 2011 14:44:28 +0800

Changed in bindwood (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers