Banshee corrupts certain music files

Reported by Jonathan Blackhall on 2010-05-27
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Banshee
New
High
banshee (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned
banshee-community-extensions (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: banshee

I purchased the album Lungs by Florence + the Machine from AmazonMP3. The first time I downloaded it, I tried pyMazon. It worked well, but as I started listening to the album in Banshee, I noticed some noise distortion after I listened to a song or two (sort of like squeeks, listen to attached mp3). I quit Banshee and tried to listen to some of the songs in Totem. The ones that had squeeked in Banshee, also squeeked in Totem, but others that I hadn't played using Banshee worked fine. I thought maybe a file or two had been corrupted during download, so I re-opened Banshee and started playing the rest of the album. Low and behold, some of the songs that had just played fine in Totem now had squeeks in Banshee. When I quit Banshee and opened the same song in Totem, it now had the squeeks there also.

Now I started thinking maybe I had *somehow* missed the squeeks the first time listening in Totem and that the entire album had been corrupted somehow during download with pyMazon. Unfortunately, I hadn't had a chance to make a back-up of the files and now they ALL had squeeks in them. Forunately, I got the AmazonMP3 store to re-open the download for me. I deleted the original (now corrupted) album. This time I downloaded using the actual AmazonMP3 installer (for Windows) via Wine (since I can't get AmazonMP3's native downloader to work with Lucid).

After re-downloading the album, I made a back-up of the files right away. I started by opening a bunch of the songs individually in Totem and Rhythmbox. They had no squeeks, so I chalked up my problem to a corrupted download from pyMazon. However, today I wanted to listen to the album again, so again I opened Banshee. The first song played fine. The second song (one which I'm confident I had checked in Rhythmbox and Totem just a few days ago) started squeeking. I quit Banshee and opened up the file in Totem, and it squeeked there too!!

I then ran md5sums on the original and the back-up of the song that squeeks and a song I'm positive I haven't played yet in Banshee ("09 - Cosmic Love.mp3" is the song that squeeks):

jonathan@jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ md5sum "09 - Cosmic Love.mp3"
261ab6c0b58811a41706001c8874f00c 09 - Cosmic Love.mp3

jonathan@jonathan-laptop:~/Downloads/Florence + The Machine/Lungs$ md5sum "09 - Cosmic Love.mp3"
00da0f56c209d65ec25fe2397c088a53 09 - Cosmic Love.mp3

jonathan@jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ md5sum "12 - Blinding.mp3"
9280f68424d5d132830b559041ed8ca3 12 - Blinding.mp3

jonathan@jonathan-laptop:~/Downloads/Florence + The Machine/Lungs$ md5sum "12 - Blinding.mp3"
9280f68424d5d132830b559041ed8ca3 12 - Blinding.mp3

What the hell?

If you want to hear it, listen to the attached excerpts.

I'm using the default Banshee 1.6.0-1 packaged with Ubuntu 10.04 64-bit with plugins: application indicator, lyrics, ubuntu one music store, wikipedia, audio cd, audiobooks, file system preview, internet radio, play queue, podcasts, ipod support, karma support, mass storage media player support, mtp media player support, internet archive, last.fm, bookmarks, bpm, cover art, daap, importers for amarok etc, library watcher, multimedia keys

I also have the boxes checked (in Edit->Preferences): Write Metadata to files, Write ratings and play counts to files. Perhaps the problem is related to those 2 boxes?

I also think it may have something to do with the "+" symbol in either the Artist ID3 tag or the file path. I have played other music in Banshee in the last couple of days and this seems to be the only album affected that I've found.

Regardless, I definitely think this is a major bug. Please let me know what more information I can provide. My Banshee application also intermittently starts to freeze/hang occasionally. I think it was actually doing that when I was playing one of the songs that ended up getting squeeks in it earlier.

TEST CASE (for banshee-community-extensions lucid SRU):
1. Backup a music file (it should not contain lyrics in it, verify with id3v2 -l)
2. Start Banshee (with lyrics extension enabled)
3. Turn off the "Write metadata to files" option.
4. Play the music file, and view the lyrics to make sure it is loaded.
5. Check that the music file is unchanged (lyrics should still not be present using id3v2 -l)

PATCH: http://gitorious.org/banshee-community-extensions/banshee-community-extensions/commit/f12d70a1b2a3a0a380ecabfcf7a3b15fe0c989ae (included in upstream sources already).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: banshee 1.6.0-1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
Date: Wed May 26 20:09:25 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee

adding normal sample

Gabriel Burt (gabaug) wrote :

Make sure the equalizer is disabled - View -> Equalizer menu.

Not at home right now so I can't check, but would the equalizer make permanent changes to the music file? A once-normal song (played in Totem), after being played in Banshee, has this distortion in both Banshee and Totem, as per my description above.

I am seeing exactly the same bug with the Ubuntu 10.04 banshee package on amd64.

Nearly all (if not really all) MP3s I play have these scratches/squeeks permanently after playing them once in Banshee. The files I tried with are all rippend and encoded (using lame) by myself.

It seems that really the MP3 file itself gets somehow corrupted - it has nothing to do with any equalizer settings. To track down the source of the error, I made a backup of one file before playing it in Banshee. Obviously banshee changes something within the file while playing it

This is the file before playing it in banshee (I made this backup copy just before playing the file):
-rw-r--r-- 1 peter peter 6755509 2010-05-27 22:53 10 - Tiger Of Sabrod.mp3.orig

And this is the file after being played in banshee:
-rw-r--r-- 1 peter peter 6759403 2010-05-27 22:54 10 - Tiger Of Sabrod.mp3

As you easily can see, the file has been changed (new timestamp, different size). I have not(!) activated this "writemeta tag to file" option because in general I don't want my players to change my files. Why does banshee change the file nevertheless and even corrupts it by doing this?

I agree this is a major bug because it can render the whole music collection unusable (if you don't have a backup:) ).

Aha... just found out that banshee is at least adding another ID3v1 tag (in addition to the existing ID3v2 tag) and the lyrics to the MP3 (even though I advised not to change the meta data in my files!):

Original file:
$ id3v2 -l 10\ -\ Tiger\ Of\ Sabrod.mp3.orig
id3v2 tag info for 10 - Tiger Of Sabrod.mp3.orig:
TSSE (Software/Hardware and settings used for encoding): LAME 64bits version 3.98.2 (http://www.mp3dev.org/)
TIT2 (Title/songname/content description): Tiger Of Sabrod
TPE1 (Lead performer(s)/Soloist(s)): Powerwolf
TALB (Album/Movie/Show title): Lupus Dei
TYER (Year): 2007
TRCK (Track number/Position in set): 10/11
TCON (Content type): Power Metal (255)
TLEN (Length): 233280

---> only one id3v2 tag, no id3v1 tag

File after being played and corrupted by banshee:
id3v2 -l 10\ -\ Tiger\ Of\ Sabrod.mp3
id3v1 tag info for 10 - Tiger Of Sabrod.mp3:
Title : Tiger Of Sabrod Artist: Powerwolf
Album : Lupus Dei Year: 2007, Genre: Unknown (255)
Comment: Track: 10
id3v2 tag info for 10 - Tiger Of Sabrod.mp3:
TSSE (Software/Hardware and settings used for encoding): LAME 64bits version 3.98.2 (http://www.mp3dev.org/)
TIT2 (Title/songname/content description): Tiger Of Sabrod
TPE1 (Lead performer(s)/Soloist(s)): Powerwolf
TALB (Album/Movie/Show title): Lupus Dei
TYER (Year): 2007
TRCK (Track number/Position in set): 10/11
TCON (Content type): Power Metal (255)
TLEN (Length): 233280
USLT (Unsynchronized lyric/text transcription): ()[deu]:
Cantus lupus
Satura luna
Corpus nudus domina
Agnus totus
Animus mortus
Ave deus sinistra
Cultus lupus
Opus damnatus
Metus mortis nocturna
Terra sanguis
Padre occultus
Sanctus pupus anima
Dark is the day
God of the grey
Born to obey
All they will say
Mine is the way
Fall down and pray
Hey, hey, wolfes don't pray!
Symbols of pain
Out in the rain
sent to remain
The harvest of the grain
Mine is the blame
The curse of the sane
Hey, hey, wolfes don't pray!
Ahh - Lupus dei
At night in the forest of Sabrod
A tiger in search of his prey
I wonder will we be alive by the dawning of day?
Predator of godly creation
In hunger he stops at no child
Obsessed by the fever to follow the call of the wild
Take this life
And you're safe
Say goodbye for today
It's the tiger of Sabrod
And he's fighting from the heart
Will you return?
Tiger of Sabrod
Oh - Tiger of Sabrod
The eyes of the tiger are closed now
And lifeless he lies in the mud
Don't trust in your triumoh and glory
Revenge will bring blood
At night he will raise from the dead ones
And then he will search you all night and day
The wolf will still live on tomorrow - Survivors will pay!
Take this life
And you're safe
Say goodbye for today
It's the tiger of Sabrod
And he's fighting from the heart
Will you return?
Tiger of Sabrod
Oh - Tiger of Sabrod

 Powered by LyricsPlugin (http://www.lyricsplugin.com)

--> now there is also an id3v1 tag (which is completely useless to me) and the lyrics.

Glad to hear it's not just me. I won't be glad to hear this in all my music though (if it ends up that way). Thanks for narrowing down the problem. I'm going to report it upstream.

Changed in banshee (Ubuntu):
status: New → Confirmed
status: Confirmed → New

@Gabriel, just to confirm, my equalizer is disabled

Changed in banshee:
status: Unknown → New
Artem Yakimenko (temik) wrote :

Same thing here, Banshee corrupts files in my library exactly the same way.
I'm glad I had a backup, switching to rhytmbox until it gets fixed.
Some of my music was very hard to find, I'd hate to lose it because of a simple bug.

Acknowledged upstream, so confirming here. According to the upstream bug report, this issue may be larger than just the lyrics plugin, since this should not be corrupting the music files.

Changed in banshee (Ubuntu):
status: New → Confirmed
Changed in bansheelyricsplugin (Ubuntu):
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

This package has been removed in favour of the banshee-extension-lyrics that comes from the combined banshee-community-extensions project.

Changed in bansheelyricsplugin (Ubuntu):
status: Confirmed → Invalid
Chow Loong Jin (hyperair) wrote :

Er whoops, I meant to reassign it to banshee-community-extensions. Anyway the fix (regarding writing lyrics to the files) was committed upstream as commit f12d70a1b2a3a0a380ecabfcf7a3b15fe0c989ae.

affects: bansheelyricsplugin (Ubuntu) → banshee-community-extensions (Ubuntu)
Changed in banshee-community-extensions (Ubuntu):
status: Invalid → Fix Committed

Per Bertrand Lorentz upstream: "The main issue is still valid : the file should not get corrupted. Further
investigation is needed."

Unfortunately I don't know what further investigation I can provide.

On Sun, 06 Jun 2010 23:38:47 -0000
Jonathan Blackhall <email address hidden> wrote:

> Per Bertrand Lorentz upstream: "The main issue is still valid : the file
> should not get corrupted. Further investigation is needed."
>
> Unfortunately I don't know what further investigation I can provide.
>

I think he means that you should perform the md5sum test again (which you did
at the beginning of this bug report) after the fix for banshee-extension-lyrics
has been released. Banshee Community Extensions 1.6.1 is due pretty soon,
and the fix would be part of it.

--
Kind regards,
Chow Loong Jin

Chow Loong Jin (hyperair) wrote :

Fixed in 1.6.1-1.

Changed in banshee-community-extensions (Ubuntu):
status: Fix Committed → Fix Released

For the sake of clarity, is this fixed now in ubuntu lucid standard repositorys?

At the moment I can get 1.6.1-1~lucid1 for the "banshee" package (updated a couple of hours ago) and 1.6.0-1ubuntu5 for the "banshee-community-extensions" package (also the "banshee-extension-lyrics package).

As far as I could find out, there is only a "banshee-community-extensions" package in version 1.6.1 available for the upcoming ubuntu 10.10.

So is it enough to have banshee 1.6.1-1~lucid1 and banshee-coummunity-extenions 1.6.0-1ubuntu5 to not run into this bug anymore? It would be more than bad to shredder music files again...

Chow Loong Jin (hyperair) wrote :

On Sat, 26 Jun 2010 14:20:56 -0000
Jürgen 'jiha' Harter <email address hidden> wrote:

> For the sake of clarity, is this fixed now in ubuntu lucid standard
> repositorys?
>
> At the moment I can get 1.6.1-1~lucid1 for the "banshee" package
> (updated a couple of hours ago) and 1.6.0-1ubuntu5 for the "banshee-
> community-extensions" package (also the "banshee-extension-lyrics
> package).
>
> As far as I could find out, there is only a "banshee-community-
> extensions" package in version 1.6.1 available for the upcoming ubuntu
> 10.10.
>
> So is it enough to have banshee 1.6.1-1~lucid1 and banshee-coummunity-
> extenions 1.6.0-1ubuntu5 to not run into this bug anymore? It would be
> more than bad to shredder music files again...
>

You can disable the lyrics extension, which is to blame for
modifications to music files. The version of
banshee-extension-lyrics (from banshee-community-extensions) that fixes
this bug is 1.6.1, which is not in Lucid yet. It's been uploaded and
pending approval though.

This same version is available in the Banshee PPA
(https://launchpad.net/~banshee-team/+archive/ppa) if you're impatient.

--
Kind regards,
Chow Loong Jin

I can only get banshee-community-extensions 1.6.0-1 from the PPA, although banshee 1.6.1-1 is available.

I am also curious if this problem is fully resolved with the proposed fix, since upstream did not seem convinced that the lyrics plugin was the only problem. Any thoughts?

Chow Loong Jin (hyperair) wrote :

On Sun, 27 Jun 2010 17:44:39 -0000
Jonathan Blackhall <email address hidden> wrote:

> I am also curious if this problem is fully resolved with the proposed
> fix, since upstream did not seem convinced that the lyrics plugin was
> the only problem. Any thoughts?
>

Well, I haven't noticed any corruption done to my files, though it
probably would be worth keeping a backup of your music collection, and
comparing the md5/sha1 checksums of files after playing them.

The Banshee task is kept open, as whether this issue does exist or not
is kind of ambiguous at the moment (it might have been a misplaced bug
that was originally just the lyrics extension). If you (or the original
bug reporter) can confirm whether this bug exists without the lyrics
extension, it'd be great.

--
Kind regards,
Chow Loong Jin

Jonathan Riddell (jr) wrote :

1.6.1-1ubuntu1~lucid1 is waiting in lucid-proposed unapproved queue. It needs approval from ubuntu-sru to be accepted. I don't see a patch on this bug (or the other three addressed by the same upload) for them to approve. I don't see a test case for it to be tested with.

description: updated
John Dong (jdong) wrote :

Hi all,

Why is the diff so huge for a single listed patch?

Chow Loong Jin (hyperair) wrote :

On Sat, 03 Jul 2010 04:51:02 -0000
John Dong <email address hidden> wrote:

> Hi all,
>
> Why is the diff so huge for a single listed patch?
>

If you're referring to the debdiff, that's because there are three
other Launchpad bugs fixed by this upload, among other bugfixes that
aren't reported in Launchpad.

--
Kind regards,
Chow Loong Jin

Accepted banshee-community-extensions into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in banshee-community-extensions (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Download full text (4.2 KiB)

I just updated to the version of the lyrics plugin in lucid-proposed (banshee-extension-lyrics 1.6.1-1ubuntu1~lucid2) and enabled it. Although I haven't heard any distortion yet, there is still a change in the md5 sum (although could this change be due to automatic downloading of album art?). This was done after freshly copying my backup (from my Downloads folder) to my main Music folder. The md5sums match:
jonathan@jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ md5sum 09*
00da0f56c209d65ec25fe2397c088a53 09 - Cosmic Love.mp3
jonathan@jonathan-laptop:~/Downloads/Florence + The Machine/Lungs$ md5sum 09*
00da0f56c209d65ec25fe2397c088a53 09 - Cosmic Love.mp3

Now this was done after playing the song in Banshee with the lyrics plugin enabled. They don't match:
jonathan@jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ md5sum 09*
00da0f56c209d65ec25fe2397c088a53 09 - Cosmic Love.mp3
jonathan@jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ md5sum 09*
dd0015cb90b46cf1d62fab700c683428 09 - Cosmic Love.mp3

I also compared the id3 tags as described above by Peter Weissgerber. You'll see they've still been edited:
jonathan@jonathan-laptop:~/Downloads/Florence + The Machine/Lungs$ id3v2 -l 09\ -\ Cosmic\ Love.mp3
id3v1 tag info for 09 - Cosmic Love.mp3:
Title : Cosmic Love Artist: Florence + The Machine
Album : Lungs Year: 2009, Genre: Alternative (20)
Comment: Amazon.com Song ID: 21195894 Track: 9
id3v2 tag info for 09 - Cosmic Love.mp3:
TCOM (Composer): Florence Welch
TIT2 (Title/songname/content description): Cosmic Love
TCOP (Copyright message): (C) 2009 Universal Island Records Ltd. A Universal Music Company.
TCON (Content type): Alternative Rock (255)
TPE1 (Lead performer(s)/Soloist(s)): Florence + The Machine
TPE3 (Conductor/performer refinement):
TALB (Album/Movie/Show title): Lungs
COMM (Comments): ()[eng]: Amazon.com Song ID: 211958944
TRCK (Track number/Position in set): 9/13
APIC (Attached picture): ()[, 3]: image/jpeg, 77143 bytes
TPE2 (Band/orchestra/accompaniment): Florence + The Machine
TPOS (Part of a set): 1/1
TYER (Year): 2009

jonathan@jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ id3v2 -l 09\ -\ Cosmic\ Love.mp3
id3v1 tag info for 09 - Cosmic Love.mp3:
Title : Cosmic Love Artist: Florence + The Machine
Album : Lungs Year: 2009, Genre: Alt. Rock (40)
Comment: Amazon.com Song ID: 21195894 Track: 9
id3v2 tag info for 09 - Cosmic Love.mp3:
TCOM (Composer): Florence Welch
TIT2 (Title/songname/content description): Cosmic Love
TCOP (Copyright message): (C) 2009 Universal Island Records Ltd. A Universal Music Company.
TCON (Content type): Alt. Rock (40)
TPE1 (Lead performer(s)/Soloist(s)): Florence + The Machine
TALB (Album/Movie/Show title): Lungs
COMM (Comments): ()[eng]: Amazon.com Song ID: 211958944
TRCK (Track number/Position in set): 9/13
APIC (Attached picture): ()[, 3]: image/jpeg, 77143 bytes
TPE2 (Band/orchestra/accompaniment): Florence + The Machine
TPOS (Part of a set): 1/1
TYER (Year): 2009
USLT (Unsynchronized lyric/text transcripti...

Read more...

Sorry, I misunderstood the upstream bug report. Apparently the lyrics plugin is supposed to follow the Edit->Preferences "Write Metadata to Files" option. If that is unchecked, the lyrics are not written to an id3 tag. If it is checked, they are. This now works correctly. My question still stands whether the lyrics plugin is corrupting the music by adding the lyrics to the song in an id3 tag, but as I said a few minutes ago, with the new version of the lyrics plugin, I haven't had any distortion of my music so far (knock on wood).

On Thu, 08 Jul 2010 01:01:03 -0000
Jonathan Blackhall <email address hidden> wrote:

> Sorry, I misunderstood the upstream bug report. Apparently the lyrics
> plugin is supposed to follow the Edit->Preferences "Write Metadata to
> Files" option. If that is unchecked, the lyrics are not written to an
> id3 tag. If it is checked, they are. This now works correctly. My
> question still stands whether the lyrics plugin is corrupting the
> music by adding the lyrics to the song in an id3 tag, but as I said a
> few minutes ago, with the new version of the lyrics plugin, I haven't
> had any distortion of my music so far (knock on wood).
>

Could you check if the checksums change when "Write metadata to files"
is disabled? If the checksums don't change, then we'll know that
Banshee no longer corrupts files when playing them. As for sound
distortion, check that your equalizer (View->Equalizer, or Ctrl+E) is
disabled, or pick a different profile. Some equalizer profiles cause
sound to crack up on certain speakers and headphones.

--
Kind regards,
Chow Loong Jin

When "Write metadata to files" is disabled, the checksums are now identical, even with the lyrics plugin enabled. The id3 tags are also unchanged.

>"If the checksums don't change, then we'll know that Banshee no longer corrupts files when playing them."
My issue with that is: I want to leave the "Write metadata to files" option checked when I'm using Banshee. That way if I make changes to the normal id3 tags of my music in Banshee, they're saved in the actual music file. I'm still not quite sure why the lyrics plugin writes the lyrics to an id3 tag. Even more concerning is why writing the lyrics to an id3 tag corrupts the audio (which the upstream developer also acknowledged). What I'd really like to see: "even if the checksums do change (if the write option is enabled), Banshee will no longer corrupt files when playing them." This may very well be true now. However I can't be sure at this point. It's looking promising though. I haven't gotten any corruption yet, but I'm going to keep trying with the write option enabled and the lyrics plugin enabled just to see.

Also, I have never had the equalizer enabled in Banshee and this distortion is/was not an equalizer problem. Once the music files were corrupted by Banshee, the same distortion was also present when opening the music file in Totem and Rhythmbox.

Chow Loong Jin (hyperair) wrote :

On Friday 09,July,2010 09:16 AM, Jonathan Blackhall wrote:
> When "Write metadata to files" is disabled, the checksums are now identical,
> even with the lyrics plugin enabled. The id3 tags are also unchanged.
>
>> "If the checksums don't change, then we'll know that Banshee no longer
>> corrupts files when playing them."
> My issue with that is: I want to leave the "Write metadata to files" option
> checked when I'm using Banshee. That way if I make changes to the normal id3
> tags of my music in Banshee, they're saved in the actual music file. I'm
> still not quite sure why the lyrics plugin writes the lyrics to an id3 tag.

The Lyrics extension writes the lyrics to an id3 tag because there is a
specification for adding the lyrics there. This is to be expected, IMO. Perhaps
there should be an option for telling the Lyrics extension not to automatically
write lyrics to the tags.

> Even more concerning is why writing the lyrics to an id3 tag corrupts the
> audio (which the upstream developer also acknowledged). What I'd really like
> to see: "even if the checksums do change (if the write option is enabled),
> Banshee will no longer corrupt files when playing them." This may very well
> be true now. However I can't be sure at this point. It's looking promising
> though. I haven't gotten any corruption yet, but I'm going to keep trying
> with the write option enabled and the lyrics plugin enabled just to see.

You did mention sometime back that there were some files that had the audio get
corrupted. Do you remember which files they were? Perhaps you could get Banshee
to play those files again and check if the audio gets corrupted.

> Also, I have never had the equalizer enabled in Banshee and this distortion
> is/was not an equalizer problem. Once the music files were corrupted by
> Banshee, the same distortion was also present when opening the music file in
> Totem and Rhythmbox.

Definitely not an equalizer problem then :-)

--
Kind regards,
Chow Loong Jin

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee-community-extensions - 1.6.1-1ubuntu1~lucid2

---------------
banshee-community-extensions (1.6.1-1ubuntu1~lucid2) lucid-proposed; urgency=low

  * Disable Telepathy extension again, it wasn't supposed to have been
    enabled for Lucid's SRU

banshee-community-extensions (1.6.1-1ubuntu1~lucid1) lucid-proposed; urgency=low

  * No change upload to lucid-proposed
  * Bugs fixed:
    + AppIndicator extension not aware of window status (LP: #584364)
    + LiveRadio extension doesn't work with shoutcasts stations (LP: #572819)
    + StreamRecorder extension does not work with any webradio (LP: #581832)
    + Lyrics extension does not honour "Write metadata to files" setting
      (LP: #586174)
 -- Chow Loong Jin <email address hidden> Fri, 02 Jul 2010 18:52:07 +0800

Changed in banshee-community-extensions (Ubuntu Lucid):
status: Fix Committed → Fix Released
Artem Yakimenko (temik) wrote :

Still corrupts music files with lyrics plugin turned on.
Ubuntu lucid
Banshee 1.6.1-1~lucid1
Banshee-extension-lyrics 1.6.1-1ubuntu1~lucid2

MD5 before(backup):
~/HAL/Data/Music/El Cuarteto de Nos/[2006] Raro$ md5sum 06*
4ee30bebfe114c60f7b67713f60e8287 06 Ya no sé que hacer conmigo.mp3
MD5 after:
~/Music/El Cuarteto de Nos/[2006] Raro$ md5sum 06*
5da26486e12b14726c9125f758e53534 06 Ya no sé que hacer conmigo.mp3

Guys, this bug is quite serious! Banshee is supposed to play music not screw it up beyond repair.

Chow Loong Jin (hyperair) wrote :

On Friday 30,July,2010 05:04 PM, Artem Yakimenko wrote:
> Still corrupts music files with lyrics plugin turned on.
> Ubuntu lucid
> Banshee 1.6.1-1~lucid1
> Banshee-extension-lyrics 1.6.1-1ubuntu1~lucid2
>
> MD5 before(backup):
> ~/HAL/Data/Music/El Cuarteto de Nos/[2006] Raro$ md5sum 06*
> 4ee30bebfe114c60f7b67713f60e8287 06 Ya no sé que hacer conmigo.mp3
> MD5 after:
> ~/Music/El Cuarteto de Nos/[2006] Raro$ md5sum 06*
> 5da26486e12b14726c9125f758e53534 06 Ya no sé que hacer conmigo.mp3
>
> Guys, this bug is quite serious! Banshee is supposed to play music not
> screw it up beyond repair.
>

Did you uncheck "Write metadata to files" in preferences dialog? If you have,
please upload a before/after sample of an mp3 that is affected for debugging
purposes.

--
Kind regards,
Chow Loong Jin

Artem Yakimenko (temik) wrote :
Download full text (6.6 KiB)

No, "write metadata" is still cheked. Is it not supposed to be checked?

Regards,
Artem Yakimenko

On Sat, Jul 31, 2010 at 12:07 AM, Chow Loong Jin <email address hidden>wrote:

> On Friday 30,July,2010 05:04 PM, Artem Yakimenko wrote:
> > Still corrupts music files with lyrics plugin turned on.
> > Ubuntu lucid
> > Banshee 1.6.1-1~lucid1
> > Banshee-extension-lyrics 1.6.1-1ubuntu1~lucid2
> >
> > MD5 before(backup):
> > ~/HAL/Data/Music/El Cuarteto de Nos/[2006] Raro$ md5sum 06*
> > 4ee30bebfe114c60f7b67713f60e8287 06 Ya no sé que hacer conmigo.mp3
> > MD5 after:
> > ~/Music/El Cuarteto de Nos/[2006] Raro$ md5sum 06*
> > 5da26486e12b14726c9125f758e53534 06 Ya no sé que hacer conmigo.mp3
> >
> > Guys, this bug is quite serious! Banshee is supposed to play music not
> > screw it up beyond repair.
> >
>
> Did you uncheck "Write metadata to files" in preferences dialog? If you
> have,
> please upload a before/after sample of an mp3 that is affected for
> debugging
> purposes.
>
> --
> Kind regards,
> Chow Loong Jin
>
> --
> Banshee corrupts certain music files
> https://bugs.launchpad.net/bugs/586174
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Banshee Music Player: New
> Status in “banshee” package in Ubuntu: Confirmed
> Status in “banshee-community-extensions” package in Ubuntu: Fix Released
> Status in “banshee” source package in Lucid: New
> Status in “banshee-community-extensions” source package in Lucid: Fix
> Released
>
> Bug description:
> Binary package hint: banshee
>
> I purchased the album Lungs by Florence + the Machine from AmazonMP3. The
> first time I downloaded it, I tried pyMazon. It worked well, but as I
> started listening to the album in Banshee, I noticed some noise distortion
> after I listened to a song or two (sort of like squeeks, listen to attached
> mp3). I quit Banshee and tried to listen to some of the songs in Totem.
> The ones that had squeeked in Banshee, also squeeked in Totem, but others
> that I hadn't played using Banshee worked fine. I thought maybe a file or
> two had been corrupted during download, so I re-opened Banshee and started
> playing the rest of the album. Low and behold, some of the songs that had
> just played fine in Totem now had squeeks in Banshee. When I quit Banshee
> and opened the same song in Totem, it now had the squeeks there also.
>
> Now I started thinking maybe I had *somehow* missed the squeeks the first
> time listening in Totem and that the entire album had been corrupted somehow
> during download with pyMazon. Unfortunately, I hadn't had a chance to make
> a back-up of the files and now they ALL had squeeks in them. Forunately, I
> got the AmazonMP3 store to re-open the download for me. I deleted the
> original (now corrupted) album. This time I downloaded using the actual
> AmazonMP3 installer (for Windows) via Wine (since I can't get AmazonMP3's
> native downloader to work with Lucid).
>
> After re-downloading the album, I made a back-up of the files right away.
> I started by opening a bunch of the songs individually in Totem and
> Rhythmbox. They had no squeeks, so I chalked up my problem to a corrupted
> ...

Read more...

Chow Loong Jin (hyperair) wrote :

On Sunday 01,August,2010 03:41 AM, Artem Yakimenko wrote:
> No, "write metadata" is still cheked. Is it not supposed to be checked?

When it is checked, the lyrics extension will automatically write the lyrics to
the metadata of the mp3 file as an IDv3 tag. This will cause the checksum of the
file to change, as you have observed, and is perfectly normal behaviour.

--
Kind regards,
Chow Loong Jin

Artem Yakimenko (temik) wrote :
Download full text (6.3 KiB)

Sorry, I haven't thought about that, I should've uploaded the file first.
But the fact that the audio gets corrupted is not normal, however.
I'll try to recreate the bug without writing the metadata tomorrow.

Regards,
Artem Yakimenko

On Sat, Jul 31, 2010 at 11:57 PM, Chow Loong Jin <email address hidden>wrote:

> On Sunday 01,August,2010 03:41 AM, Artem Yakimenko wrote:
> > No, "write metadata" is still cheked. Is it not supposed to be checked?
>
> When it is checked, the lyrics extension will automatically write the
> lyrics to
> the metadata of the mp3 file as an IDv3 tag. This will cause the checksum
> of the
> file to change, as you have observed, and is perfectly normal behaviour.
>
> --
> Kind regards,
> Chow Loong Jin
>
> --
> Banshee corrupts certain music files
> https://bugs.launchpad.net/bugs/586174
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Banshee Music Player: New
> Status in “banshee” package in Ubuntu: Confirmed
> Status in “banshee-community-extensions” package in Ubuntu: Fix Released
> Status in “banshee” source package in Lucid: New
> Status in “banshee-community-extensions” source package in Lucid: Fix
> Released
>
> Bug description:
> Binary package hint: banshee
>
> I purchased the album Lungs by Florence + the Machine from AmazonMP3. The
> first time I downloaded it, I tried pyMazon. It worked well, but as I
> started listening to the album in Banshee, I noticed some noise distortion
> after I listened to a song or two (sort of like squeeks, listen to attached
> mp3). I quit Banshee and tried to listen to some of the songs in Totem.
> The ones that had squeeked in Banshee, also squeeked in Totem, but others
> that I hadn't played using Banshee worked fine. I thought maybe a file or
> two had been corrupted during download, so I re-opened Banshee and started
> playing the rest of the album. Low and behold, some of the songs that had
> just played fine in Totem now had squeeks in Banshee. When I quit Banshee
> and opened the same song in Totem, it now had the squeeks there also.
>
> Now I started thinking maybe I had *somehow* missed the squeeks the first
> time listening in Totem and that the entire album had been corrupted somehow
> during download with pyMazon. Unfortunately, I hadn't had a chance to make
> a back-up of the files and now they ALL had squeeks in them. Forunately, I
> got the AmazonMP3 store to re-open the download for me. I deleted the
> original (now corrupted) album. This time I downloaded using the actual
> AmazonMP3 installer (for Windows) via Wine (since I can't get AmazonMP3's
> native downloader to work with Lucid).
>
> After re-downloading the album, I made a back-up of the files right away.
> I started by opening a bunch of the songs individually in Totem and
> Rhythmbox. They had no squeeks, so I chalked up my problem to a corrupted
> download from pyMazon. However, today I wanted to listen to the album
> again, so again I opened Banshee. The first song played fine. The second
> song (one which I'm confident I had checked in Rhythmbox and Totem just a
> few days ago) started squeeking. I quit Banshee and opened up the...

Read more...

Artem Yakimenko (temik) wrote :

Can't yet replicate the bug, using "write metadata to files" both checked and unchecked.
But, I noticed there is a slight hiccup in playback when banshee writes the lyrics metadata after downloading them.
The audio got corrupted in the same exact place the last time, I don't know if this is helpful to you or not though.

For now I'll try to replicate the bug. As soon as that happens, I'll upload the files here.
Thanks for the quick answer.

Changed in banshee (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in banshee:
importance: Unknown → High
tags: added: testcase
Changed in banshee (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.