Startup notification could register invalid applications

Bug #1560490 reported by Marco Trevisan (Treviño) on 2016-03-22
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
BAMF
Low
Marco Trevisan (Treviño)
bamf (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

If desktop-file is not provided when launching an app, we create a desktop-less app which can't be correctly handled.

Related branches

Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Low
status: New → In Progress
Changed in bamf:
milestone: none → 0.5.2
Changed in bamf (Ubuntu):
milestone: none → ubuntu-16.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.3~bzr0+16.04.20160322.1-0ubuntu1

---------------
bamf (0.5.3~bzr0+16.04.20160322.1-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * BamfMatcher: avoid to register apps with invalid (empty or not
    existing) destkop files (LP: #1560490)

  [ Rico Tzschichholz ]
  * BamfView: Fix ABI break caused by r625 (LP: #1560486)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 22 Mar 2016 15:35:03 +0000

Changed in bamf (Ubuntu):
status: In Progress → Fix Released
Changed in bamf:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers