Libreoffice .desktop files containing StartupWMClass strings (since 4.1) confuse BAMF in precise

Bug #1238122 reported by Marco Trevisan (Treviño) on 2013-10-10
84
This bug affects 20 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Marco Trevisan (Treviño)
0.2
Medium
Marco Trevisan (Treviño)

Bug Description

LO 4.1 adds to .desktop files the StartupWMClass string. While this is correct in general, the LO windows are very slow to update their flags and this leads to matching errors in Ubuntu 12.04.

We need to ignore such values then.

A woarkaround for people affected by this is just removing the class key from .desktop files by running:
  sudo sed '/StartupWMClass=.*/d' -i /usr/share/applications/libreoffice-*.desktop

Saucy is not affected by this bug, since it monitors the window class directly.

Related branches

summary: Libreoffice .desktop files containing StartupWMClass strings (since 4.1)
- confuse BAMF
+ confuse BAMF in precise
description: updated
Changed in bamf:
milestone: none → 0.2.128
description: updated
Changed in bamf:
status: In Progress → Fix Committed
Adam Niedling (krychek) wrote :

Marco: Your 'sed' workaround does not fix this problem entirely. After running it every calc and every writer document has only one icon on the launcher and when you hover your mouse over them it only says "LibreOffice Calc" or "LibreOffice Writer" instead of each document having its own icon and the mouse hovering would tell you the name of the document.

Argh, I just checked this on a 13.10 box and the behavior is the same., documents have no separate icons on the launcher. Since when is this the default behavior?

@Adam: I don't understand your complaint. What you are describing is
completely normal behaviour for all unity icons on the launcher (if I
understood correctly). Please try again to explain.

On Wed, Oct 23, 2013 at 8:42 PM, Adam Niedling
<email address hidden> wrote:
> Marco: Your 'sed' workaround does not fix this problem entirely. After
> running it every calc and every writer document has only one icon on the
> launcher and when you hover your mouse over them it only says
> "LibreOffice Calc" or "LibreOffice Writer" instead of each document
> having its own icon and the mouse hovering would tell you the name of
> the document.
>
> Argh, I just checked this on a 13.10 box and the behavior is the same.,
> documents have no separate icons on the launcher. Since when is this the
> default behavior?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1077518).
> https://bugs.launchpad.net/bugs/1238122
>
> Title:
> Libreoffice .desktop files containing StartupWMClass strings (since
> 4.1) confuse BAMF in precise
>
> Status in BAMF Application Matching Framework:
> Fix Committed
>
> Bug description:
> LO 4.1 adds to .desktop files the StartupWMClass string. While this is
> correct in general, the LO windows are very slow to update their flags
> and this leads to matching errors in Ubuntu 12.04.
>
> We need to ignore such values then.
>
> A woarkaround for people affected by this is just removing the class key from .desktop files by running:
> sudo sed '/StartupWMClass=.*/d' -i /usr/share/applications/libreoffice-*.desktop
>
> Saucy is not affected by this bug, since it monitors the window class
> directly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bamf/+bug/1238122/+subscriptions

--
Martin Wildam

http://martin.wildam.org/

Adam Niedling (krychek) wrote :

Martin: I was talking about group vs ungrouped icons of LibreOffice documents on the launcher. Is there a way to have them ungrouped?

apienk (andrzej-pienkowski) wrote :

The workaround is not working anymore in LO 4.2.1.1. Generic icon, no bamf grouping.

Ryan Tandy (rtandy) wrote :

Treviño, your patch (lp:bamf/0.2) fixes LibreOffice 4.1, but not 4.2. Not sure whether it's the same thing or something new.

Changed in bamf:
status: Fix Committed → Fix Released
milestone: 0.2.128 → none
Martin Wildam (mwildam) wrote :

Latest LibreOffice-Updates didn't have the issue any more in my case,
that I have to correct the strings after the update.

My system is an Ubuntu 12.04 (manually upgraded kernel to
3.8.0-44-generic #66~precise1-Ubuntu SMP Tue Jul 15 04:01:04 UTC 2014
x86_64 x86_64 x86_64 GNU/Linux).

So for my case I can confirm the fix.

On Wed, Apr 15, 2015 at 1:18 AM, Marco Trevisan (Treviño)
<mail@3v1n0.net> wrote:
> ** Changed in: bamf
> Status: Fix Committed => Fix Released
>
> ** Also affects: bamf/0.2
> Importance: Undecided
> Status: New
>
> ** Changed in: bamf/0.2
> Status: New => Fix Committed
>
> ** Changed in: bamf
> Milestone: 0.2.128 => None
>
> ** Changed in: bamf/0.2
> Importance: Undecided => Medium
>
> ** Changed in: bamf/0.2
> Assignee: (unassigned) => Marco Trevisan (Treviño) (3v1n0)
>
> ** Changed in: bamf/0.2
> Milestone: None => 0.2.128
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1238122
>
> Title:
> Libreoffice .desktop files containing StartupWMClass strings (since
> 4.1) confuse BAMF in precise
>
> Status in BAMF Application Matching Framework:
> Fix Released
> Status in BAMF 0.2 series:
> Fix Committed
>
> Bug description:
> LO 4.1 adds to .desktop files the StartupWMClass string. While this is
> correct in general, the LO windows are very slow to update their flags
> and this leads to matching errors in Ubuntu 12.04.
>
> We need to ignore such values then.
>
> A woarkaround for people affected by this is just removing the class key from .desktop files by running:
> sudo sed '/StartupWMClass=.*/d' -i /usr/share/applications/libreoffice-*.desktop
>
> Saucy is not affected by this bug, since it monitors the window class
> directly.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bamf/+bug/1238122/+subscriptions

--
Martin Wildam

http://martin.wildam.org/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers