busybox with (initramfs) / boot: / kernel not found

Bug #276822 reported by C.S.Cameron
110
This bug affects 13 people
Affects Status Importance Assigned to Milestone
usb-creator (Baltix)
New
Undecided
Unassigned
usb-creator (Ubuntu)
Fix Released
High
Evan

Bug Description

Binary package hint: usb-creator

Loaded onto thumbdrive running Xubuntu 8.04.1.
Tried installing from disks:
Xubuntu 8.04.1
Ubuntu 8.04.1
Ubuntu-EEE
seemed to go ok but ended up in busybox with (initramfs).
Installed Xubuntu 8.10 -6 from disk with no problem.
But get busybox with (initramfs) when trying to boot on old mother board using Boot CD.
Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great also

Revision history for this message
Matthew Nuzum (newz) wrote :

I have confirmed this. I get the same result every time when running usb-creator 0.1.7 on Intrepid to create a bootable Ubuntu 8.04.1 LTS usb stick. I've tried creating both with and without allocating reserved extra space.

The system starts too boot and then, within a few seconds, I'm stuck at an (initramfs) prompt. It appears to be a busy box prompt. I'm going to try creating an intrepid beta boot disk to see if the same problems happen.

Revision history for this message
Evan (ev) wrote :

Can you both please attach the /casper.log file at the initramfs prompt, following the instructions in https://wiki.ubuntu.com/DebuggingCasper

Thanks!

Changed in usb-creator:
assignee: nobody → evand
status: New → Incomplete
Revision history for this message
Matthew Nuzum (newz) wrote :

I will, but in the meantime I tested it with Intrepid Beta cdimage and it booted just fine, so it may be that this problem is limited to 8.04.1

Revision history for this message
Matthew Nuzum (newz) wrote :

OK, attached is the casper.log and dmesg.txt from a failed boot of the 8.04.1 ubuntu desktop image created with usb-creator 0.1.7 on a 4G usb memory stick. For completeness, here is the disk layout of the usb memory stick:

Disk /dev/sdb: 4063 MB, 4063232000 bytes
254 heads, 16 sectors/track, 1952 cylinders
Units = cylinders of 4064 * 512 = 2080768 bytes
Disk identifier: 0x0008e42c

   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1953 3967999+ c W95 FAT32 (LBA)

Revision history for this message
Matthew Nuzum (newz) wrote :
Matthew Nuzum (newz)
Changed in usb-creator:
status: Incomplete → New
Revision history for this message
C.S.Cameron (cscameron) wrote : Re: [Bug 276822] Re: busybox with (initramfs)

Will give install with 8.04.1 another shot today, with 8.10.1 Beta both
Ubuntu and Xubuntu are working fine.

On Mon, Oct 13, 2008 at 10:22 AM, Evan Dandrea <email address hidden> wrote:

> Can you both please attach the /casper.log file at the initramfs prompt,
> following the instructions in https://wiki.ubuntu.com/DebuggingCasper
>
> Thanks!
>
> ** Changed in: usb-creator (Ubuntu)
> Assignee: (unassigned) => Evan Dandrea (evand)
> Status: New => Incomplete
>
> --
> busybox with (initramfs)
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "usb-creator" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: usb-creator
>
> Loaded onto thumbdrive running Xubuntu 8.04.1.
> Tried installing from disks:
> Xubuntu 8.04.1
> Ubuntu 8.04.1
> Ubuntu-EEE
> seemed to go ok but ended up in busybox with (initramfs).
> Installed Xubuntu 8.10 -6 from disk with no problem.
> But get busybox with (initramfs) when trying to boot on old mother board
> using Boot CD.
> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
> also
>

Revision history for this message
C.S.Cameron (cscameron) wrote :

Booting from 8.10 Beta and using usb-creator to make 8.04.1 start up disk
again get BusyBox, (initramfs).
Scrolling was too fast to see much during debug, however the last line
before BusyBox was:

( 57.847326) EXT3-fs: Unrecognized mount option "mode=755" or missing
value.

I recall removing mode=755 from scripts/casper allows a flash drive created
using liveusb to boot in persistence mode.

On Mon, Oct 13, 2008 at 10:22 AM, Evan Dandrea <email address hidden> wrote:

> Can you both please attach the /casper.log file at the initramfs prompt,
> following the instructions in https://wiki.ubuntu.com/DebuggingCasper
>
> Thanks!
>
> ** Changed in: usb-creator (Ubuntu)
> Assignee: (unassigned) => Evan Dandrea (evand)
> Status: New => Incomplete
>
> --
> busybox with (initramfs)
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "usb-creator" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: usb-creator
>
> Loaded onto thumbdrive running Xubuntu 8.04.1.
> Tried installing from disks:
> Xubuntu 8.04.1
> Ubuntu 8.04.1
> Ubuntu-EEE
> seemed to go ok but ended up in busybox with (initramfs).
> Installed Xubuntu 8.10 -6 from disk with no problem.
> But get busybox with (initramfs) when trying to boot on old mother board
> using Boot CD.
> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
> also
>

Revision history for this message
AGarren (agarren+launchpad) wrote : Re: busybox with (initramfs)

I was following these instructions:

http://www.ubuntumini.com/2008/10/installing-ubuntu-on-dell-inspiron-mini.html

in order to throw 8.10 beta on a new Mini9. I pulled off a 8.10 beta iso earlier today and installed into a VM on another box. Using usb-creator 0.1.9 to throw the iso onto a 1gb thumb gave me a bootable stick. Unfortunately, about a third of the way through the installation I was getting dropped into busybox and unable to proceed. Interestingly, I repeated the procedure with UNetBootin and got the same result. Both applications were able to get me into a Hardy install on the Mini9 without issue. Following the second "manual liveUSB" option from this article:

http://www.pendrivelinux.com/2008/10/15/ubuntu-810-persistent-flash-drive-install-from-live-cd/

got me up and running on 8.10 (using the same iso as above) without issue. I'm just guessing but I suspect that the 8.10 livecd is doing something that doesn't behave when slapped on a thumbdrive having a capacity less than 2gb.

I'd be curious to know if those who had encountered the busybox issue were using smaller capacity thumbdrives.

Revision history for this message
Shane Par-Due (shanepardue) wrote :

I'm using a 2gb flash drive and having the same problem.

Revision history for this message
Cristóbal M. Palmer (cristobalpalmer) wrote :

I have the same problem. I'm using an Intrepid .iso from an installed intrepid system.

cmpalmer@kant:~$ dpkg -l usb-creator|grep ^ii
ii usb-creator 0.1.9 Ubuntu USB desktop image creator
cmpalmer@kant:~$ lsb_release -d
Description: Ubuntu intrepid (development branch)

Please see my attached dmesg and casper.log from the failed session.

Revision history for this message
Cristóbal M. Palmer (cristobalpalmer) wrote :
Revision history for this message
Evan (ev) wrote :

I believe this is fixed in the latest daily-live CDs. Can anyone that was seeing a busybox prompt, please try creating an image using one of the CDs found here:

http://cdimage.ubuntu.com/daily-live/

Thanks!

Changed in usb-creator:
importance: Undecided → High
status: New → Incomplete
Revision history for this message
C.S.Cameron (cscameron) wrote : Re: [Bug 276822] Re: busybox with (initramfs)

Downloading now, will test when complete.

On Mon, Oct 20, 2008 at 11:20 PM, Evan Dandrea <email address hidden> wrote:

> I believe this is fixed in the latest daily-live CDs. Can anyone that
> was seeing a busybox prompt, please try creating an image using one of
> the CDs found here:
>
> http://cdimage.ubuntu.com/daily-live/
>
> Thanks!
>
> ** Changed in: usb-creator (Ubuntu)
> Importance: Undecided => High
> Status: New => Incomplete
>
> --
> busybox with (initramfs)
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "usb-creator" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: usb-creator
>
> Loaded onto thumbdrive running Xubuntu 8.04.1.
> Tried installing from disks:
> Xubuntu 8.04.1
> Ubuntu 8.04.1
> Ubuntu-EEE
> seemed to go ok but ended up in busybox with (initramfs).
> Installed Xubuntu 8.10 -6 from disk with no problem.
> But get busybox with (initramfs) when trying to boot on old mother board
> using Boot CD.
> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
> also
>

Revision history for this message
John Fink (john-fink) wrote : Re: busybox with (initramfs)

The latest Live CD image works for me with no dropping into busybox. Hooray!

Revision history for this message
C.S.Cameron (cscameron) wrote : Re: [Bug 276822] Re: busybox with (initramfs)

Works for me, usb-creator is looking good.

On Mon, Oct 20, 2008 at 11:20 PM, Evan Dandrea <email address hidden> wrote:

> I believe this is fixed in the latest daily-live CDs. Can anyone that
> was seeing a busybox prompt, please try creating an image using one of
> the CDs found here:
>
> http://cdimage.ubuntu.com/daily-live/
>
> Thanks!
>
> ** Changed in: usb-creator (Ubuntu)
> Importance: Undecided => High
> Status: New => Incomplete
>
> --
> busybox with (initramfs)
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "usb-creator" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: usb-creator
>
> Loaded onto thumbdrive running Xubuntu 8.04.1.
> Tried installing from disks:
> Xubuntu 8.04.1
> Ubuntu 8.04.1
> Ubuntu-EEE
> seemed to go ok but ended up in busybox with (initramfs).
> Installed Xubuntu 8.10 -6 from disk with no problem.
> But get busybox with (initramfs) when trying to boot on old mother board
> using Boot CD.
> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
> also
>

Revision history for this message
Elias K Gardner (zorkerz) wrote :

agreed a newer intrepid iso worked fine. I was misreading this bugreport
discussion.

Revision history for this message
C.S.Cameron (cscameron) wrote :

Well I installed several times yesterday to a 2G flash with success using
U-C.
Tried a dozen time to install to a 4G flash but only got error 17, have
tried everything.

On Mon, Oct 20, 2008 at 11:20 PM, Evan Dandrea <email address hidden> wrote:

> I believe this is fixed in the latest daily-live CDs. Can anyone that
> was seeing a busybox prompt, please try creating an image using one of
> the CDs found here:
>
> http://cdimage.ubuntu.com/daily-live/
>
> Thanks!
>
> ** Changed in: usb-creator (Ubuntu)
> Importance: Undecided => High
> Status: New => Incomplete
>
> --
> busybox with (initramfs)
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "usb-creator" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: usb-creator
>
> Loaded onto thumbdrive running Xubuntu 8.04.1.
> Tried installing from disks:
> Xubuntu 8.04.1
> Ubuntu 8.04.1
> Ubuntu-EEE
> seemed to go ok but ended up in busybox with (initramfs).
> Installed Xubuntu 8.10 -6 from disk with no problem.
> But get busybox with (initramfs) when trying to boot on old mother board
> using Boot CD.
> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
> also
>

Revision history for this message
Fernando Miguel (fernandomiguel) wrote : Re: busybox with (initramfs)

Using todays daily / RC I get thrown to initramfs with both i386 and 64bit isos, on a kingston 4GiBs pen drive, on my laptop.

On another PC with i386 I get the "Missing Operating System" of bug #277903.

$ apt-cache show usb-creator
Package: usb-creator
Installed-Size: 192
Architecture: all
Version: 0.1.9

I'll reboot later and see if I can get the casper.log (any ideas on how to save if?)

Revision history for this message
Michael Kozma (myckeul) wrote :

Hi !

I have the same problem today with usb-creator on Intrepid RC.

I use ubuntu 8.04.1 - desktop and xubuntu 8.04 - desktop cd's

My usb key is a Kingston 4GB drive.

Revision history for this message
C.S.Cameron (cscameron) wrote :

Yes, my problem is also with a Kingston 4G (purple) also.
Have tried installing from the RC Live CD onto 2 different Kingston 4G, from 2 different computers today.
Still getting Error 17.

Revision history for this message
fjgold (fjgoldster) wrote :

I have tried usb creator using a 2 GB Titanium and a 4 GB Titanium with both Hardy and Intrepid.
I've used both the liveCD created from the .iso's and the .iso's themselves. Get the initiramfs error every time. If I use usb creator installed on hardy I get an OS not found error.
Is there any fix in sight? I will try again when Intrepid goes final but I think (IMHO) the problem is with the usb creator program.

thanks

Revision history for this message
Achim (ach1m) wrote :

I have used an old version of usb-creator (v1.5) that I had installed in Hardy and I was able to create an bootable usb stick.
I used the ubuntu-8.10-rc-desktop-i386.iso.

I had no luck with the usb-creator (1.8) in intrepid.

Regards
Achim

Evan (ev)
Changed in usb-creator:
status: Incomplete → Fix Released
Revision history for this message
C.S.Cameron (cscameron) wrote : Re: [Bug 276822] Re: busybox with (initramfs)

With today's install of U-C I am only getting "grub_" with my Kingston 4G.
It is still installing ok to my 2G Kingston, Persistence seems to be working
fine except for hardware drivers.

On Mon, Oct 27, 2008 at 3:24 AM, Evan Dandrea <email address hidden> wrote:

> ** Changed in: usb-creator (Ubuntu)
> Status: Incomplete => Fix Released
>
> --
> busybox with (initramfs)
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "usb-creator" source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: usb-creator
>
> Loaded onto thumbdrive running Xubuntu 8.04.1.
> Tried installing from disks:
> Xubuntu 8.04.1
> Ubuntu 8.04.1
> Ubuntu-EEE
> seemed to go ok but ended up in busybox with (initramfs).
> Installed Xubuntu 8.10 -6 from disk with no problem.
> But get busybox with (initramfs) when trying to boot on old mother board
> using Boot CD.
> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
> also
>

Revision history for this message
fjgold (fjgoldster) wrote : Re: busybox with (initramfs)

Just got finished testing usb-creator 0.1.5 thru 0.1.9 in intrepid 64 bit RC. Successfully created bootable
live USB drives with Dapper, Hardy 64 and Intrepid 64. Used raw .iso's in all tests. Drive used was a Sandisk 4 GB Titanium. Usb-creator versions 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed using .deb's. Have kept the 0.1.8 version installed. The only trouble is Intrepid keeps trying to update to the latest version.

In all cases persistence doesn't work.

Revision history for this message
C.S.Cameron (cscameron) wrote : Re: [Bug 276822] Re: busybox with (initramfs)

A comment on upgrading Intrepid to the latest version, casper-rw seems to
get filled up if this is done often, and then I get ownership errors trying
to install any more applications.

On Mon, Oct 27, 2008 at 4:35 PM, fjgold <email address hidden> wrote:

> Just got finished testing usb-creator 0.1.5 thru 0.1.9 in intrepid 64 bit
> RC. Successfully created bootable
> live USB drives with Dapper, Hardy 64 and Intrepid 64. Used raw .iso's in
> all tests. Drive used was a Sandisk 4 GB Titanium. Usb-creator versions
> 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed
> using .deb's. Have kept the 0.1.8 version installed. The only trouble is
> Intrepid keeps trying to update to the latest version.
>
> In all cases persistence doesn't work.
>
> --
> busybox with (initramfs)
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "usb-creator" source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: usb-creator
>
> Loaded onto thumbdrive running Xubuntu 8.04.1.
> Tried installing from disks:
> Xubuntu 8.04.1
> Ubuntu 8.04.1
> Ubuntu-EEE
> seemed to go ok but ended up in busybox with (initramfs).
> Installed Xubuntu 8.10 -6 from disk with no problem.
> But get busybox with (initramfs) when trying to boot on old mother board
> using Boot CD.
> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
> also
>

Revision history for this message
C.S.Cameron (cscameron) wrote :

Trying to install Xubuntu 8.0.1 to 2G Kingston ends up at (initramfs)_.

On Mon, Oct 27, 2008 at 4:56 PM, Courtley Cameron <email address hidden>wrote:

> A comment on upgrading Intrepid to the latest version, casper-rw seems to
> get filled up if this is done often, and then I get ownership errors trying
> to install any more applications.
>
>
> On Mon, Oct 27, 2008 at 4:35 PM, fjgold <email address hidden> wrote:
>
>> Just got finished testing usb-creator 0.1.5 thru 0.1.9 in intrepid 64 bit
>> RC. Successfully created bootable
>> live USB drives with Dapper, Hardy 64 and Intrepid 64. Used raw .iso's in
>> all tests. Drive used was a Sandisk 4 GB Titanium. Usb-creator versions
>> 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed
>> using .deb's. Have kept the 0.1.8 version installed. The only trouble is
>> Intrepid keeps trying to update to the latest version.
>>
>> In all cases persistence doesn't work.
>>
>> --
>> busybox with (initramfs)
>> https://bugs.launchpad.net/bugs/276822
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in "usb-creator" source package in Ubuntu: Fix Released
>>
>> Bug description:
>> Binary package hint: usb-creator
>>
>> Loaded onto thumbdrive running Xubuntu 8.04.1.
>> Tried installing from disks:
>> Xubuntu 8.04.1
>> Ubuntu 8.04.1
>> Ubuntu-EEE
>> seemed to go ok but ended up in busybox with (initramfs).
>> Installed Xubuntu 8.10 -6 from disk with no problem.
>> But get busybox with (initramfs) when trying to boot on old mother board
>> using Boot CD.
>> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
>> also
>>
>
>

Revision history for this message
C.S.Cameron (cscameron) wrote :

sorry, Xubuntu 8.04.1

On Mon, Oct 27, 2008 at 5:45 PM, Courtley Cameron <email address hidden>wrote:

> Trying to install Xubuntu 8.0.1 to 2G Kingston ends up at (initramfs)_.
>
>
> On Mon, Oct 27, 2008 at 4:56 PM, Courtley Cameron <email address hidden>wrote:
>
>> A comment on upgrading Intrepid to the latest version, casper-rw seems to
>> get filled up if this is done often, and then I get ownership errors trying
>> to install any more applications.
>>
>>
>> On Mon, Oct 27, 2008 at 4:35 PM, fjgold <email address hidden> wrote:
>>
>>> Just got finished testing usb-creator 0.1.5 thru 0.1.9 in intrepid 64 bit
>>> RC. Successfully created bootable
>>> live USB drives with Dapper, Hardy 64 and Intrepid 64. Used raw .iso's in
>>> all tests. Drive used was a Sandisk 4 GB Titanium. Usb-creator versions
>>> 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed
>>> using .deb's. Have kept the 0.1.8 version installed. The only trouble is
>>> Intrepid keeps trying to update to the latest version.
>>>
>>> In all cases persistence doesn't work.
>>>
>>> --
>>> busybox with (initramfs)
>>> https://bugs.launchpad.net/bugs/276822
>>> You received this bug notification because you are a direct subscriber
>>> of the bug.
>>>
>>> Status in "usb-creator" source package in Ubuntu: Fix Released
>>>
>>> Bug description:
>>> Binary package hint: usb-creator
>>>
>>> Loaded onto thumbdrive running Xubuntu 8.04.1.
>>> Tried installing from disks:
>>> Xubuntu 8.04.1
>>> Ubuntu 8.04.1
>>> Ubuntu-EEE
>>> seemed to go ok but ended up in busybox with (initramfs).
>>> Installed Xubuntu 8.10 -6 from disk with no problem.
>>> But get busybox with (initramfs) when trying to boot on old mother board
>>> using Boot CD.
>>> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
>>> also
>>>
>>
>>
>

Revision history for this message
fjgold (fjgoldster) wrote : Re: busybox with (initramfs)

Observations. Live USB Ubuntus boot fast, real fast. Install to a HD from a live USB is real quick also. About a 25% of the time of the install from the live CD at least on my machine.
If I were to install Ubuntu on another persons machine I would use a live USB drive.
USB creator will be a great tool once the bugs are worked out.

Revision history for this message
C.S.Cameron (cscameron) wrote : Re: [Bug 276822] Re: busybox with (initramfs)

Installed today using usb-creator on 2G Kingston, works with persistence.
Install to 4G Kingston gives "grub_"
Cloning 2G to 4G using "sudo dd if=/dev/sdc of=/dev/sdd" makes 4G Kingston
bootable and persistent.

On Mon, Oct 27, 2008 at 5:45 PM, Courtley Cameron <email address hidden>wrote:

> Trying to install Xubuntu 8.0.1 to 2G Kingston ends up at (initramfs)_.
>
>
> On Mon, Oct 27, 2008 at 4:56 PM, Courtley Cameron <email address hidden>wrote:
>
>> A comment on upgrading Intrepid to the latest version, casper-rw seems to
>> get filled up if this is done often, and then I get ownership errors trying
>> to install any more applications.
>>
>>
>> On Mon, Oct 27, 2008 at 4:35 PM, fjgold <email address hidden> wrote:
>>
>>> Just got finished testing usb-creator 0.1.5 thru 0.1.9 in intrepid 64 bit
>>> RC. Successfully created bootable
>>> live USB drives with Dapper, Hardy 64 and Intrepid 64. Used raw .iso's in
>>> all tests. Drive used was a Sandisk 4 GB Titanium. Usb-creator versions
>>> 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed
>>> using .deb's. Have kept the 0.1.8 version installed. The only trouble is
>>> Intrepid keeps trying to update to the latest version.
>>>
>>> In all cases persistence doesn't work.
>>>
>>> --
>>> busybox with (initramfs)
>>> https://bugs.launchpad.net/bugs/276822
>>> You received this bug notification because you are a direct subscriber
>>> of the bug.
>>>
>>> Status in "usb-creator" source package in Ubuntu: Fix Released
>>>
>>> Bug description:
>>> Binary package hint: usb-creator
>>>
>>> Loaded onto thumbdrive running Xubuntu 8.04.1.
>>> Tried installing from disks:
>>> Xubuntu 8.04.1
>>> Ubuntu 8.04.1
>>> Ubuntu-EEE
>>> seemed to go ok but ended up in busybox with (initramfs).
>>> Installed Xubuntu 8.10 -6 from disk with no problem.
>>> But get busybox with (initramfs) when trying to boot on old mother board
>>> using Boot CD.
>>> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
>>> also
>>>
>>
>>
>

Revision history for this message
rick tuesta hualinga (freddierith) wrote : Re: busybox with (initramfs)

Also I have the error busybox I have not been able to solve any of the following form
all_generic_ide acpi = off

Revision history for this message
C.S.Cameron (cscameron) wrote : Re: [Bug 276822] Re: busybox with (initramfs)

Having some space left over from the 2G to 4G clone, I made two ext3
partitions and labeled one as casper-rw and the other as home-rw.
I had to use gparted Live CD as partitioner in Ubuntu gave errors trying to
label a partition as casper-rw.
I deleted the casper file from the U-C installation.
Everything seems to working ok now.

On Tue, Oct 28, 2008 at 10:58 AM, Courtley Cameron <email address hidden>wrote:

> Installed today using usb-creator on 2G Kingston, works with persistence.
> Install to 4G Kingston gives "grub_"
> Cloning 2G to 4G using "sudo dd if=/dev/sdc of=/dev/sdd" makes 4G Kingston
> bootable and persistent.
>
>
> On Mon, Oct 27, 2008 at 5:45 PM, Courtley Cameron <email address hidden>wrote:
>
>> Trying to install Xubuntu 8.0.1 to 2G Kingston ends up at (initramfs)_.
>>
>>
>> On Mon, Oct 27, 2008 at 4:56 PM, Courtley Cameron <email address hidden>wrote:
>>
>>> A comment on upgrading Intrepid to the latest version, casper-rw seems to
>>> get filled up if this is done often, and then I get ownership errors trying
>>> to install any more applications.
>>>
>>>
>>> On Mon, Oct 27, 2008 at 4:35 PM, fjgold <email address hidden> wrote:
>>>
>>>> Just got finished testing usb-creator 0.1.5 thru 0.1.9 in intrepid 64
>>>> bit RC. Successfully created bootable
>>>> live USB drives with Dapper, Hardy 64 and Intrepid 64. Used raw .iso's
>>>> in all tests. Drive used was a Sandisk 4 GB Titanium. Usb-creator versions
>>>> 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed
>>>> using .deb's. Have kept the 0.1.8 version installed. The only trouble is
>>>> Intrepid keeps trying to update to the latest version.
>>>>
>>>> In all cases persistence doesn't work.
>>>>
>>>> --
>>>> busybox with (initramfs)
>>>> https://bugs.launchpad.net/bugs/276822
>>>> You received this bug notification because you are a direct subscriber
>>>> of the bug.
>>>>
>>>> Status in "usb-creator" source package in Ubuntu: Fix Released
>>>>
>>>> Bug description:
>>>> Binary package hint: usb-creator
>>>>
>>>> Loaded onto thumbdrive running Xubuntu 8.04.1.
>>>> Tried installing from disks:
>>>> Xubuntu 8.04.1
>>>> Ubuntu 8.04.1
>>>> Ubuntu-EEE
>>>> seemed to go ok but ended up in busybox with (initramfs).
>>>> Installed Xubuntu 8.10 -6 from disk with no problem.
>>>> But get busybox with (initramfs) when trying to boot on old mother board
>>>> using Boot CD.
>>>> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked great
>>>> also
>>>>
>>>
>>>
>>
>

Revision history for this message
C.S.Cameron (cscameron) wrote :

Sorry I meant to say "I deleted the casper-rw file from the U-C
installation."

On Wed, Oct 29, 2008 at 11:30 AM, Courtley Cameron <email address hidden>wrote:

> Having some space left over from the 2G to 4G clone, I made two ext3
> partitions and labeled one as casper-rw and the other as home-rw.
> I had to use gparted Live CD as partitioner in Ubuntu gave errors trying to
> label a partition as casper-rw.
> I deleted the casper file from the U-C installation.
> Everything seems to working ok now.
>
>
> On Tue, Oct 28, 2008 at 10:58 AM, Courtley Cameron <email address hidden>wrote:
>
>> Installed today using usb-creator on 2G Kingston, works with persistence.
>> Install to 4G Kingston gives "grub_"
>> Cloning 2G to 4G using "sudo dd if=/dev/sdc of=/dev/sdd" makes 4G Kingston
>> bootable and persistent.
>>
>>
>> On Mon, Oct 27, 2008 at 5:45 PM, Courtley Cameron <email address hidden>wrote:
>>
>>> Trying to install Xubuntu 8.0.1 to 2G Kingston ends up at (initramfs)_.
>>>
>>>
>>> On Mon, Oct 27, 2008 at 4:56 PM, Courtley Cameron <email address hidden>wrote:
>>>
>>>> A comment on upgrading Intrepid to the latest version, casper-rw seems
>>>> to get filled up if this is done often, and then I get ownership errors
>>>> trying to install any more applications.
>>>>
>>>>
>>>> On Mon, Oct 27, 2008 at 4:35 PM, fjgold <email address hidden> wrote:
>>>>
>>>>> Just got finished testing usb-creator 0.1.5 thru 0.1.9 in intrepid 64
>>>>> bit RC. Successfully created bootable
>>>>> live USB drives with Dapper, Hardy 64 and Intrepid 64. Used raw .iso's
>>>>> in all tests. Drive used was a Sandisk 4 GB Titanium. Usb-creator versions
>>>>> 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed
>>>>> using .deb's. Have kept the 0.1.8 version installed. The only trouble is
>>>>> Intrepid keeps trying to update to the latest version.
>>>>>
>>>>> In all cases persistence doesn't work.
>>>>>
>>>>> --
>>>>> busybox with (initramfs)
>>>>> https://bugs.launchpad.net/bugs/276822
>>>>> You received this bug notification because you are a direct subscriber
>>>>> of the bug.
>>>>>
>>>>> Status in "usb-creator" source package in Ubuntu: Fix Released
>>>>>
>>>>> Bug description:
>>>>> Binary package hint: usb-creator
>>>>>
>>>>> Loaded onto thumbdrive running Xubuntu 8.04.1.
>>>>> Tried installing from disks:
>>>>> Xubuntu 8.04.1
>>>>> Ubuntu 8.04.1
>>>>> Ubuntu-EEE
>>>>> seemed to go ok but ended up in busybox with (initramfs).
>>>>> Installed Xubuntu 8.10 -6 from disk with no problem.
>>>>> But get busybox with (initramfs) when trying to boot on old mother
>>>>> board using Boot CD.
>>>>> Tried installing Xubuntu 8.10 -6 from .iso on desktop, this worked
>>>>> great also
>>>>>
>>>>
>>>>
>>>
>>
>

Revision history for this message
Michael Kozma (myckeul) wrote : Re: busybox with (initramfs)

Hi !

For complementary information, my casper.log contain these lines :

mount: Mounting /dev/loop1 on /cow failed: Invalid argument
Can not mount /dev/loop1 on /cow

Revision history for this message
Philip Aston (philipa) wrote :

So this is fixed in 8.10, right? I have similar problems with both 1G and 2G USB drives. I tried this with yesterdays daily live CD - no improvement.

Revision history for this message
mac.ryan (macryan) wrote :

The bug is not fixed. The USB startup disk creator from 8.10 version works fine with some of the ISO's but not all. In particular, it fails (busybox state) with the 8.04.1, which is quite a bad thing, given that that should be the most recent LTS version of ubuntu...

Changed in usb-creator:
status: Fix Released → Confirmed
Revision history for this message
mac.ryan (macryan) wrote :

(to be more specific: the desktop 64 bit standard installation version)

Revision history for this message
Bryan Quigley (bryanquigley) wrote :

Bug (duplicate of this): https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/290154
has lot's more useful information.

I just added 4 bugs that appear to be duplicates of this bug, apologies if I got anything wrong, and thanks to all the bug reporters for reporting them.

Revision history for this message
Scott Lewin (sclewin) wrote :

Yea, my bug is a duplicate of this one for sure. So, I can confirm it with Ubuntu 8.04.1 and Kubuntu 8.04.1 Desktop iso. From some help on the mailing list I was able to find out that some things where missing from the USB and that is why it was dropping out to the Busybox shell.

I was using a new 8 GB Thumb drive.

Revision history for this message
jonas bergel (jonas-bergel) wrote :

Hi all,

It works with: xubuntu-8.10-desktop-i386.iso (Date 20. November. 2008)
I have used: "create a usb startup disk" (usb-creator 0.1.10)

I got someting like "i/o error... replace disk!" I think it is because I have executed "create a usb startup disk" as normal user. Following commands have solved it:
#new MBR :
sudo lilo -M /dev/sdb
#install bootloader:
sudo syslinux -f /dev/sdb1

Works well on my IBM X41! My first semi-live (stores automatic etc and home!) system on an usb stick. Very useful for me!
Bye, Jonas.

Revision history for this message
Evan (ev) wrote :

Using an 8.04.1 CD will not work because persistence is broken in the version of casper included in 8.04.1. This will be fixed in 8.04.2.

Revision history for this message
Sébastien Bertrand (damocles) wrote :

I confirm what said Evan Dandrea, I tested usb-creator with Ubuntu Eee 8.04.1 :
* It didn't worked with persistent mode enabled ;
* It worked without persistent mode disabled.

Revision history for this message
jpka (jopka) wrote :

[quote author=fjgold] "Usb-creator versions 0.1.9 and 0.1.10 failed with the Busybox error. All versions were installed using .deb's. Have kept the 0.1.8 version installed." [/quote]

For me, 0.1.8 not work, with same '(initramfs)_' error as latest 0.1.10 creator, using ubuntu-eee-8.04.1.iso and standard 8.10 iso.
In 0.1.10, normally works xubuntu-8.10-desktop-i386.iso.
I don't know what is 'persistence' in this thread. I have Ubuntu 8.10 and 8.04.1. Please suggest any working way to workaround for '(initramfs)_' error and get working official usb installation. Thanks.

Revision history for this message
Richard Theil (richard-theil) wrote :

I think my observations would fit the head description of bug 290154 (duplicate of this) somewhat better. Latest intrepid, generated a 4 GB thumbdrive with the daily jaunty image. Tried both "Create a USB startup disk" and "UNetbootin" to get the image to the stick:

- A Gigabyte GA-P35-DS4 board will fail on boot with the "kernel not found" message, while an
- IBM T41 did boot from the stick.

Looks like a syslinux/BIOS conflict that has to be sorted out. Boot device on the Gigabyte board was given as "USB-HDD", it does not find the stick at all and goes straight to HD with the other options.

Revision history for this message
jpka (jopka) wrote :

I also found that:
- different usb drives can show different problems; some is bootable and some (old?) isn't.
- some (old?) motherboards (Asus P4PE for ex.) can not boot from usb drive, if filesystem is not FAT16.
usb-creator not give me option to select a filesystem when it formats clean usb drive.
But latest boards and drives normally boots on default settings, using xubuntu iso. I only select boot device *after* bios tests, not *in* BIOS (to select boot device, use 'esc' on eeepc, 'F8' on asus m/b, etc.).

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

Wasn't it supposed to be added to Hardy 8.04.2 disk? It's not. I tried this Hardy version and Intrepid, and the latter works ok.

Revision history for this message
wirechief (wirechief) wrote :

My logs and problem discription in more detail on bug 293083 but basically i am dropped to a intramfs . I made
logs of my attempt. I am using usb-creator 0.1.15

Revision history for this message
wirechief (wirechief) wrote :
Revision history for this message
wirechief (wirechief) wrote :

in my attempts I tried using unetbooten-linux-319 and it fails the same way i am dropped into a intramfs shell.
i have tried this on 8gb, 4gb and 1gb, I have tried using windows version of unetbooten and got the same results.
ii syslinux 2:3.63+dfsg-2ubuntu3
ii usb-creator 0.1.15
Linux wirechief-laptop 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:39:23 UTC 2009 x86_64 GNU/Linux
     Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1878 984063+ c W95 FAT32 (LBA)

The one usb stick continues to be successfull and boots to the desktop, it is the same brand pny attache as the others
that were tested.

Revision history for this message
wirechief (wirechief) wrote :

in my recent attempt i tried using unetbootin_304_1_amd64.deb
ii unetbootin 304-1
using daily ubuntu build with unetbootin it downloaded and installed to a 1gb stick, the result with reboot
was being dropped into a intramfs shell. I burned a dvd r/w with the build and it worked fine booting up
to a live Desktop. i used netbooten on the live to a 8gb stick, it resulted in the same intramfs shell something in the script or config file causing this to fail. i am including the casper.log and demesg
   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1638 7823327+ c W95 FAT32 (LBA)

Revision history for this message
wirechief (wirechief) wrote :
Revision history for this message
wirechief (wirechief) wrote :

I took the one usb stick that successully booted to a Desktop and cloned it to another 8gb usb stick using
dd the result is that i have two usb sticks that can boot jaunty 9.04 so this should put to sleep any thought
i had a defective stick. using Linux ubuntu 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:00 UTC 2009 x86_64 GNU/Linux is the one that works, any iso's i have tried after that
did not work,
I am including the /var/log/dpkg.log for this stick....

Revision history for this message
Chip Piller (piller) wrote :

I've been having problems in the last week or two with jaunty daily-live desktop iso images which I used with usb-creator to make a liveusb stick where it will drop into busybox initramfs when I try to boot the usbstick. I found that when I try to boot I need to press F6 key, go to expert mode, remove "persistent" from boot command line, and then it will boot OK.

Revision history for this message
wirechief (wirechief) wrote :

I tried the same thing, removal of the persistent =/file to /file , removal of "persistent" provides a workaround for it
to boot to the Desktop...good find Chip Piller I hope now this will provide enough details for a solution to the issue
and they can get persistence working again. my last test the persistence was working. seems something got changed
right after that.

Revision history for this message
RIco (rico-rootscore-deactivatedaccount) wrote :

i'm still getting the busybox prompt on jaunty rc!!!

Revision history for this message
wirechief (wirechief) wrote :

I found https://bugs.launchpad.net/bugs/290153 had similar problems with dropping to a busybox and the work around
was adding rootdelay=90 I tried this on a recently created usb stick and found success, it booted to the Desktop there
are other things that users tried but simply giveing a wait provided success.

Revision history for this message
wirechief (wirechief) wrote : Re: [Bug 276822] Re: busybox with (initramfs) / boot: / kernel not found

try adding rootdelay=90 to the grub boot line.
I just tried it and had successfull boot to the desktop, you might be
able to use a lower value if that
works, i found this in bug 290153 which has similar problems of
dropping to a busybox.

On Thu, Apr 16, 2009 at 4:38 PM, RIco <email address hidden> wrote:
> i'm still getting the busybox prompt on jaunty rc!!!
>
> --
> busybox with (initramfs) / boot: / kernel not found
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Reach out and share life, care for others,

Revision history for this message
Forest (foresto) wrote :

I appreciate that we have a semi-successful workaround with rootdelay, but does anyone really find adding one or more minutes to your boot time an acceptable solution?

In my case, the device in question is a 3ware hardware RAID. This didn't happen with older kernels / ubuntu releases, which leads me to believe that a solution must exist that doesn't involve artificial delays.

Revision history for this message
wirechief (wirechief) wrote :

I didn't have to add rootdelay when i made my first stick, it was
after a update around Apr 3rd that this
occurred. not having a workaround until a fix can be made is not good
either, if the person working to fix
this knows the area to look perhaps a fix will come sooner.

On Thu, Apr 16, 2009 at 6:49 PM, Forest <email address hidden> wrote:
> I appreciate that we have a semi-successful workaround with rootdelay,
> but does anyone really find adding one or more minutes to your boot time
> an acceptable solution?
>
> In my case, the device in question is a 3ware hardware RAID.  This
> didn't happen with older kernels / ubuntu releases, which leads me to
> believe that a solution must exist that doesn't involve artificial
> delays.
>
> --
> busybox with (initramfs) / boot: / kernel not found
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Reach out and share life, care for others,

Revision history for this message
Osama Khalid (osamak) wrote :

Same problem with Ubuntu 9.04 RC and my LiveUSB-8GB stick.

Revision history for this message
Tom Jaster (futur3-tom) wrote :

Where do i have to add this rootdelay?, didnt found grub on the usb file system (please dont tell me its in the image file... -.-)

Revision history for this message
wirechief (wirechief) wrote :

after you hit enter for English select F6 (then other options if required) but i just hit esc and then
you are brought to the grub boot line and use the arrow keys to navigate.
I had to use the fix of removal of the persistent =/file to /file , removal of "persistent" this time as rootdelay=90 didn't work, this was with the jaunty 9.04 rc amd64 seems more work needs to be done yet with the use of a usb stick to boot into Ubuntu.

Revision history for this message
Tokenekie (tokenekie) wrote :

See progress on bug: https://bugs.launchpad.net/ubuntu/+source/casper/+bug/363038

Comment by user David Mandala shows a recent build of Jaunty seems to have solved the problem.

Currently trying to confirm the fix on my x86 PC.

Revision history for this message
Joe Baker (joebaker) wrote :

I'm having this problem with Jaunty RC - I get a prompt that says initramfs.
I thought it might be related to my hard drive partitions using encrypted LUKS over LVM, so I removed the hard drive but still had the same problem.

Once I hit enter a couple times at the initramfs prompt and got past the problem to a boot screen but that was with Ubuntu 9.04 beta.

This is really important to me. I want to distribute memory sticks equiped with pre-setup voip clients, vpns and encrypted email for friends.

I also need to get the exact list of packages to pin/hold which will not be upgradable on a memory stick environment - ie Kernel, libc6?

Thanks!

Revision history for this message
Joe Baker (joebaker) wrote :

I've attached a casper log.
I forgot to capture the output of dmesg, but I did run dmesg and visually inspected it. It seemed to report corruption in an ext3 filesystem. This could have been my /boot partition, but I think it unlikely. Again I did encrypt the entire root partition as an option of the alternate install of Ubuntu 8.04.

Thanks

Revision history for this message
Joe Baker (joebaker) wrote :

I've downloaded the daily snapshot dated 4/18/2008.
I processed it using the usb-creator application installed on an Ubuntu Jaunty i386 Desktop RC machine with all updates about 2 hours ago. It did not boot for me. This is a Verbatim memory stick 4 GB. I am erasing it with "Partition Editor"/gparted by formatting the partition. USB Creator always says the stick needs reformatting. Next I will try installing from CD this latest day's Image, and will then try writing the memory stick from there.

Gateway MT 6920 laptop

Loading, please wait...

BusyBox v1.10.2 (ubuntu 1:1.10.2-2ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands.

with the initramfs prompt

I typed 'exit' and it started processing again as shown by lights on the memory stick.
Then... this error:
run-init: overmounting root: Stale NFS file handle
[ 933.162720] Kernel panic - not syncing: Attempted to kill init!

Revision history for this message
wirechief (wirechief) wrote :

I downloaded the daily-build on Apri 20th 2009 it came with new files
associated with casper
lupin-casper ubiquity-casper and of course casper.
The stick created worked, I dont know if there are other files needed
but you might try sudo apt-get lupin-casper ubiquity-casper casper
and see if it works with those updates, it sure would be easier than
getting another daily build.

On Sun, Apr 19, 2009 at 10:05 PM, Joseph William Baker
<email address hidden> wrote:
> I've downloaded the daily snapshot dated 4/18/2008.
> I processed it using the usb-creator application installed on an Ubuntu Jaunty i386 Desktop RC machine with all updates about 2 hours ago.  It did not boot for me.  This is a Verbatim memory stick 4 GB.  I am erasing it with "Partition Editor"/gparted by formatting the partition.  USB Creator always says the stick needs reformatting.   Next I will try installing from CD this latest day's Image, and will then try writing the memory stick from there.
>
> Gateway MT 6920 laptop
>
> Loading, please wait...
>
> BusyBox v1.10.2 (ubuntu 1:1.10.2-2ubuntu7) built-in shell (ash)
> Enter 'help' for a list of built-in commands.
>
> with the initramfs prompt
>
> I typed 'exit'  and it started processing again as shown by lights on the memory stick.
> Then... this error:
> run-init: overmounting root: Stale NFS file handle
> [  933.162720] Kernel panic - not syncing:  Attempted to kill init!
>
> --
> busybox with (initramfs) / boot: / kernel not found
> https://bugs.launchpad.net/bugs/276822
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Reach out and share life, care for others,

Revision history for this message
C.S.Cameron (cscameron) wrote :

Daily-build of April 20th 2009 worked without incident for me also.

Revision history for this message
Joe Baker (joebaker) wrote :

Thanks Wirechief,

Your suggestion to install
lupin-casper, ubiquity-casper and casper
worked!

Revision history for this message
BobMcD (mcbobbo) wrote :

I just experienced this same error using a 64-bit version of 9.04.

I did not experience it on the 32-bit version.

Revision history for this message
Evan (ev) wrote :

This bug report has lost its focus entirely. I believe the original issue, that the casper-rw persistence file did not have a proper ext3 filesystem, has been indirectly fixed with other changes to the main install routine.

If you are seeing this error message in usb-creator 0.2.7, please file a new bug and attach /casper.log following the instructions in http://wiki.ubuntu.com/DebuggingCasper

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers