casper USB media fails to boot: USB storage device not detected, drops to (initramfs) prompt

Bug #363038 reported by ilovemistakes on 2009-04-17
56
This bug affects 4 people
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Critical
Unassigned
Jaunty
Critical
Unassigned
linux (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned

Bug Description

I have Acer Aspire 5920G laptop. I've tried to run installation of Jaunty from usb flash, but failed. I've downloaded ubuntu-9.04-rc-desktop-i386.iso using 8.10, started "Create a USB Startup Disk" program and created a fresh 9.04 boot usb flash disk. When I tried to boot my laptop from this flash disk, it immediately said "Missing operating system" to console. The I booted back to my 8.10, create a VM (with virtualbox) and booted it from iso (started a live session). Successfully. I started "USB bootdisk creator" from 9.04 live session, created bootable usb disk again and rebooted by laptop. GRUB showed me language selection. I selected russian and hit the "Try Ubuntu" menu entry. "Loading, please wait..." message flashed and usplash came up. Progress bar was running left-to-right and backwards, as it was expected. But after few seconds usplash had gone, and I saw a Busybox 1.10.2's prompt (without any error messages) ending with "(initramfs)". USB flash led stopped blinking at this time. Alt+{2,3,4,5,6,7} shows empty screens.

1) I used 9.04 RC desktop cd iso
3) I expected to boot fully working 9.04 RC from USB disk.
4) It dropped me to Busybox during boot.

I can reproduce it, so I can give any useful information if somebody tells me how i can gather it.

Related branches

Matt Zimmerman (mdz) on 2009-04-17
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
Pete Graner (pgraner) wrote :

Having the same problem on a Dell M1330 & Dell Latitude XT.

I booted in debug mode and got the casper.log and dmesg (attached).

Appears to not find /dev/sda, when I look at the system from the BusyBox prompt there is in fact a /dev/sda and /dev/sda1

affects: linux (Ubuntu) → casper (Ubuntu)
Changed in casper (Ubuntu):
importance: High → Critical
status: Triaged → Confirmed
Changed in linux (Ubuntu):
milestone: none → ubuntu-9.04
Pete Graner (pgraner) wrote :
Matt Zimmerman (mdz) on 2009-04-17
summary: - 9.04 RC does not boot from usb disk
+ casper USB media fails to boot: USB storage device not detected, drops
+ to (initramfs) prompt
Pete Graner (pgraner) wrote :
Matt Zimmerman (mdz) wrote :

<mdz> pgraner: do I understand correctly that:
 - when it drops to the (initramfs) prompt, there is only sda in /sys/block
 - you run udevadm trigger && udevadm settle, and there is still only sda
 - you plug in a second USB stick, and then you get sdb
 ?
<pgraner> mdz: yes, exactly

Furthermore, pgraner confirms that once he plugs in the second USB stick, *both* the original stick (the one booted from) and the second one (inserted later) are detected at the same time. So it seems that the USB stick isn't coldplugged correctly, but when a second one is hotplugged, that gets it going. usb-storage is not loaded until the second stick is inserted.

[ 103.828099] usb 1-2: new high speed USB device using ehci_hcd and address 5
[ 103.962559] usb 1-2: configuration #1 chosen from 1 choice
[ 103.970424] Initializing USB Mass Storage driver...
[ 103.973192] scsi2 : SCSI emulation for USB Mass Storage devices
[ 103.975094] usb-storage: device found at 2
[ 103.975149] usb-storage: waiting for device to settle before scanning
[ 103.976986] scsi3 : SCSI emulation for USB Mass Storage devices
[ 103.977597] usbcore: registered new interface driver usb-storage
[ 103.977654] USB Mass Storage support registered.
[ 103.977828] usb-storage: device found at 5
[ 103.977878] usb-storage: waiting for device to settle before scanning
[ 108.972248] usb-storage: device scan complete
[ 108.973520] scsi 2:0:0:0: Direct-Access LEXAR JD FIREFLY 1100 PQ: 0 ANSI: 0 CCS
[ 108.975411] sd 2:0:0:0: [sdb] 7928832 512-byte hardware sectors: (4.05 GB/3.78 GiB)
[ 108.976474] sd 2:0:0:0: [sdb] Write Protect is off
[ 108.976533] sd 2:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 108.976585] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 108.977441] usb-storage: device scan complete
[ 108.977994] scsi 3:0:0:0: Direct-Access SanDisk U3 Cruzer Micro 2.18 PQ: 0 ANSI: 2
[ 108.980234] sd 2:0:0:0: [sdb] 7928832 512-byte hardware sectors: (4.05 GB/3.78 GiB)
[ 108.981226] sd 2:0:0:0: [sdb] Write Protect is off
[ 108.981293] sd 2:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 108.981349] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[ 108.981405] sdb: sdb1
[ 108.982761] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[ 108.982909] sd 2:0:0:0: Attached scsi generic sg1 type 0
[ 108.986475] sd 3:0:0:0: [sdc] 2006673 512-byte hardware sectors: (1.02 GB/979 MiB)
[ 108.987084] sd 3:0:0:0: [sdc] Write Protect is off
[ 108.987140] sd 3:0:0:0: [sdc] Mode Sense: 03 00 00 00
[ 108.987193] sd 3:0:0:0: [sdc] Assuming drive cache: write through
[ 108.988841] sd 3:0:0:0: [sdc] 2006673 512-byte hardware sectors: (1.02 GB/979 MiB)
[ 108.989464] sd 3:0:0:0: [sdc] Write Protect is off
[ 108.989519] sd 3:0:0:0: [sdc] Mode Sense: 03 00 00 00
[ 108.989571] sd 3:0:0:0: [sdc] Assuming drive cache: write through
[ 108.989627] sdc: sdc1
[ 108.994009] sd 3:0:0:0: [sdc] Attached SCSI removable disk
[ 108.994155] sd 3:0:0:0: Attached scsi generic sg2 type 0

S.Spillan (junk-apexpraxis) wrote :

This also affects xubuntu-9.04-rc-desktop-i386.iso when using USB Creator to make a USB startup disk.

The USB disk fails after a few seconds at the usplash prompt and drops to the busybox prompt.

David Mandala (davidm) wrote :

Have confirmed this bug on both a IBM T60 and an eeePC 1000.

The T60 CPU's are Genuine Intel(R) CPU T2400 @ 1.83GHz and the eeePC 1000 is an ATOM N270 1.60GHz

I tested the Beta image and it boots fine on both machines from the same USB stick so I know the USB stick is working and that the Beta worked.

Robbie Williamson (robbiew) wrote :

Reverting revision 611 fixes it for me. With 611 I get errors about "head: not found". If I remove the "head -n1" from revision 611, I get the 'mount' error in the attached casper.log file.

Robbie Williamson (robbiew) wrote :

error starts at line 3928

Robbie Williamson (robbiew) wrote :

Attaching /proc/mounts, as it seems odd that /dev/sdb1 is mounted twice...over /cdrom and /casper-rw-backing

Robbie Williamson (robbiew) wrote :

Correctly applied revision 618 by slangasek, and problem resolved for me.

Steve Langasek (vorlon) wrote :

"revision 611" - this refers to a change in the casper bzr repo, which corrects a misuse of head (we don't have the 'head' command available in the initramfs). I've pushed a change that fixes this, but I haven't uploaded yet because it doesn't appear to be related to the problem in Pete's logs.

It is, however, the problem that Robbie was reproducing (the error in the preceding log is actually due to a mis-application of the fix), and may be the bug that the original submitter (and others) are actually hitting.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.173

---------------
casper (1.173) jaunty; urgency=low

  * Don't use head -n1 in where_is_mounted, we don't have head in the
    initramfs. LP: #363038.

 -- Steve Langasek <email address hidden> Fri, 17 Apr 2009 22:22:06 -0700

Changed in casper (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

I'm fairly certain that the bug Pete is seeing is not a casper bug, because it manifests so early in the boot process; I think we're looking at a kernel, udev, initramfs-tools, or hardware bug. Opening a task on 'linux' for that, for the moment.

Since TTBOMK no one else has reproduced that particular failure yet (upon retest, everyone else has said the casper fix resolves the problem for them), this appears to be a very hardware-specific issue. Marking 'medium' for now - if others are still seeing a problem using the next daily ISO build, then we should re-evaluate that, but the information we currently have suggests the remaining bug is not a release blocker.

Changed in linux (Ubuntu Jaunty):
importance: Undecided → Medium
Steve Langasek (vorlon) wrote :

The remaining system showing the USB problem is the Dell Latitude XT.

A google search does turn up references to others reporting that this hardware has problems with USB devices plugged in at boot time (presumably on Windows):
http://www.gottabemobile.com/forum/forum_posts.asp?TID=6595&PID=45284&SID=3a2zz67cfbfdf45b73b86987ab1d5c1e#45284

Though that could be entirely unrelated.

Robbie Williamson (robbiew) wrote :

FWIW, I noticed I was down-level on about 100 packages, including initramfs-tools and kernel. I updated, rebooted, recreated the bootable USB key, applied revision 618, and still did not experience the problem seen observed by Pete.

Steve Langasek (vorlon) wrote :

The fixed version of casper is included on today's ISOs at <http://cdimage.ubuntu.com/daily-live/current/>. ilovemistakes, S.Spillan, could you please test to confirm that these work for you?

Thomas Kottek (7tkh) wrote :

I had the same issue as described in this Bug when trying to boot a EEEPC 701 using a USB key.
I have then tried the "today's ISO" jaunty-desktop-i386.iso as Steve Langasek suggested. -> It works fine!

FriedChicken (domlyons) wrote :

Does Kubuntu need an extra fix? At least it didn't work with todays daily life (18th April).

ilovemistakes (ilovemistakes) wrote :

Today's ISO works fine for me. Bug fixed, thank you.

xourov (xourov) wrote :

I had a similar problem with 9.04rc-desktop-amd64 on Lenovo ThinkPad X200 (https://bugs.launchpad.net/ubuntu/+bug/363147). "Today's ISO", jaunty-desktop-amd64.iso suggested by Steve Langasek solved the problem. Thanks!!

Unsubscribe
------Original Message------
From: xourov
Sender: <email address hidden>
To: <email address hidden>
ReplyTo: Bug 363038
Subject: [Bug 363038] Re: casper USB media fails to boot: USB storage devicenot detected, drops to (initramfs) prompt
Sent: Apr 18, 2009 9:39 AM

I had a similar problem with 9.04rc-desktop-amd64 on Lenovo ThinkPad
X200 (https://bugs.launchpad.net/ubuntu/+bug/363147). "Today's ISO",
jaunty-desktop-amd64.iso suggested by Steve Langasek solved the problem.
Thanks!!

--
casper USB media fails to boot: USB storage device not detected, drops to (initramfs) prompt
https://bugs.launchpad.net/bugs/363038
You received this bug notification because you are a direct subscriber
of the bug.

Status in “casper” source package in Ubuntu: Fix Released
Status in “linux” source package in Ubuntu: New
Status in casper in Ubuntu Jaunty: Fix Released
Status in linux in Ubuntu Jaunty: New

Bug description:
I have Acer Aspire 5920G laptop. I've tried to run installation of Jaunty from usb flash, but failed. I've downloaded ubuntu-9.04-rc-desktop-i386.iso using 8.10, started "Create a USB Startup Disk" program and created a fresh 9.04 boot usb flash disk. When I tried to boot my laptop from this flash disk, it immediately said "Missing operating system" to console. The I booted back to my 8.10, create a VM (with virtualbox) and booted it from iso (started a live session). Successfully. I started "USB bootdisk creator" from 9.04 live session, created bootable usb disk again and rebooted by laptop. GRUB showed me language selection. I selected russian and hit the "Try Ubuntu" menu entry. "Loading, please wait..." message flashed and usplash came up. Progress bar was running left-to-right and backwards, as it was expected. But after few seconds usplash had gone, and I saw a Busybox 1.10.2's prompt (without any error messages) ending with "(initramfs)". USB flash led stopped blinking at this time. Alt+{2,3,4,5,6,7} shows empty screens.

1) I used 9.04 RC desktop cd iso
3) I expected to boot fully working 9.04 RC from USB disk.
4) It dropped me to Busybox during boot.

I can reproduce it, so I can give any useful information if somebody tells me how i can gather it.

Sent via BlackBerry by AT&T

S.Spillan (junk-apexpraxis) wrote :

The jaunty-desktop-i386.iso dated 18-Apr-2009 08:07 at http://cdimage.ubuntu.com/daily-live/current/ booted fine from usb for me.

John Ward (automail) wrote :

Another workaround for those who don't have the ability / want / time to download the daily ISO build, when the busybox prompt appears wait around 30 seconds to 1 minute and then type exit and press Enter, busybox should exit and the Ubuntu boot process will continue.

This problem could come down to you having an Intel D945 motherboard and the need for extra time in discovering S-ATA devices.

Check this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/290153

David Mandala (davidm) wrote :

I can confirm that the jaunty-desktop-i386.iso dated 18-Apr-2009 08:07 at http://cdimage.ubuntu.com/daily-live/current/ booted fine from usb for me on both my T60 and my eee PC 1000 so it appears the fix works.

Since this is fixed for the original submitter, perhaps the suspected kernel
issue should be filed separately.

--
 - mdz

Steve Langasek (vorlon) wrote :

FriedChicken,

> Does Kubuntu need an extra fix? At least it didn't work with todays
> daily life (18th April).

The kubuntu and ubuntu images are built at different times, and the kubuntu
images for the day had already been built when this fix landed. This fix
will be included in the next kubuntu images built.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

FriedChicken (domlyons) wrote :

Ok, thank you. So I guess it will work with the next daily.

wirechief (wirechief) wrote :

I downloaded the jaunty 9.04 RC from www.distrowatch.com at 3am, I tested it with a 8gb usb-stick that previously
tested ok, (reformated it fat32, made it bootable, lba) I installed using my new download and tried the stick. It failed.
I was not able to have it continue booting from the intramfs busy box with a exit some 1 min later. The boot cheat
that I had success before rootdelay=90 failed too. I had to remove the file= as I described in the bug https://bugs.launchpad.net/bugs/276822 I did not see a change in the release usb-creator 0.1.15 same version as tested
with other daily live .iso's this test being run on a AMD emachine T6420

Matt Zimmerman (mdz) wrote :

On Sun, Apr 19, 2009 at 12:06:38AM -0000, wirechief wrote:
> I downloaded the jaunty 9.04 RC from www.distrowatch.com at 3am, I tested it with a 8gb usb-stick that previously
> tested ok, (reformated it fat32, made it bootable, lba) I installed using my new download and tried the stick. It failed.
> I was not able to have it continue booting from the intramfs busy box with a exit some 1 min later. The boot cheat
> that I had success before rootdelay=90 failed too. I had to remove the file= as I described in the bug https://bugs.launchpad.net/bugs/276822 I did not see a change in the release usb-creator 0.1.15 same version as tested
> with other daily live .iso's this test being run on a AMD emachine T6420

This bug was identified and fixed after the RC was released, so the RC is
known not to work. You'll need a recent daily build instead, or wait for
the final release this week.

--
 - mdz

i got the daily build of Apr 20th, it has additional files
lupin-casper and ubiquity-casper
not sure if those are all thats needed to make this work but it is
now working with the latest
build. thanks for your work.

On Sun, Apr 19, 2009 at 7:16 AM, Matt Zimmerman <email address hidden> wrote:
> On Sun, Apr 19, 2009 at 12:06:38AM -0000, wirechief wrote:
>> I downloaded the jaunty 9.04 RC from www.distrowatch.com at 3am, I tested it with a 8gb usb-stick that previously
>> tested ok, (reformated it fat32, made it bootable, lba) I installed using my new download and tried the stick. It failed.
>> I was not able to have it continue booting from the intramfs busy box with a exit some 1 min later. The boot cheat
>> that I had success before rootdelay=90 failed too. I had to remove the file=  as I described in the bug https://bugs.launchpad.net/bugs/276822  I did not see a change in the release usb-creator 0.1.15 same version as tested
>> with other daily live .iso's  this test being run on a AMD emachine T6420
>
> This bug was identified and fixed after the RC was released, so the RC is
> known not to work.  You'll need a recent daily build instead, or wait for
> the final release this week.
>
> --
>  - mdz
>
> --
> casper USB media fails to boot: USB storage device not detected, drops to (initramfs) prompt
> https://bugs.launchpad.net/bugs/363038
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Reach out and share life, care for others,

Changed in linux (Ubuntu Jaunty):
status: New → Won't Fix

Pete's kernel issue being tracked in bug #364538

Steve Langasek (vorlon) wrote :

marking the linux task invalid, based on the redirect

Changed in linux (Ubuntu):
status: New → Invalid
mugginz (mugginz1) wrote :

I'm being dropped to a busybox prompt as well.

Kubuntu 9.04-desktop-i386

Acer Aspire One.

casper.log

/init: line 1: cannot open /dev/sda: no such file
/init: line 1: cannot open /dev/sda: no such file
/init: line 1: cannot open /dev/sda1: no such file
/init: line 1: cannot open /dev/sda2: no such file
Unable to find a medium containing a live file system

Then I put the Kubuntu 8.10 vmlinuz and initrd.gz onto /casper and it would boot, and by modding xorg.conf would even boot to a gui. Then put the 9.04 initrd.gz and vmlinuz back into /casper and the same fault appears again.

autozine (ivo-autozine) wrote :

The bug seems to be fixed. I replaced Ubuntu 9.04 RC with the final release. This version does not have this bug and boots perfectly well.

mugginz (mugginz1) wrote :

@autozine

It might be fixed for your hardware but on the Apire One it still fails.

I downloaded the iso from http://cdimage.ubuntu.com/kubuntu/daily-live/current/ about an hour ago and tried with that and still have the same failure.

Steve Langasek (vorlon) wrote :

mugginz,

please open a new bug report for your issue. This bug has been fixed.

I found the same bug in Kubuntu Desktop Lucid Beta 1 amd64

md5sum: 274da210f5ccb02773f34ea70debbfac
syn date: 2010-03-20

errror:
stdin: error 0
/init: line 7: can't open /dev/sr0: No medium found

mount: mounting /dev loop0 on //filesystem.squashfs failed: input/output error
can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs

tags: added: iso-testing
Matt Zimmerman (mdz) wrote :

Every time this has happened to me, I have (eventually) traced it to corrupt data on the installation medium.

Mount the CD (or USB stick or whatever), cd to /media/whatever, and run:

md5sum -c md5sum.txt

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers